Previous 1 2 Next 15 Replies Latest reply: Mar 19, 2013 10:13 AM by rccharles
Nina R Level 1 (10 points)

I've been browsing here for a while to try to solve my increasingly frustrating problems with Safari 5.0.6, which reached the point yesterday where I got so mad I deleted every file on my computer with the word "safari" in its name and downloaded a fresh copy, and all it would do was hang. It couldn't get to first base (the Safari/welcome page). In between, I also tried restoring an old copy from Time Machine but of course that failed too.


I was about to post a question in direct relation to all that, but decided to first create a new user, because my other browsers haven't been behaving too well either (including TenFourFox, which copes with almost everything but cannot be on Amazon more than five minutes without crashing).


I've never created a new user before. When I logged in to it, I looked down at the Dock with its giant icons, and there was Safari's, so I clicked and zoom! here I am.


I'm thinking this new user might solve a lot of problems for my poor old Power Mac G5, suffering from my hoarding tendencies which extend into the digital realm. Never-throw-anything-out-itis. True? If so I'm happy to build a new me to run this machine for a few more months until I am finally able to buy a Mini or whatever and relieve this one from Internet duty. (Of course I will NEVER throw the G5 out, LOL. I got a stack of G3 and two 7600s over here… and none of them has earned the love that the G5 has.)


Anybody got a quick tip or a handy link with instructions for selectively copying/moving/whatever applications and documents from an old user to a new one? I remember having to do this several times at my old office, and we migrated everything to the new user, and it took forever.

Power Mac G5 2.0 (late '05), two PM 7600s (bless 'em), beige G3, CDMA iPhone 4, Mac OS X (10.5.8)
  • Kappy Level 10 (265,951 points)
  • Nina R Level 1 (10 points)

    Now I'm on Facebook and it's like butter. Why didn't I do this two years ago?

  • Kappy Level 10 (265,951 points)

    Glad I could help.

  • Nina R Level 1 (10 points)

    I am puzzled by the "fast user switching" feature as described by Pondini, though. I enabled it, but I don't seem to be able to access it while logged in to the new user. Looking it up here now.

  • Kappy Level 10 (265,951 points)

    Fast User Switching enables you to have more than one user logged in at the same time on one computer and switch quickly between them without having to logout of one account an login to another account. Hence, the use of the term, "fast."

  • Nina R Level 1 (10 points)

    I understand what it's supposed to do, I just couldn't figure out how to do it once I'd enabled it because I didn't have sense enough to click on my username at the extreme right of the menu bar. I just figured that out. Old age is ****.

  • Kappy Level 10 (265,951 points)

    Unless you are over 71 you get no sympathy.

  • Nina R Level 1 (10 points)

    Well, fast user switching isn't too slick on this old box, apparently. Perhaps caused by the same problem that will not let Safari run under the original user, who knows. Certainly not me at this point. Re: Safari, I did get it running once yesterday with the original user but when I restarted, same old same old. I reinstalled, tried repeatedly, wasted gobs of time, and finally went on another rampage of deleting every Safari-related file I could find, including some that were implicated in threads here such as library/cookies/cookies.plist.


    Today I did something different: reinstalled Safari 5.0.6 under the new user, via a disk image on one of my external HDs, and I'm online with it now. Haven't tested this with the old user yet, but I imagine it will still just hang.


    At any rate, what happened with the user switching was that when I wanted to call it a night it wouldn't let me shut down because "other users are logged in and will lose data." It asked me to enter "an admin user name and password" to rectify this—but it would not recognize either login, kept saying both were invalid. I did at least manage to turn off the fast switching feature before I had to force shutdown.


    I ran Apple Jack first thing today for whatever benefit that would bring beyond the permissions repair and disk repair I'd done yesterday, and do whenever something isn't behaving right. I was hopeful the cache cleanout would help, since I don't know which of those are possible culprits that can be safely deleted. Didn't help with Safari on the old user, which was the first thing I checked (yes, I'm stubborn); as for the user switching glitch, I'll just say again… who knows. For now I'm not messing with that feature again. If anyone is aware of a specific cause of the OS failing to recognize usernames or passwords in the fast-user-switching context, please advise. Thanks.

  • rccharles Level 5 (7,581 points)

    You could switch back to the other id & log out. notice the last line. Log back in again to whatever id you were on.  shutdown.

    Picture 5.png




    It asked me to enter "an admin user name and password" to rectify this—but it would not recognize either login, kept saying both were invalid. I did at least manage to turn off the fast switching feature before I had to force shutdown.


    You need to enter an administrator id.  I use my short user id of my admin.


    here is how you find your short id.

    log on to an administrator.

    command + shift + 3 to take a picture of screen

    create picture 1.png   file 1 could be another number

    click once on file.

    command + i  for get info

    log at file ownership.


    Picture 2.png

    look at ownership & Permissions: > details > owner.


    in my case the owner is mac. the short user name is mac.

  • rccharles Level 5 (7,581 points)

    It isn't eligant, but get the job done.


    Get a multi- gig flash drive.  This avoids problems with permissions.


    copy the files you want to coy onto the flash drive


    login to the new id.  copy the files from the flash drive. 



  • Nina R Level 1 (10 points)

    Thanks. I do know the short names of both users, and I tried every possible combination. The dialog asked me to enter "an" admin username and password. It didn't say "your" (meaning me as the user who had called for shutdown) username and password. So I figured either one would work, both being admins, and when the user I was on was denied for "invalid username or password" I tried the other. I guess that could be what I did wrong, I don't know. I do know for sure I wasn't making typos or entering the wrong info all the many times I tried. And as soon as I got rid of fast user switching, the OS recognized those same users and PWs just fine. Something glitched out.

  • Kappy Level 10 (265,951 points)

    When you shutdown the OS will not until the other user is logged out. It is asking you for permission to do that. The admin password needed is your admin password, not the password of the other user(s).

  • Nina R Level 1 (10 points)

    But it wasn't recognizing my password, as the root (correct?) user and original admin. You're saying this thing has ANOTHER password for "administrators"?

  • Nina R Level 1 (10 points)

    On second thought, that can't be what you meant…  Most likely the first thing I entered was the name/password of the other user thinking that would allow me to log it out. Either that or I did make a typo in the password initially. . I'm going to assume this was one of those one-strike-you're-out permission situations and try the feature again, remembering to log the other one out before I ask the system to shut down. Thanks.

Previous 1 2 Next