12 Replies Latest reply: Apr 13, 2013 1:53 PM by dbmoore
dbmoore Level 1 Level 1 (105 points)

Ap 3.4.3 has been constantly crashing.  Ive done Repair Rebuild lib, reinstalled ap,  from CD Ap3,   reiinstalled 10.8.2 .  After all that it wants to rebuild previews so Im letting it run but it crashes while building preview.  Lib is Referenced with images on Drobo S.  Main HD is an ssd in the MBP while the lib is on the other internal HD formatted for osx journaled. Disk utilitys says internal 500g disk is ok.  I have repaired and reubuild the library many many times.  Any suggestions??????


Process:         Aperture [371]

Path:            /Applications/Aperture.app/Contents/MacOS/Aperture

Identifier:      com.apple.Aperture

Version:         3.4.3 (3.4.3)

Build Info:      Aperture-310022000000000~1

Code Type:       X86-64 (Native)

Parent Process:  launchd [152]

User ID:         501


Date/Time:       2013-03-13 17:37:34.074 -0700

OS Version:      Mac OS X 10.8.2 (12C60)

Report Version:  10


Interval Since Last Report:          219506 sec

Per-App Interval Since Last Report:  110199 sec

Anonymous UUID:                      C71C4B30-7E65-B442-AAC8-B87788846A44


Crashed Thread:  18  Dispatch queue: com.apple.photoapps.version



Exception Codes: EXC_I386_GPFLT


Application Specific Information:

objc_msgSend() selector name: retain



Thread 0:: Dispatch queue: com.apple.main-thread

0   libsystem_kernel.dylib                  0x00007fff86e7e686 mach_msg_trap + 10

1   libsystem_kernel.dylib                  0x00007fff86e7dc42 mach_msg + 70

2   com.apple.CoreFoundation                0x00007fff8e027803 __CFRunLoopServiceMachPort + 195

3   com.apple.CoreFoundation                0x00007fff8e02cee6 __CFRunLoopRun + 1078

4   com.apple.CoreFoundation                0x00007fff8e02c6b2 CFRunLoopRunSpecific + 290

5   com.apple.HIToolbox                     0x00007fff83f030a4 RunCurrentEventLoopInMode + 209

6   com.apple.HIToolbox                     0x00007fff83f02e42 ReceiveNextEventCommon + 356

7   com.apple.HIToolbox                     0x00007fff83f02cd3 BlockUntilNextEventMatchingListInMode + 62

8   com.apple.AppKit                        0x00007fff8237a613 _DPSNextEvent + 685

9   com.apple.AppKit                        0x00007fff82379ed2 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128

10  com.apple.Aperture                      0x00000001101d2205 0x10fd5c000 + 4678149

11  com.apple.AppKit                        0x00007fff82371283 -[NSApplication run] + 517

12  com.apple.prokit                        0x0000000111282324 NSProApplicationMain + 378

13  com.apple.Aperture                      0x000000010fd6c4a2 0x10fd5c000 + 66722

14  com.apple.Aperture                      0x000000010fd6bdf4 0x10fd5c000 + 65012


Thread 1:: Dispatch queue: com.apple.libdispatch-manager

0   libsystem_kernel.dylib                  0x00007fff86e80d16 kevent + 10

1   libdispatch.dylib                       0x00007fff83ccbdea _dispatch_mgr_invoke + 883

2   libdispatch.dylib                       0x00007fff83ccb9ee _dispatch_mgr_thread + 54


Thread 2:

0   libsystem_kernel.dylib                  0x00007fff86e7e6c2 semaphore_wait_trap + 10

1   libdispatch.dylib                       0x00007fff83ccdc32 _dispatch_thread_semaphore_wait + 16

2   libdispatch.dylib                       0x00007fff83cce424 _dispatch_sync_f_slow + 140

3   com.apple.RedRock                       0x00000001107807e5 -[RKVersion(Imaging) imageProxyState] + 150

4   com.apple.RedRock                       0x000000011096dde1 -[RKImageCache renderThumbnailForVersionAddress:force:workOrder:] + 778

5   com.apple.RedRock                       0x000000011096e972 -[RKImageCache renderThumbnailsForVersionAddressHandler:] + 154

6   com.apple.proxtcore                     0x0000000111f58f7c -[XTList makeObjectsPerformSelector:withObject:] + 59

7   com.apple.proxtcore                     0x0000000111f58b3a -[XTDistributor distributeMessage:] + 480

8   com.apple.proxtcore                     0x0000000111f584d9 -[XTThread handleMessage:] + 342

9   com.apple.proxtcore                     0x0000000111f57292 -[XTThread run:] + 345

10  com.apple.Foundation                    0x00007fff8af57612 __NSThread__main__ + 1345

11  libsystem_c.dylib                       0x00007fff8ae09742 _pthread_start + 327

12  libsystem_c.dylib                       0x00007fff8adf6181 thread_start + 13

Aperture 3, OS X Mountain Lion (10.8.2), AP 3.4.3 2009MBP 8GB ram int ssd
  • Frank Caggiano Level 7 Level 7 (25,715 points)

    Open Aperture while holding down the shift key. This will force Aperture to skip preview generation. If Aperture runs it means you have a corrupted image in the library.


    Post back the results and we'll take if from there,

  • dbmoore Level 1 Level 1 (105 points)

    Thanks Frank.  I was hoping it was simplar than that ...like a driver problem or some rogue plist file of imagecapture.  Ive tried everything else so I guess I have nothing to loss except time and start figuring out which image.  Probably something with a mask in channels from PS to make a knockout would be my first guess.  Ill let you know.  Any other ideas out there?????  Cheers

  • Frank Caggiano Level 7 Level 7 (25,715 points)

    So did Aperture start and run ok when started with the shift key held?

  • dbmoore Level 1 Level 1 (105 points)

    Yes I can open the library by using the shift key or just open it and turn off the process of building thumbnails.  Sorry I should of mentioned that.  Im now looking for paths or extra channels, in PS, in certain product jobs Ive had.  Found some but have a long way to go.  Not sure why it would work for a while and then just quit... probalble a rebuild of the datatbase set it off again.  Ill mark the problemed solved in a week once Im back up and fully running.  Thanks again   DBM

  • léonie Level 10 Level 10 (81,710 points)

    Lib is Referenced with images on Drobo S. 

    How is your "Drobo S. " formatted? Preview generation can also fail, if the filename has a corruption, not only if the media part of an image has corrupted data. If your Drobo is not MacOS Extended you may have copied a filename that MacOS X cannot deal with, or one of your image filenames may contain invisible characters. So, in addition to Frank's advice, I'd suggest also to screen the filenames, not only "Probably something with a mask in channels from PS". And frequently it is a video that was imported together with the image files, that is causing the preview generation to crash.


    One way to search would be to turn on the Activity Window (Window > Show Activity) and to select your most recent imports in the Browser, then use the command "Photos > Update Previews". The Activity window will show you the filename of the currently processed image. Look, if Aperture is unusally slow on some images.

    • If it crashes, you will know that the culprit is among the currently processed set.
    • Then use Frank's "Divide and Conquer" strategy - I do not find a link to his post, where he described the method first. But the general idea is to split the set of the suspect images into halves:
      • Try to build previews for half of the suspect images. If it succedes, you'll know these images are o.k. If it does not succeed, even better. The culprit is within the batch you just processed.
      • Split the set again, and keep subdividing the part that makes Aperture crash.
      • By systematically splitting and testing partial sets of images you can test 1000000 images by only splitting the set of images to be tested twenty times. So it is not really hopeless, it only requires keeping track of images already tested. Having two albums "Images to be tested" and "Images already tested and ok" may help. If the images is among your most recently media and you only have to test 500 images or so, you should be done with 9 splits and tests.


    Good luck.


  • dbmoore Level 1 Level 1 (105 points)

    Thanks Frank and Leonie.  I have a correction to make an appologies for the confusion.  The Title to the problem is correct but in the dscription I wronglysaid Previews.  I have Previews set to never in AP preference.  AP is trying to rebuild the Thumbnails even though I can see them while using AP.  If I cancel the Process of rebuilding Thumbnails I can use AP just fine.   So if you havent thrown your hands up in frustration and still willing to help  Im here humbley listening.  dbm

  • Frank Caggiano Level 7 Level 7 (25,715 points)

    Pretty much everything still holds.


    It appears you have a corruption (either in the file data or filename) in the library.


    Setting Previews to never in the Preferences only keeps Aperture from generating previews in new projects. It says nothing about what happens with projects already in existence.


    If that preferences was ever set to generate previews then the projects that were made at that time are still generating previews.

  • dbmoore Level 1 Level 1 (105 points)

    Frank it seems strange that when I select a whole month of images to generat a new thumbnail,  the activity process window shows prevews being built and not thumbnails.  Guess I can go back and delete previews to keep the lib small.  The only time I see thumbnails being built is when I first open AP it starts at 80k of images but not from oldest to newest,  just random.  My hope was to rebuild thumbnails only in ordered sections with out previews being built.  Thanks for your help really appreciate it.  One other question ....  I know that AP dosent like masks saved as channels but How does AP like paths built for knockouts.  I think it the extra channel built in PS is  what gives AP a problem and not the Path.  But If its Paths then I need to delete those as well I guess.  Thanks for your help really appreciate it.

  • léonie Level 10 Level 10 (81,710 points)
    I think it the extra channel built in PS is  what gives AP a problem and not the Path.  But If its Paths then I need to delete those as well I guess.  Thanks for your help really appreciate it.


    I would test that by importing a Photoshop image with paths into a new Aperture library, created just for testing. Use "File > Switch to lIbrary > Other/new" to create test library and import one single image. Then you will see, what Aperture can handle.


    Aperture should be able to import tiffs and psd files with layers and alpha channel, only it does not promise to be able to edit them and to create correct thumbnails or previews.

  • dbmoore Level 1 Level 1 (105 points)

    Leonie!   the Drobo S is a NAS with its own format I believe.  Pretty sure its not OsX Journaled.  I had a similar problem years ago with masks saved as a channel and AP would not be able to create a correct thumbnail.  I could easily go through my catelog and see the files that were coruputed.  Now all thumbnails are correct so very hard to see where the problem is.  I will divide and concur the lib after I check out the jobs that I know I have paths and masks in.   Thank you for your thoughts.  David

  • dbmoore Level 1 Level 1 (105 points)

    Update:  Been watching the pie Chart in Activity monitor while using AP and while using PS both togather and separately.  Seems to me the Inactive Ram (blue) does not give up ram to the program that needs it.  When it gets close to NO free space the page outs occure even if I have 3.8gb inactive ram available.   When the pageouts occure I then get the original problem that when closing AP I get the Updating Lib message and have to wait 20 min for it to finish. The Thumbnail process may be heavey on ram due to the Drobo, still thinking about that. But I think there is something wrong if I have close to 4 gb inactive ram and still Page Out.   So I think its time to Nuke this old 2009 MBP and start fresh.....or buy a new imac...    Preparing to Nuke in between jobs.


    Frank and Leonie  thank you for your time Ill let you know.

  • dbmoore Level 1 Level 1 (105 points)

    Update:  Ive separated all five years of projects by year and have found a few previews that were bad  and some missing images.  Now my most current Lib is 2013 and crashed importing some images.  Crashed Thread 0 then restaarted and imported fine. 


    Process:         Aperture [252]

    Path:            /Applications/Aperture.app/Contents/MacOS/Aperture

    Identifier:      com.apple.Aperture

    Version:         3.4.3 (3.4.3)

    Build Info:      Aperture-310022000000000~1

    Code Type:       X86-64 (Native)

    Parent Process:  launchd [155]

    User ID:         501



    Date/Time:       2013-04-13 13:23:42.949 -0700

    OS Version:      Mac OS X 10.8.3 (12D78)

    Report Version:  10



    Crashed Thread:  0  Dispatch queue: com.apple.main-thread



    Exception Type:  EXC_BAD_ACCESS (SIGSEGV)

    Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000023



    VM Regions Near 0x23:


        __TEXT                 000000010029e000-00000001009f4000 [ 7512K] r-x/rwx SM=COW  /Applications/Aperture.app/Contents/MacOS/Aperture



    Thread 0 Crashed:: Dispatch queue: com.apple.main-thread

    0   libobjc.A.dylib                         0x0000000104a984d8 objc_msgSend_vtable4 + 24

    1   com.apple.iLifeSQLAccess                0x00000001042244f7 -[HgModel isEqual:] + 67

    2   com.apple.Aperture                      0x000000010052be54 0x10029e000 + 2678356

    3   com.apple.Aperture                      0x00000001005276f6 0x10029e000 + 2660086

    4   com.apple.Aperture                      0x000000010051e91e 0x10029e000 + 2623774

    5   libdispatch.dylib                       0x000000010788ff01 _dispatch_call_block_and_release + 15

    6   libdispatch.dylib                       0x000000010788c0b6 _dispatch_client_callout + 8

    7   libdispatch.dylib                       0x00000001078910c8 _dispatch_main_queue_callback_4CF + 275

    8   com.apple.CoreFoundation                0x0000000102505b4c __CFRunLoopRun + 1644

    9   com.apple.CoreFoundation                0x00000001025050e2 CFRunLoopRunSpecific + 290

    10  com.apple.HIToolbox                     0x000000010662deb4 RunCurrentEventLoopInMode + 209

    11  com.apple.HIToolbox                     0x000000010662dc52 ReceiveNextEventCommon + 356

    12  com.apple.HIToolbox                     0x000000010662dae3 BlockUntilNextEventMatchingListInMode + 62

    13  com.apple.AppKit                        0x0000000105144563 _DPSNextEvent + 685

    14  com.apple.AppKit                        0x0000000105143e22 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128

    15  com.apple.Aperture                      0x0000000100714205 0x10029e000 + 4678149

    16  com.apple.AppKit                        0x000000010513b1d3 -[NSApplication run] + 517

    17  com.apple.prokit                        0x0000000102e156c5 NSProApplicationMain + 378

    18  com.apple.Aperture                      0x00000001002ae4a2 0x10029e000 + 66722

    19  com.apple.Aperture                      0x00000001002addf4 0x10029e000 + 65012



    Thread 1:: Dispatch queue: com.apple.libdispatch-manager

    0   libsystem_kernel.dylib                  0x0000000107aa6d16 kevent + 10

    1   libdispatch.dylib                       0x000000010788edea _dispatch_mgr_invoke + 883

    2   libdispatch.dylib                       0x000000010788e9ee _dispatch_mgr_thread + 54



    Thread 2:

    0   libsystem_kernel.dylib                  0x0000000107aa60fa __psynch_cvwait + 10

    1   libsystem_c.dylib                       0x0000000107935023 _pthread_cond_wait + 927

    2   com.apple.Foundation                    0x00000001045cffe3 -[NSCondition waitUntilDate:] + 357

    3   com.apple.Foundation                    0x00000001045cfe39 -[NSConditionLock lockWhenCondition:beforeDate:] + 235

    4   com.apple.proxtcore                     0x000000010410003a -[XTMsgQueue waitForMessage] + 47

    5   com.apple.proxtcore                     0x00000001040ff282 -[XTThread run:] + 329

    6   com.apple.Foundation                    0x00000001045a4cd2 __NSThread__main__ + 1345

    7   libsystem_c.dylib                       0x00000001079307a2 _pthread_start + 327

    8   libsystem_c.dylib                       0x000000010791d1e1 thread_start + 13



    Thread 23:

    0   libsystem_kernel.dylib                  0x0000000107aa66d6 __workq_kernreturn + 10

    1   libsystem_c.dylib                       0x0000000107932f4c _pthread_workq_return + 25

    2   libsystem_c.dylib                       0x0000000107932d13 _pthread_wqthread + 412

    3   libsystem_c.dylib                       0x000000010791d1d1 start_wqthread + 13



    Thread 0 crashed with X86 Thread State (64-bit):

      rax: 0x0000000000000003  rbx: 0x0000000000000002  rcx: 0x00007fff5f960201  rdx: 0x000000010430fa18

      rdi: 0x00007f9c6f8de600  rsi: 0x00007f9c68400260  rbp: 0x00007fff5f960340  rsp: 0x00007fff5f960318

       r8: 0x0000000000012068   r9: 0x00007fff5f9602a0  r10: 0x00000001197fc800  r11: 0x00007f9c68c32e98

      r12: 0x0000000000000036  r13: 0x0000000104a97240  r14: 0x00007f9c6b278f10  r15: 0x00007f9c6f8de600

      rip: 0x0000000104a984d8  rfl: 0x0000000000010246  cr2: 0x0000000000000023

    Logical CPU: 0



    Binary Images:

           0x10029e000 -        0x1009f3fff  com.apple.Aperture (3.4.3 - 3.4.3) <01A802BA-0100-3F80-947C-A8FEA4726352> /Applications/Aperture.app/Contents/MacOS/Aperture

           0x100c15000 -        0x100c1eff7  com.apple.PhotoFoundation (1.0 - 10.17) <C7921155-5546-33EF-8846-B86721EBA1C4> /Applications/Aperture.app/Contents/Frameworks/PhotoFoundation.framework/Versio ns/A/PhotoFoundation

           0x100c9a000 -        0x1011bafff  com.apple.RedRock (1.9.4 - 310.33) <9B94495A-2267-3684-B6E8-9FE3D4B46495> /Applications/Aperture.app/Contents/Frameworks/RedRock.framework/Versions/A/Red Rock

           0x1014c0000 -        0x101543fff  com.apple.iLifePageLayoutCore (1.0 - 200.9) <8AAC1EB9-5823-3624-A525-635C2A77C34E> /Applications/Aperture.app/Contents/Frameworks/iLifePageLayoutCore.framework/Ve rsions/A/iLifePageLayoutCore

           0x1015a1000 -        0x1015a1fff  com.apple.Cocoa (6.7 - 19) <1F77945C-F37A-3171-B22E-F7AB0FCBB4D4> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa

           0x1015a9000 -        0x1015a9fff  com.apple.Carbon (154 - 155) <372716D2-6FA1-3611-8501-3DD1D4A6E8C8> /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon

           0x1015ad000 -        0x10182dff7  com.apple.AOSKit (1.05 - 152.2) <43361229-45F3-3946-A11A-CC0FF2129F06> /System/Library/PrivateFrameworks/AOSKit.framework/Versions/A/AOSKit

           0x101859000 -        0x10185efff  com.apple.iLifePhotoStreamConfiguration (3.4 - 2.5) <906317D7-09FF-3B77-8F35-01BB74C0109C> /Applications/Aperture.app/Contents/Frameworks/iLifePhotoStreamConfiguration.fr amework/Versions/A/iLifePhotoStreamConfiguration

           0x10186c000 -        0x10189dff7  com.apple.iLifeAssetManagement (2.7 - 40.34) <E4E1A39C-E8AE-31D5-9C50-B392EBAD7447> /Applications/Aperture.app/Contents/Frameworks/iLifeAssetManagement.framework/V ersions/A/iLifeAssetManagement

           0x1018cd000 -        0x1018daff7  com.apple.iphoto.AccountConfigurationPlugin (1.2 - 1.2) <0F515DED-D77E-3E4F-876D-F5CE596A844C> /Applications/Aperture.app/Contents/Frameworks/AccountConfigurationPlugin.frame work/Versions/A/AccountConfigurationPlugin

           0x1018ed000 -        0x101990ff7  com.apple.MobileMe (13 - 1.0.4) <8A990383-9B6C-3CF4-826E-D61373653AB2> /Applications/Aperture.app/Contents/Frameworks/MobileMe.framework/Versions/A/Mo bileMe

           0x101a0c000 -        0x101a0cfff  com.apple.ApplicationServices (45 - 45) <A3ABF20B-ED3A-32B5-830E-B37831A45A80> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Application Services

           0x101a13000 -        0x101b9eff7  com.apple.WebKit (8536 - 8536.28.10) <792FA1F3-68F2-36F8-A070-898B3682F5DE> /System/Library/Frameworks/WebKit.framework/Versions/A/WebKit

           0x101c96000 -        0x101f67ff7  com.apple.security (7.0 - 55179.11) <73958084-5BBC-3597-A751-7370B0C247E5> /System/Library/Frameworks/Security.framework/Versions/A/Security

           0x10209c000 -        0x10210afff  com.apple.framework.IOKit (2.0.1 - 755.22.5) <1547DA6F-9793-30A2-8E92-7368DE84D46C> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit

           0x10213a000 -        0x1022e8fff  com.apple.QuartzCore (1.8 - 304.2) <234EABE1-067C-3DAE-BEAC-674526E232C2> /System/Library/Frameworks/QuartzCore.framework/Versions/A/QuartzCore

           0x1023a5000 -        0x1023b4fff  com.apple.opengl (1.8.7 - 1.8.7) <26F7FF79-6BB2-3968-B70D-71D4E07C9551> /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL

           0x1023c3000 -        0x102460ff7  com.apple.PDFKit (2.7.3 - 2.7.3) <5AE5FD4E-658F-38BC-90DD-C2B28E17ED34> /System/Library/Frameworks/Quartz.framework/Versions/A/Frameworks/PDFKit.framew ork/Versions/A/PDFKit

           0x1024cb000 -        0x1024cbfff  com.apple.CoreServices (57 - 57) <9DD44CB0-C644-35C3-8F57-0B41B3EC147D> /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices

           0x1024d0000 -        0x1026baff7  com.apple.CoreFoundation (6.8 - 744.18) <A60C3C9B-3764-3291-844C-C487ACF77C2C> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation

           0x10281e000 -        0x10286fff7  com.apple.SystemConfiguration (1.12.2 - 1.12.2) <A4341BBD-A330-3A57-8891-E9C1A286A72D> /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfi guration

           0x10289f000 -        0x10289ffff  com.apple.Accelerate (1.8 - Accelerate 1.8) <6AD48543-0864-3D40-80CE-01F184F24B45> /System/Library/Frameworks/Accelerate.framework/Versions/A/Accelerate

           0x1028a3000 -        0x1028a9fff  com.apple.DiskArbitration (2.5.2 - 2.5.2) <C713A35A-360E-36CE-AC0A-25C86A3F50CA> /System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration

           0x1028b5000 -        0x1028c2ff7  com.apple.PluginManager (1.7.6 - 55) <9C4EFFC0-1CDC-360B-9294-57E710B2912A> /Library/Frameworks/PluginManager.framework/Versions/B/PluginManager

           0x1028d5000 -        0x1028d5fff  com.apple.quartzframework (1.5 - 1.5) <6403C982-0D45-37EE-A0F0-0EF8BCFEF440> /System/Library/Frameworks/Quartz.framework/Versions/A/Quartz

           0x1028df000 -        0x102a50ff7  com.apple.QTKit (7.7.1 - 2599.24) <A2153722-268B-3293-B9E3-CB59273CDE41> /System/Library/Frameworks/QTKit.framework/Versions/A/QTKit

           0x102b5a000 -        0x102cabfff  com.apple.audio.toolbox.AudioToolbox (1.8 - 1.8) <C680EE1A-B4ED-3E77-A08C-DC47922ACA33> /System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox

           0x102d3a000 -        0x102d3affd  com.apple.audio.units.AudioUnit (1.8 - 1.8) <173346B7-614C-380B-8E80-9BD1BE501674> /System/Library/Frameworks/AudioUnit.framework/Versions/A/AudioUnit

           0x102d41000 -        0x102d9eff7  com.apple.audio.CoreAudio (4.1.1 - 4.1.1) <D15F3FB3-BE53-3545-AD37-9A25A597FE3C> /System/Library/Frameworks/CoreAudio.framework/Versions/A/CoreAudio

           0x102dc7000 -        0x102dd8fff  com.apple.AERegistration (1.2 - 401) <16C4537B-4989-3DF7-8263-588F5C882063> /Applications/Aperture.app/Contents/Frameworks/AERegistration.framework/Version s/A/AERegistration

           0x102df7000 -        0x10306dff7  com.apple.prokit (7.3.2 - 1944.10) <41FA1781-64AA-37C2-8CBF-9D72CFD705C0> /System/Library/PrivateFrameworks/ProKit.framework/Versions/A/ProKit

           0x10320b000 -        0x1035affff  com.apple.iLifeSlideshow (3.1 - 1151.4) <61A831CA-B996-3762-B3DD-85A3CB46F28D> /Applications/Aperture.app/Contents/Frameworks/iLifeSlideshow.framework/Version s/A/iLifeSlideshow

           0x103733000 -        0x1039f6ff7  com.apple.AddressBook.framework (7.1 - 1169) <5FFF3765-414A-3633-ADE5-337CD4B9A102> /System/Library/Frameworks/AddressBook.framework/Versions/A/AddressBook

           0x103c4c000 -        0x103c63ff7  com.apple.iLifeFaceRe


    So Im thinking that even though I have reciently reintalled AP and OSX mt lion   I need to do it again?

    Unless you see anyting in the above?  Guess Ill build a new account and see if that improves stability.


    Thanks for input!!!!