7 Replies Latest reply: Mar 22, 2013 10:23 AM by ededwa Branched to a new discussion.
ededwa Level 1 Level 1 (0 points)

I followed all directions above and nothing changed in iPhoto.  My thumbnails are still blank and when I click on them I still get a burry circle with an exclamation point in the middle.  I don't know what I'm doing wrong.  I'd appreciate any advice!


MacBook Pro, Mac OS X (10.5.8)
  • Old Toad Level 10 Level 10 (126,120 points)

    Which directions above what?  Evidently you were in another topic.  Why not respond in it rather than in a new topic where all the background material is missing?

     

    Or if you were just reading the other topic you need to provide us with relavant information like which verision of system and iPhoto you're using, what your problem is and when started, what you've already tried to do to fix it, etc. Otherwise will have to use THIS to try to help you.

     

    OT

  • ededwa Level 1 Level 1 (0 points)

    I followed directions from this article, which is listed above and which should explain all issues I'm facing: 

    iPhoto 6 and later: Rebuilding the iPhoto library

     

    I simply went to the bottom of the article to post a question, and this is where it led me, so I am obviously posting the question in the only place that I'm aware of doing so, which I find relevant (not "relavant")

     

    My system information is clearly written in my question:  Macbook Pro, with OS X version 10.5.8.  I'm using iPhoto '08. 

     

    If you don't care to read all of my information but instead want to criticize me for not giving enough, please don't reply to the question.

  • Old Toad Level 10 Level 10 (126,120 points)

    I don't rely on the profile as so many of them  are old and not updated.  Asking up front saves a lot of time and back and fourth posting trying to get the right information. We need the correct information so we can provide a fix that was relevent to the version in question.

     

    Using iPhoto Library Manager  to Rebuild Your iPhoto Library

     

      1. Download iPhoto Library Manager and launch.
      2. Click on the Add Library button,

        iPhoto Library Manager002.jpg 

        navigate to your Home/Pictures folder and select your iPhoto Library folder.

      3. Now that the library is listed in the left hand pane of iPLM, click on your library and go to the Library ➙ Rebuild Library menu option

        iPhoto Library Manager001.jpg

      4. In the next  window name the new library and select the location you want it to be placed.
      5. Click on the Create button.

     

    Note: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments. However, books, calendars, cards and slideshows will be lost.

     

    Note:  your current library will be left untouched for further attempts at a fix if so desired.

     

    If that fails give this a go:

     

    Starting over from scratch with new library

     

    Start over with a new library and import the Originals (iPhoto 09 and earlier) or the Masters (iPhoto 11) folder from your original library as follows:

     

    1. Open the library folder.

     

    2. Launch iPhoto with the Option key held down and, when asked, select the option to create a new library.

     

    3. Drag the subfolders from the Originals folder into the open iPhoto window a few at a time.

     

    iPhotolibcontents.PNG

     

     

    This will create a new library with the same Events as the original library but will not keep the metadata, albums, books slideshows and other projects.

     

    Note:  your current library will be left untouched for further attempts at a fix if so desired.

  • ededwa Level 1 Level 1 (0 points)

    Thanks for trying, but your first suggestion requires that I have a newer operating system, and your second suggestion led to me having another library with the exact same problems:  blank thumbnails that, when clicked on, appear as blurry circles with exclamation points in the middle.

  • Terence Devlin Level 10 Level 10 (133,295 points)

    Go to the FatCat Software site again. You can download older versions of iPhoto Library Manager there that will run on your system.

     

    If the second suggestion produced the same result then you've either a: done it wrong or b: you're opening the wrong library. In iPhoto 08 clicking on a library will not open it, only open the most recently used one. To select a library in 08:  Hold down the option (or alt) key key and launch iPhoto. From the resulting menu select 'Choose Library'

  • ededwa Level 1 Level 1 (0 points)

    I neither a. did it wrong or b. opened the wrong library.  Your snide, patronizing, and presumptious advide did not help in the least.

  • LarryHN Level 9 Level 9 (64,895 points)

    WOW - for someone requesting help from strangers who are strictly volenteers you have quiet an attitude

     

    Given that your posts do not make sense and you prefer to get nasty rather than answser simple questions so that someone can provide assistance as far as I am concerned you are on your own - good luck

     

    The only Snide comments here are yours

     

    Have a great day

     

    LN

     

    PS - Given the totallity of little information in yoru posts the most likely reason for your problem is user error and the most likely solution is to restore your backup from before you messed up