2 Replies Latest reply: Mar 29, 2013 5:11 PM by Vampryss
Henry Greisman Level 1 Level 1 (5 points)



Could use some help understanding what's happening with my iCal, iCloud, and meeting invites. At the moment, people are complaining that they are not receiving my meeting invites at all.


I have a MacBook Air running 10.8.2 with iCal, Address Book and Apple Mail, plus other applications. I also have an iPhone 5

iCloud is set for Address Book and iCal

I have 4 email accounts which are recorded in my personal Address Book entry, with the desired email account set as the default.


I do not use the iCloud applications at all. I work from my Mac and that's where I initiate the meeting invites.


It's important for me to be able to send invites from the correct email account, as that can change based on the work I am doing. It's also important that my iPhone and iCal are synchronized.


I see a lot of threads on this topic, but don't see any resolution which deals with my issue. If I need to disable iCloud, and go back to synchronizing the Mac and iPhone, I am prepared to do that.




Thanks, Henry

OS X Mountain Lion (10.8.2)
  • Vampryss Level 1 Level 1 (0 points)

    I too have this issue. I need to send iCal invites FROM both my work email address and personal. How can this be resolved?


    I have an iPhone 5 and iPad 4. I stay mobile and need work and personal separate. I shouldn't have to use 3rd party apps to get this result.

  • Csound1 Level 8 Level 8 (44,285 points)

    I issue invitations from iCloud (using iCloud mail) all the time, they work fine. Make a new user account, login to it and test.

  • Vampryss Level 1 Level 1 (0 points)

    Using iCloud email isn't the issue.


    The issue is I have a personal calendar and a work calendar. When I send appointment invites from my work calendar they send from my default personal email address. Not my work email address. There should be an option to choose what email address these invites are coming from without having to create new accounts, or change the default settings each time I use the calendar. I'm shocked that this is isn't just a standard option. I'm a mobile user 100%, I don't have the time to edit settings for something that shouldn't be an issue in the first place.

  • Csound1 Level 8 Level 8 (44,285 points)

    Don't see a way to that, it is derived from the default set in Mail.