1 Reply Latest reply: Mar 14, 2013 5:51 PM by Niel
delanieefoxx Level 1 Level 1 (0 points)

my compter is basically not compatible with anything because its on the old Leopard operating system. so i was wondering how i got my 2008 MacBook to the latest operating system ?


MacBook, Mac OS X (10.5.8)