Previous 1 2 3 Next 89 Replies Latest reply: Mar 23, 2014 7:36 PM by AndrewC1970
Steve Howells Level 1 (0 points)

Just tried to install Windows using Boot Camp on the new 3TB supporting version.


It hung at the partitioning stage, and I was left with a messed up Disk Image and about 1.2TB less disk space than I had before. I tried a full restore via Recovery Assistant, but now Disk Utility seems to think I only have a 2TB disk.


I went back in to Recovery Assistant to try a reinstall, and it again showed Macintosh HD as a 2TB volume, so doesn't look like that will solve the problem either.


Any ideas? I'm outside of my 90 days tech support so thought I'd ask here before paying for a call.

iMac (27-inch, Late 2012), OS X Mountain Lion (10.8.3)
  • mende1 Level 10 (92,171 points)

    First of all, I doubt that the space has disappeared. Probably, Boot Camp resized your OS X partition but didn't create the Windows partition, so you have that "lost" space. To recover it, follow these steps:


    1. Open Disk Utility and select the hard disk at the top of the sidebar.


    2. Go to Partitions tab and you will see a bar similar to this:


    Captura de pantalla 2013-03-15 a la(s) 17.24.53.png


    3. As you can see, at the bottom right of "Macintosh HD" volume, you can select it, so put the cursor on it and drag it to the bottom of the sidebar. Finally, press Apply, and you will recover your lost space

  • Steve Howells Level 1 (0 points)

    Yeah, it's not selectable for me right now. There's something weird going on where the Mac HD Logical Volume Group says it's 2TB used and 1TB free, but my partition map is showing only one 3TB partition.


    I think I may have been looking at the Mac HD Logical Partition rather than the Logical Volume Group when I was last in Recovery Assistant, so I'm going to boot back in to that and try some more Verify/Repair cycles (and also see if it shows me a different partition map there).


    Thanks for the suggestions!

  • mende1 Level 10 (92,171 points)

    Have you verified if Fusion Drive is OK? Open Disk Utility, select the second "Macintosh HD" on the sidebar and verify the disk. I have seen that problem before

  • Steve Howells Level 1 (0 points)

    Both the first and second Macintosh HDs verify with no errors.


    As my partition table seems to be messed up somehow, I'm now trying to create a second partition in the hope that will straighten things out. This is now sitting at "Resizing Core Storage Physical Volume Structures" and has been for five minutes or so. Given the problems I'm already having I suspect I'll just have to wait this one out, unless it sticks there for several hours!

  • Steve Howells Level 1 (0 points)

    Changing the partition size didn't do the trick - was still a 2TB volume in a 3TB partition when I was done.


    My next approach was to erase the volume and rebuild it, which seems to have done the trick. Currently restoring from Time Machine so will know for certain in a couple of hours. I have to say, Time Machine is just about my favourite OS X feature at this point - love being able to roll back so simply and (over USB3) quickly.

  • stevefromcambridge Level 1 (5 points)



    I'm having the exact same problem you have on my 27" iMac  and have tried everything except erasting the volume, rebuilding and restoring fom Time machine ... plese keep us posted on how that works for you!




  • Steve Howells Level 1 (0 points)

    It worked perfectly - the only thing was the "Resizing Core Storage Physical Volume Structures" stage in Disk Utility took literally an hour. Which makes me suspect that Boot Camp Asssistant was actually working fine when I did it and I just didn't give it long enough. Just not used to anything taking that long on the new iMac.

  • stevefromcambridge Level 1 (5 points)

    Phew.  Just did the erase and full recovery as well, and everything is back to the was it ws before .. with a drive that correctly shows as 3tb.  In my case the erase went quickly, and restoring form time machine took ~4 hrs.


    Now the big question is dare we try to create a BootCamp partition again, or should we wait for an update?  Several other threads are cropping up on the Apple support pages, so we are definitely not alone with this issue. 

  • group8productions Level 1 (0 points)

    Hey everyone, I did find a solution for our iMac, which is the new 27" 3TB fusion drive.


    I did a full Time Machine backup, then booted holding down CMD-R to boot into recovery mode.  Made sure I had an ethernet connection for fast internet, and then went into disk utility, erased the hard drive, then went back to the main menu and did a re-install of Mountain Lion.


    Then I did ONLY the Apple updates to 10.8.3, then ran Boot Camp Assistant and the install went off without a hitch.  Once I confirmed that Windows 7 was running perfectly, I went back into the Mac OS, opened up Migration Assistant (in the utilities folder) and migrated my Time Machine backup back on to the hard drive.


    Now both work great.  The whole process took about 6 hours.  I actually moved the iMac into the living room so I could watch t.v. while I did it.  Made the process a lot more fun when you're realxing with some good movies and clicking a few buttons now and again.  :-)


    Hope that helps!

  • Steve Howells Level 1 (0 points)

    I tried again this morning. The initial partitioning took just over one hour, so I think that first time around I did just hit abort too quickly.


    However - Windows failed to install. In the Windows installer screen I had the best part of a dozen partitions showing, and BOOTCAMP was on Disk 1 Partition 4. It formatted OK, but I got an error saying Windows couldn't install to it.


    I may well try Daniel's suggestion next.

  • tonyep Level 1 (0 points)

    Had the same problem with mine but when I verify using disk utilities, a error came up and it tells me to repair the disk. Ran repair disk and it did not solved the problem and it did not allow me to install a clean version of OS X. Dropped off my iMac at the genius bar on saturday. They ran checks on the fusion drive and everything appears good yet still unable to install OS X. The guy at genius bar had no idea what's wrong with it.

  • Didier D.D.A Level 1 (0 points)

    I actually experienced the same thing (lost 931Gb after bootcamp hung while partitioning and had to quit).


    The way I solved it was to boot into recovery mode and run disk utility, then repair the Macintosh HDD. I did ran it from the OS previously, it would detect the discrepancy, but would not repair it.


    Hope this will help, but I am indeed "very angry"* at Apple for issuing a OSX 10.8.3 with bootcamp support on HDD greater than 3TB... and I see that a lot of people are having issues.


    By the way, in the process of trying to chose the size of my win7 partition, if you have "too little space" (in my case "only" 667Gb left (does not seem so small to me)) then bootcamp would allow me to have a 20GB partition only, and if I tried to increase it, then the slider would show "-153GB" (yes - read "minus")... bug? Naaaa not possible. ;-)

    Anyway, I had to free up some space in order to regain the ability to partition a 100GB for WIndows (which did not work - see above)


    Hope the first part of the post will help my fellow Bootcamp users with 3TB fusion drive.


    * seems like the bot or moderator does not allow being explicit ;-)

  • Turnip579 Level 1 (15 points)

    I have a new 27inch with the 3TB Fusion drive. In your opinion, how much space should I allow for Windows 7. I would like to game a bit also if possible.

  • Turnip579 Level 1 (15 points)

    Thank you Daniel. This is pretty much what APPLE just told me to do, albeit with the migration part. I have a new system and not much on it yet. They feel there may be some Bootcamp files that didn't make it into the system or they got corrupted.

Previous 1 2 3 Next