Previous 1 3 4 5 6 7 Next 89 Replies Latest reply: Mar 23, 2014 7:36 PM by AndrewC1970 Go to original post
  • CoffeeGuy251 Level 1 Level 1 (20 points)

    To everyone who is concerned about the three-partition setup once BootCamp has been successfully set up, as shown in RaymondJones1's photo:

     

    photo.JPG

    This is normal on any Mac with a 3TB or larger drive, whether it be a Fusion or standard drive.  The reason this happens has to do with a limitation in Windows, where it cannot be installed on a partition farther away than the fourth from the physical start of the drive, *AND* that partition must begin and end all within the first 2.2TB of the physical drive.

     

    Prior to 10.8.3, Boot Camp Partition was not able to create a Windows partition on a 3TB or larger drive (see this link to read about what was necessary to achieve the same thing prior to 10.8.3: http://blog.twocanoes.com/post/42453643591/bootcamp-on-a-3-tb-fusion-drive (kind of makes me appreciate what Apple's engineers have achieved with Boot Camp Assistant in 10.8.3)).  The latest Boot Camp Assistant (v5.0.2) in 10.8.3 is able to perform some very tricky CoreStorage sleight-of-hand to make it so you can have Windows on a 3TB+ drive, and have your "Macintosh HD" still appear as one volume icon on the Desktop.

     

    So, while it may seem to be cause for worry that there are three partitions, Mac -> Windows -> Mac, that's actually exactly as it should be if you have a Boot Camp partition on your 3TB+ drive.

     

    If you're still not comfortable with it, you can blame Microsoft.

     

    Now, all that said, I have found myself in the same situation as many of you, with a ~2.2TB Macintosh HD and~800GB Free Space on my 3TB Fusion Drive, and no way to get all of my 3TB back.  I'm still impressed with what Apple's engineers have achieved with the latest Boot Camp Assistant, but I'm not happy that it's not yet bulletproof.

     

    <sigh />

     

    Message was edited by: CoffeeGuy251

  • bracherb Level 1 Level 1 (0 points)

    Wow - I went through the same process as many of the folks here: After attempting to install Bootcamp, my 2012 27" iMac froze up (I let bootcamp install over night, but when I woke up, the iMac was frozen on a black screen). After rebooting into OS X, everything seemed normal, until I noticed that my 3 TB hard drive was 1 TB smaller and I couldn't access that missing hard drive space. I tried to rearrange the partition in Disk Utility, but it never worked (DU simply ignored my attempts to format the "Free Space"). When I tried to repair the disk in DU, either within OS X or within the recover mode, it warned me of errors, but was unable to fix them. I seemed to be stuck, and was worried that I'd have to take my iMac in to the Apple Store for repairs (fortunately, I do have Apple Care).

     

    However I knew that only software was being affected, so there must be a software solution (i.e., no hardware was malfunctioning). Here's what worked for me: First, I made sure I had a Time Machine backup of my computer. Then I booted into the Windows 8 installation CD by holding down the option key and selecting the Windows CD. I then pretended to install Windows 8 until I got to the "Where do you want to install Windows" screen. Then I carefull identified the two partitions of the main Mac hard drive: One was about 2 TB in size, and the other was about 1 TB in size. Please note that I didn't have a third bootcamp drive at this point (I deleted it earlier), so that partition was not listed. I then selected the "Drive options (advanced)" button and then deleted both of those partitions. I then rebooted the computer holding down CMD-R and prepared to reinstall Mac OS X. When I opened Disk Utility, it immediately recognized that the main hard drive was no longer in proper condition (because I had just deleted both partitions in Windows), and re-partitioned the drive into a single 3TB drive.  Problem solved. I then proceeded to restore my Time Machine backup.

     

    A few caveats: So I had to start my Bootcamp installation over completely within OS X, but this time, everything worked fine. I think my initial problem was that I had multiple hard drives plugged into the iMac when I attempted to install Bootcamp the first time. When I installed BC correctly, I had no additional hard drives plugged in. But for some reason, Time Machine wouldn't recognize my backup when I tried to restore it, which means I might have to reinstall my Mac from scratch. This problem is not related to the original problem, of course, but I have to say, getting Windows on this thing has proven to be a real pain!

     

    -Brian

  • DJ_Spin Level 1 Level 1 (0 points)

    Same thing happened here. A Tier 2 Genius at an Apple Retail Store performed a one-page fix (passed down from engineers at Cupertino). The Genius wasn't allowed to give me specific details on how he fixed it but did say it was two commands in Terminal. He recommended Parallels 8 as an alternate method of installing a Windows OS in iMac. I'm going to give up the idea of trying to convert my powerful new Ferrari F438 (27" iMac i7 3.4GHz GTX 680MX) with a tow-hitch, ala Ford F-150 (Windows).

  • Ielara Level 1 Level 1 (0 points)

    I can hardly believe this!  I finally decided to go the Bootcamp route after becoming frustrated with the limitations (mainly speed) with Windows 7 in Parallels, and the hassle of juggling remote access to my speedy Windows 8 machine.  The more I tried, the worse it got.  Each attempt to create a windows partition failed, then I realised how much of my 3TB Fusion drive I was losing.  The suggestions in this discussion didn't really help and eventually I've had to resort to erasing partitions and doing a full restore from Time Machine (with every indication that I've got my full 3TB back).  That's due to finish in an hour, hopefully successfully.  How is it possible that Apple can know what a mess they've created but not have clear solutions to solve the problem.  I've spent 7 or 8 hours on this folly!

     

    I'm assuming the restore will be fine - if not you'll hear from me again, at which point I'll probably be really upset!!

  • Csound1 Level 8 Level 8 (44,760 points)

    As we, like you are just users of Apple equipment what do you want us to say when you are "really upset"

  • Thresher100 Level 1 Level 1 (10 points)

    I am having the exact same issue on my iMac 27" with 3TB Fusion drive. 

     

    I've never encountered a situation like this that Disk Utility couldn't solve.  The resizing option doesn't work and when I try to format, I get a really quick message that passes so fast I can't read all of it, but it starts with "Preparing to..." and nothing happens.  No error messages, but it is not formatting the partition.

     

    I'll try using the Windows disk to delete both partitions in the morning and start over.

     

    This is extremely frustrating.  Bootcamp worked like a charm on my Macbook Pro, but my iMac has been a nightmare. 

  • Rockinrobstar Level 1 Level 1 (0 points)

    This is a bit of a guess and you might have do a bit of further reading to understand what I am trying to say but basically:

     

    When you buy a Mac - its Hard Disks come partitioned using the GPT partitioning scheme that is used for the UEFI boot process (All new Windows 8 badged computers have UEFI now as well - Macs have been using it for years). This is opposed to the old MBR partitioning scheme that was used with the BIOS boot process.

     

    There are quite a few limitations of the MBR partitioning scheme including:

    • A limit of 4 partitions per volume

    • A limit of 2 TB per partition

    • Poor support for AHCI

     

    Boot Camp consists of two parts - the first part turns your partitioning into a hybrid of the two partitioning schemes above, so you get stuck with all the limitations of MBR - with the 2 TB limit above I suspect of giving you issues. The second part is the drivers for Mac hardware in Windows.

     

    You have a couple of possible solutions:

    1. Test with having all partitions less than 2 TB

    or

    2. (Technical) Try and install Windows 8 in EFI mode - its a bit tricky at the moment and a little bit of work - but I have it working on my MacBook Pro ok with the Boot Camp driver pack (although I do have nVidia graphics driver issues that you may or may not encounter as well). See my wiki at multiboot.info for links if you want to attempt this.

     

    This second option would be a lot easier if Apple simply began to support EFI booting Windows 8 with Boot Camp - more and more people I suspect are going to run into these issues. Please nag Apple to do this.

  • Kenli-z Level 1 Level 1 (0 points)

    I had the similar problem.

     

    Thanks for sharing with us

  • Sterrestar Level 1 Level 1 (0 points)

    I have been struggeling with this problem the entire day yesterday.

     

    27" iMac with 3TB fusion drive as well.

     

    Bootcamp regocnizes the install disk of Windows, but it seems it's stuck at one point in the partitioning process.

    I haven't run it for an hour though, since I thought it was stuck. Stopped it three times and had the missing TB aswell.

     

    I have been able to restore my HD and the missing TB by clicking Restore in the DU en restarting my system though.

     

    Also tried to make a MS-DOS (FAT) partition manually through DU, but it says "the target disk is too small for this operation". (I have 1,35 TB left!).

     

    I've booted my iMac in the Installation disk and the install sytem works fine so I know it's not Windows, it's Mac not partitioning my HD well.

     

    I don't have a 3TB external hard drive, so I can't make a Time Machine backup, so I can't reinstall my OSX through the Restore partition

     

    Did anyone make any progress on this? Planning on calling the Dutch Apple Support tomorrow!

  • Sterrestar Level 1 Level 1 (0 points)

    And so I went today.

     

    The "genius" knew even  less than me, and kept trying to tell me that it was because Bootcamp only supported Windows 8, even when he opened a trouble shoot on his iPad and it CLEARLY stated that Windows 7 was supported just as well.

     

    He had to google everything I said. So much for genius, no help there.

     

    Then I went downstairs and spoke with a really friendly guy that was standing next to an iMac. He was off in 10 minutes, but he helped for at least 20 minutes, really cool and he really listened to me problem.

     

    He asked around, called some people and eventually said 'Well I think it has something to do with the fact that the software doesn't communicate well with the firmware, and because a fusion drive is quite a new thing, the software for Bootcamp has to be written in such a way that it only used the Hard Drive and not the SSD Flash drive. When the Imac with the 3TB first came out, Bootcamp didn't even support it, but they came out with a patch and claimed that that fixed it, but apparantly it didn't. I'm sorry but I'm afraid all you can do now is wait, keep checking the fora and get the message out there'.

     

    Even though I left without a solution, that guy did make me feel alright about it. The problem was know with Apple, atleast amongst the employees in Amsterdam, I think they will fix a patch for it in the future. Maybe when Mavericks comes out?

  • popsynic Level 1 Level 1 (10 points)

    Has anyone had any success with Bootcamp & Windows 7 or 8 on Fusion 3TB - all I have heard is stories of big fat fails, despite apple saying this issue has been fixed?

     

    I am expecting delivery of a 3TB Fusion Drive iMAc any day - and as a mac newbie, I was relying on having the 'Newbie Comfort Zone' of being able to run windows fully resourced in bootcamp - and if it can't do what Apple claims it can in their promo blurb, then it is going to be sent right back to them - I think I have a 14 day no questions asked return Window ,(ahem, excuse the pun),  don't I?

     

    I have spent £300 ($500) extra for the 3TB drive, and it will be a  massive let down If I find out I could have got exactly want I wanted to acheive much better with a cheaper/smaller 1TB Fusion drive - and that paying the premium for the 'better spec' is actually going to give me more headaches.

     

    Anyone have any success with Bootcamp & Windows 7 or 8 on Fusion 3TB - all I have head is stories of big fat fails, despite apple saying this issue has been fixed?

  • Csound1 Level 8 Level 8 (44,760 points)

    popsynic wrote:

     

    Has anyone had any success with Bootcamp & Windows 7 or 8 on Fusion 3TB - all I have heard is stories of big fat fails, despite apple saying this issue has been fixed?

     

    I am expecting delivery of a 3TB Fusion Drive iMAc any day - and as a mac newbie, I was relying on having the 'Newbie Comfort Zone' of being able to run windows fully resourced in bootcamp - and if it can't do what Apple claims it can in their promo blurb, then it is going to be sent right back to them - I think I have a 14 day no questions asked return Window ,(ahem, excuse the pun),  don't I?

    Yes you do.

  • popsynic Level 1 Level 1 (10 points)

    Update on my experience of installing Windows 7 & BOOTCAMP on my 3TB Fusion Drive iMac 27". 

     

    Bottom line is that I did it (I think) but it was not as straightforward as the instructions provided by Apple.

     

    Screen Shot 2013-08-12 at 09.28.29.png

     

    Everything worked fine right up to point of actually installing Windows using my external Superdrive - which basically caused the installation of Windows to come to a screeching halt - i think because when the iMac switched over to the windows install procedure, the drivers for my superdrive where no longer available, and the diskdrive just became a cold slab of metal, not doing anything with my disk trapped inside.  I got a black screen.

     

    So I rebooted to OS X and checked out my BOOTCAMP, which now had a Windows partition, but no windows!. 

     

    So this time I used my WINDOWS ISO image to create a bootable install of windows on a flash drive using the facility within BOOTCAMP.  BOOTCAMP again began the process, but it wouldn't let me simply install windows on the exisiting WINDOWS/BOOTCAMP partition. It wanted me to first delete the BOOTCAMP partition and 'uninstall' windows 7 (which hadn't actually been installed anway!!)

     

    So I did that using BOOTCAMP, and looked at my drive.  All seemed fine, and I had once again gained my full 3TB (just over actually with the SSD Fusion element).

     

    So I tried again.  This time I got to the windows install part, and I got a black screen again - but this time with a blinking cursor????  Did a quick check online (using my laptop) and discovered that this was because I had 'too many things plugged into my USB ports' !!!!  aggghhhhhh!!!

     

    At this point very frustrated - but I unplugged everything from my USB ports (Time Machine Drive, Superdrive) and all I had plugged in now was a USB mouse and the windows install application on a USB Flash Drive.

     

    When I rebooted and started BOOTCAMP I discovered that I once again had to 'uninstall windows 7' (Which hadn't installed anyway) and remove the BOOTCAMP Partition, and then start the BOOTCAMP install again.

     

    So did this, and this time all went well.  Windows actually began to install.

     

    I then panicked because I didn't have a USB keyboard plugged in, and remembered that at some point in the process I am going to need to input details, serial number key, etc.  But when i got to that point the wireless apple keyboard worked for some reason???

     

    Anyway, windows installed, and then I ran the Apple BOOTCAMP windows drivers package I had downloaded previously to another USB stick.

     

    And I now appear to have WIndows 7 Bootcamped on my 3TB Fusion Drive and seems to bootup and work as expected.

     

     

    Screen Shot 2013-08-12 at 09.28.29.png

     

     

    The only caveat is that in order to acheive this functionality on a 3TB drive, APPLE seem to have had to develop an approach which lumps the BOOTCAMP partition in the middle of your hard drive.  If you delete the BOOTCAMP Partition, you then get what appears like two separate paritions before and after the space the BOOTCAMP was on, but it is seen by OS X as one volume.

     

    My Windows install though seems really big at 55GB - not quite sure why its that big???

     

    Screen Shot 2013-08-12 at 09.26.20.png

     

    Screen Shot 2013-08-12 at 09.28.02.png

  • Csound1 Level 8 Level 8 (44,760 points)

    popsynic wrote:


    Windows install though seems really big at 55GB - not quite sure why its that big???

     

    Screen Shot 2013-08-12 at 09.26.20.png

     

    Screen Shot 2013-08-12 at 09.28.02.png

    55GB is not big, expect it grow larger.

  • popsynic Level 1 Level 1 (10 points)

    I expect it to grow larger in use- but not quite sure why a fresh install of windows 7 with no use yet at all should take up 55gb.  Especially when the bootcamp guide says allow at least 20gb.  What if I had only made a partition of 50gb.  Looks like it wouldn't have been big enough to install bootcamp and windows.  Anyway that's my story and hope its if use to others trying to install bootcamp on a 3tb drive

Previous 1 3 4 5 6 7 Next