3 Replies Latest reply: Mar 19, 2013 7:15 AM by Michael Allbritton
Banksy11 Level 1 (0 points)

Hi, I've got lots of mixes some 45 minutes some 1hour and a half single files. I never used to have any trouble streaming to my iPhone over 3G! But now it won't stream at all. Tells me to connect to wifi!!! Kinda defeats the object I think! After all iTunes Match uploaded these files and know wont let me stream or download when I want? Anyone else having trouble?


MacBook Pro, Mac OS X (10.7.1)
  • Michael Allbritton Level 6 (16,785 points)

    Go to Settings > iTunes and App Stores and make sure the option to "use cellular data" is set to ON.

  • Banksy11 Level 1 (0 points)

    Thanks for the reply but thats not the problem. I can download or stream whole albums of files but it wont let me stream any large files such as DJ mixes over 45minutes long over 3G? It used to i'm sure Apple have changed something recently! This is annoying as i have a lot of DJ mixes dropped in the cloud mixed by myself and others and now it wont let me stream or download over 3G for these files!?!

  • Michael Allbritton Level 6 (16,785 points)

    How do you know it isn't your 3G provider that is the weak link? At any rate, first disable iTM on the iOS device, launch the music app and let the content clear out, then re-enable iTM. See if that helps.