Previous 1 2 3 Next 114 Replies Latest reply: May 30, 2015 6:28 AM by PeteF
tridentinecanon Level 1 (0 points)

Recently (within the past 4 weeks or so) I have had issues getting iTunes Match to upload/match about 10-20% of the songs I've added to iTunes.  My issue is similar to that desribed in this thread (I'm getting the little cloud with the exclamation point next to the troublesome songs), except all the songs in my iTunes library are in Apple lossless format (ripped from CDs), and so as a solution I tried to convert them to AIFF format and then back to Apple lossless.  This, however, is not working.


What's going on here?  Does anyone have any ideas/suggestions?  Thanks.



Mac Pro, OS X Mountain Lion
  • rolandomerida Level 1 (105 points)

    My situation is similar for a few tracks that I've added to iTunes. I imported them in AIFF, and when converting to Apple Lossless, iTunes Match tried to process the files. There was an error and those tracks are still waiting to be "processed by iTunes Match". The cloud icon has no exclamation point or anything, and there's no "add to iCloud" option in the contextual menu. I reimported the files and tried the AIFF solution too, but it didn't work at all.


  • Michael Allbritton Level 6 (16,785 points)

    You don't necessarily need to cross-convert the track to another format. That could just be confusing the issue. Try these steps.


    1. Remove the troublesome tracks from the iTunes library, and hide them in the cloud if you are prompted to do so.

    2. Turn off iTunes Match and log out of your iTunes Store account.

    3. Quit iTunes; restart your computer for good measure.

    4. Launch iTunes.

    5. Log into the iTunes Store account.

    6. Add the ALAC tracks back into the iTunes library.

    7. Enable iTunes Match and let it do its thing.


    Post back and let us know how it went.

  • rolandomerida Level 1 (105 points)

    Sounds good. I'll try that too. Just one thing: On step (6), you mean import again the tracks, or "unhide" them, if that is possible?


    These tracks have never been uploaded to iCloud. however, when removing them, iTunes says "they still can be played from iCloud" (?) Then offers to hide them, and their titles are dimmed and with the "dowload icon" present, but not clickable.



  • tridentinecanon Level 1 (0 points)

    Michael - Thanks for responding.  I followed each step precisely as you described, but the tracks are still giving me issues.  The iCloud icons next to each track indicate "waiting" status (the iCloud icon with dotted outline).  Admittedly, I haven't seen the exclamation point in the cloud yet, but I suspect it is only a matter of time before I do, as I have been troubleshooting this issue for a few days now before I posted here, and every time I modify the tracks in any way, they have a tendency to show a dotted outline cloud and then eventually an exclamation point cloud.


    I just want to emphasize again that this is a recent problem.  I have impoterted and matched over 15,000 individual tracks in my iTunes library without ever seeing this issue.  It's not happeneing with every track I import right now, but a significant number of tracks (10-20%).


    One other thing that just came to mind:  I know when I reset Safari that I have to log back in to my iCloud account in iTunes, and I know I reset Safari while importing/matching some new CDs I got.  I'm not sure if this could be part of the problem.  I can say that I did not reset Safari on another day when I imported other tracks that are also giving me issues.


    Any other thoughts/suggestions are greatly appreciated.

  • Michael Allbritton Level 6 (16,785 points)

    @rolandomerida, in step 6 I mean to use the "add to library" command in the File menu. Since you should not have deleted the ALAC track from the HDD of your computer.

  • Michael Allbritton Level 6 (16,785 points)

    @tridentinecanon, first be patient. Sometimes he scanning process can take some time to complete if tracks are being uploaded. Do not "modify" any tracks at this point. If the steps above aren't working for you, walk through them again but this time when disabling iTM hold down the shift key.

  • tridentinecanon Level 1 (0 points)

    Thank, Michael.  I followed each step again, this time holding the shift key when turning off iTunes Match.  Nevertheless, I'm still apparently having issues with the same songs (they are showing the dotted outline cloud right now).  It has been a few hours, but I'll "be patient" for now in hopes that the "waiting" status will fix itself.


    Will post back with an update sometime tomorrow...

  • Michael Allbritton Level 6 (16,785 points)

    If it appears the songs still are not being processed you can also remove all the troublesome songs from the iTunes library, then add them back a few at a time. Let iTunes process them, then add some more. There may be just one that is holding up all of them.

  • Paul Forgey Level 2 (160 points)

    I have the exact same situation. All of my ripped music is done from iTunes in Apple Lossless, and, also like the OP, my trouble started about a month ago.


    I tried the suggestion of holding down shift while turning off match and then re-adding my computer. This did not change anything.


    As for Michael's suggestion, I have several thousand tracks in the "waiting" stage, so removing them from my library and then slowly reintroducing them is not worth my time or sanity.

  • kottke Level 1 (0 points)

    I was posting here thinking it was just me with this one album.


    I am happy/sad to see it isn't.


    Continuous processing status symbol by these certain tracks for iCloud upload from my lossless format, then when I option click to force another Match iCloud upload it gives the error "!" symbol.

  • photocopy Level 1 (10 points)

    I'm having the same issue. It just started yesterday for me. I've got 6/12 track in the waiting status. I've tried everything mentioned above to no avail.

  • Paul Forgey Level 2 (160 points)

    This idea actually doesn't sound plausible. While I have a few thousand tracks stuck in the "waiting" state, if I rip a new CD, one or two tracks from it actually make it in. If a particular track were holding things up, this wouldn't happen.

  • ScottAinsworth Level 1 (0 points)

    I don't think it is a queuing problem either.  This also just started happening to me.  For the last album I ripped ("Majesty and Magic" by Robin Bullock in case it matters), Songs 3, 4, 7, 9, 10, and 12-14 never upload. I am ripping to Apple Lossless.  I have tried the following:


    1. Delete the tracks from iTunes and re-add.

    2. Delete from iTunes and iCloud, re-add.

    3. Delete from iTunes and iCloud, re-rip.

    4. Turn off iTunes match, log out of store, login to store, re-add, turn on iTunes match.

    5. Delete from iTunes and iCloud, add tracks on at a time, pausing for 10 mins between each.


    In each case, it is the *same* songs that will not upload.


    Other observations:


    1. If I wait long enough, sometimes the error icon is shown (i.e. cloud with exclamation point).  But it just says "error".  There is not explanation.

    2. Converting the tracks from Lossless to 256Kb AAC does not help.


    Hope Apple fixes this bug soon!

  • ScottAinsworth Level 1 (0 points)

    Okay, more inconsistency.  I removed and reconverted the tracks to AAC.  This time all 14 uploaded.  So, I removed and re-added the lossless versions.  These are still waiting even though iTunes match as "delivered results" twice since then.

Previous 1 2 3 Next