1 Reply Latest reply: Mar 15, 2013 4:03 PM by Old Toad
turnerkate Level 1 (0 points)

My iPhoto says it is in use by another application or has become unreadable. Nothing I have done is working? I've tried restarting my compuer, holding down the command and option keys as I open it and have tried downloading another version of the iPhoto..

  • Old Toad Level 10 (135,408 points)

    See if you can do the following:


    Using iPhoto Library Manager  to Rebuild Your iPhoto Library


      1. Download iPhoto Library Manager and launch.
      2. Click on the Add Library button,

        iPhoto Library Manager002.jpg 

        navigate to your Home/Pictures folder and select your iPhoto Library folder.

      3. Now that the library is listed in the left hand pane of iPLM, click on your library and go to the Library ➙ Rebuild Library menu option

        iPhoto Library Manager001.jpg

      4. In the next  window name the new library and select the location you want it to be placed.
      5. Click on the Create button.


    Note: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments. However, books, calendars, cards and slideshows will be lost.


    Note:  your current library will be left untouched for further attempts at a fix if so desired.