2 Replies Latest reply: Mar 16, 2013 1:56 AM by Jan Hedlund
MacOS-me Level 1 Level 1 (0 points)

Hi,

 

  I have an old iMac (G3 I think?) that did run Mac OS 9.1; until one day I shut off the power via the power button instead of the GUI way, and the next time I turned it off it quit on me. It now (every time it turns on) mockingly shows a blinking folder with the Finder logo and questionmark blinking intermittenly.

  So naturely, I brought it to the Apple store, hoping they would help me as they did my old Powerbook 1400c. They did, but not enough to get it functional.

  Anyway, I've been able to get it to boot into Open Firmware (via Command+Alt+O+F); but that's it. I tried issuing common commands that people have said worked for them, but to no avail. For example, I used "mac-boot", "boot hd:,\\", "reset-nvram" (or whatever that command is to reset the NVRAM), "reset-all", and even  used "boot cd:" (and "boot cd:,\\") while my Mac OS 8 install disk is in there (I don't have 9), but it does not work.

  Whenever I issue the "boot hd:,\\" and "boot cd:"; it comes up with the following message:

 

         load-size=0 adler32=1

 

         LOAD-SIZE is too small

 

  So my question is this: how/what can possibly be done to get this old computer up and running again? Some people have suggested it could be the logic board, but I am deeply hoping not (I dont' have the skill or money required to get & install one). Any ideas?

 

        Thanks!

 

P.S.- Does anyone know the boot command to make it boot from CD? I think the apple guys tried it already (and did not work), but I might as well try again. Also, if it's any help, the Open Firmware version is 3.0.f2 .


iMac, Mac OS 9.1.x, iMac g3/233, Mac OS 9.1