5 Replies Latest reply: Mar 17, 2013 8:48 PM by Linc Davis
clark49 Level 1 Level 1 (0 points)

An error is displayed when I try to open iphoto. The error states "your iphoto is damaged or unreadable and cannot be opened.Please restore from a backup." Any help would be appreciated.


iPhoto '11, OS X Mountain Lion (10.8.3)
  • Linc Davis Level 10 Level 10 (150,880 points)

    Please restore from a backup

     

    Did you do that?

  • clark49 Level 1 Level 1 (0 points)

    Yes I backup both iPhoto and my iPhoto library from time capsule that I knew system worked.about a month ago timeframe. It appeared to initially work, was loading thumbnails of photos then suddenly same error came up. I also own new MacBook Pro which has no issue with same library. The IMac in question which is having issue with iPhoto is late 09 model. Appreciate any help.

  • Linc Davis Level 10 Level 10 (150,880 points)

    Launch the Console application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ Open LaunchPad. Click Utilities, then Console in the icon grid.

     

    Make sure the title of the Console window is All Messages. If it isn't, select All Messages from the SYSTEM LOG QUERIES menu on the left. If you don't see that menu, select

    View Show Log List

    from the menu bar.

     

    Click the Clear Display icon in the toolbar. Then try the action that you're having trouble with again. Select any messages that appear in the Console window. Copy them to the Clipboard (command-C). Paste into a reply to this message (command-V).

    When posting a log extract, be selective. In most cases, a few dozen lines are more than enough.

    Please do not indiscriminately dump thousands of lines from the log into this discussion.

    Important: Some private information, such as your name, may appear in the log. Anonymize before posting.

  • clark49 Level 1 Level 1 (0 points)

    3/17/13 7:48:47.960 PM librariand[2240]: MMe quota status changed: under quota

    3/17/13 7:49:00.003 PM Dock[310]: CGSGetCurrentDisplayMode: Invalid display 0x41dc9d00

    3/17/13 7:49:00.777 PM Dock[310]: CGSGetDisplayAliasList: Invalid display 0x41dc9d00

    3/17/13 7:49:00.777 PM Dock[310]: CGSGetDisplayAliasList: Invalid display 0x41dc9d00

    3/17/13 7:49:01.492 PM iPhoto[2237]: An instance 0x7a356a00 of class MWController was deallocated while key value observers were still registered with it. Observation info was leaked, and may even become mistakenly attached to some other object. Set a breakpoint on NSKVODeallocateBreak to stop here in the debugger. Here's the current observation info:

    <NSKeyValueObservationInfo 0x7ae9f9d0> (

    <NSKeyValueObservance 0x7ae9f990: Observer: 0x7ae856a0, Key path: currentAlbum, Options: <New: YES, Old: YES, Prior: NO> Context: 0x0, Property: 0x7ae9fa10>

    )

     

    here is the information you request.