Previous 1 2 Next 15 Replies Latest reply: Apr 8, 2013 1:50 PM by autumn94
autumn94 Level 1 (0 points)

I've seen similar discussions, and I've tried many of the solutions, but to no avail.  It's only been within the last month, whatever I type into my iphone 4S ical does not show up on my ipad or MacBook Air.  It DOES work the other way around.  All of my devices are updated (10.7.5 OS X Lion on MacBook Air, iOS 6.1.2 on ipad mini, and iOS 6.1.2 on iphone 4S), I've gone into itunes (11.0.2) with my iphone plugged in and clicked on Sync calendars, I've disabled the calendars on both my iphone and ipad, rebooted, and enabled the calendars.  I've also reset my iphone.  None of it works.  I've gone into ICal on my Macbook, under the Calendar drop box, and made sure that the Icloud Calendars are clicked and not the On My Mac calendars.  Are there any other solutions to try?  Is this a problem with the software upgrades between the devices?

  • randers4 Level 9 (62,715 points)

    If I'm reading your post correctly, events added to your iPhone calendar are not syncing to your other devices but events added to your other devices are syncing with each other, as well as your phone.  I see that you've tried disabling calendar syncing with iCloud and reverted to syncing with iTunes, but I'm not sure if you went to Settings>iCloud on your phone, turned Calendars to Off, chose Delete from My iPhone when prompted, then after a minute or so turned Calendars back to On to sync back your iCloud calendars to your phone.  If you haven't, I suggest you try this.


    Also go to Settings>Mail,Contacts,Calendars>Default Calendar on your phone and make sure you have selected a calendar listed under your iCloud account as your default.  If not, make this change, then add a new event on your phone and see if it syncs now.

  • autumn94 Level 1 (0 points)


    You ARE reading my dilemma as correct.  I tried all of your suggestions, but it does not work.  What it DID do was delete all of what I had typed into the phone as of recently that was not already synced with the Mac. (I typed those dates somewhere else, just in case I lost them).  I have noticed in my itunes account that the phone does not stay registered unless I physically plug it into the computer.  When I open itunes, the ipad immediately shows up, but not the phone.  It used to...let me say that I have had SO many problem with itunes - the most un-user friendly program.  Anyway - there is no setting that allows me to "homeshare' the phone - it always had been set up that way, but now it seems it is not.  I think that is the main problem - but am not sure how to get itunes to recognize the phone over Icloud.

  • autumn94 Level 1 (0 points)

    I'll add that I'm in my itunes account, and it shows that my iphone IS associated with my apple ID.

  • randers4 Level 9 (62,715 points)

    Sorry, I don't know what you mean by "'homeshare' the phone".  Are you talking about Home Sharing?


    I also don't know what you mean by "how to get itunes to recognize the phone over iCloud".  Can you explain further?

  • autumn94 Level 1 (0 points)

    Yes - homesharing.  When I open itunes, it SHOULD show the devices that one has linked to that account (other than the Mac).  It only shows my ipad, not the iphone.  I do not have the ipad physically plugged into the computer when I open itunes.  So as I do not have the phone plugged in either, itunes should recognize that my iphone shares the same Apple account.  I THOUGHT that was done by Icloud - since nothing is physically plugged into the computer. 

    I don't know how else to explain it.  I have deleted, changed settings, reset devices, double checked everything, and it does not work.  It only stopped syncing within the last few weeks.  So it would seem to me that it's a problem through software updates or itunes, since I hadn't changed any settings.

    I'll keep trying anything though if you have suggestions - I truly appreciate your help.

  • randers4 Level 9 (62,715 points)

    I have to run right now but I'll respond when I get back.

  • randers4 Level 9 (62,715 points)

    Ok, I'm just re-reading your post.  First, home sharing doesn't use iCloud.  It only uses your wifi network.  It searches your network for other computers and iOS devices with home sharing enabled with the same Apple ID and connects them to the shared iTunes library/libraries.  If home sharing is not working on your phone, you might try turning it off, then back on in settings.  Also, be sure that you are signed into home sharing with the same Apple ID that you are using on your Mac and iPad.  Finally, be sure that you are connected to the same router on your wifi network as the other devices.  If you have a Guest account set up on your router, be sure that your devices are either all signed into the main account, or all signed into the Guest account.  If they aren't connected to the same router in the same account, they will not discover each other using home sharing.


    There are some additional home sharing troubleshooting steps you can look through here:  If you continue to need help resolving this, suggest you post a question over in the home sharing forum here:


    Your iCloud calendar syncing issue is a separate issue.  First, be sure you are not trying to sync calendars using home sharing.  Home sharing only shares media from your iTunes library with your iOS devices (music, videos, etc.), not non-iTunes library data such as calendars and contacts.  To share your iCloud calendar between your devices, you need to be syncing with the same iCloud account, and have Calendar syncing set to On (in Settings>iCloud on your iOS devices, and in System Preferences>iCloud on your Mac).  Is that what you are doing?

  • autumn94 Level 1 (0 points)

    Ok - I was out too.  So just getting back to this.  I currently have itunes open, with the phone plugged into the computer, and the "info" tab on the iphone device says "Your calendars are being synced with your iphone over the air from icloud.  Over-the-air syncings can be changed on your iPhone."  And that section leaves me no option to change that setting, which is how it is set up with the ipad, so that seems to be fixed.  It IS syncing over ICloud. So I will leave that whole thing alone and deal with the homesharing about other issues later.


    In my calendars, there is a NEW calendar that hasn't been in the icloud calendar list before named "calendar".  I did not creat it (knowingly or willingly).  It's on ALL devices.  So I just deleted that - made no difference.

    Also - before today, I did not have a grouping of calendars in my calendar drop down box headed "on my MAC".  Somehow that whole grouping was added today.

    What I notice is that events typed on the MAC are syncing, though it takes awhile (5-10 minutes) to show up on each device.  I have made sure each device is on the main wi-fi account, I had the settings open on both ipad and iphone and walked through to make sure they were identical. Something typed on the ipad is not showing up on iphone or Mac, and something typed on the phone is not showing up on ipad or Mac.  But by typing it on Mac it will show up on iphone and ipad.

    The only think I can think I did differently is that I created an icloud email account about a month or 2 ago which I never use - surely that can't be the source of these problems?  I have my comcast account set as default.

    I can't figure it out - I feel like I've wasted your day and mine.  I DO appreciate you taking your time out though.  At least I see that others have the same issues.

  • autumn94 Level 1 (0 points)

    Oh, and yes, iOS devices calendars are ON when going to Settings>ICloud, and MAC calendar is ON when going to System Preferences>iCloud.

  • randers4 Level 9 (62,715 points)

    autumn94 wrote:


    I currently have itunes open, with the phone plugged into the computer, and the "info" tab on the iphone device says "Your calendars are being synced with your iphone over the air from icloud.  Over-the-air syncings can be changed on your iPhone."  And that section leaves me no option to change that setting

    That setting is automatically set in iTunes when you have Calendars set to On in Settings>iCloud on your device, as you do.  It would change if you were to turn this to Off on your device, then reconnect it to iTunes.


    The "On My Mac" calendar (and possible the new "Calendar" as well), was created when you turned off iCloud calendar syncing and synced your calendar with your Mac instead.  The important thing is to ensure that in Settings>Mail,Contacts,Calendars>Default Calendar you have selected a calendar listed under your iCloud account name as your default as it is the only one that will sync with iCloud.  If not, you will end up entering new events on one of calendars that does not sync with iCloud and such events will not appear on your other devices.  If you haven't selected an iCloud calendar as your default, make this change, then enter a new event and see if it syncs to your calendar on now.  Do this on both your phone and your iPad.


    Creating the iCloud email account that you don't use will have no impact on any of this.

  • autumn94 Level 1 (0 points)

    Yes, the default calendars on all devices are set to an iCloud calendar. I entered something on each device about 40 minutes ago, and the only one to show up on all 3 devices was what I typed on the MAC.

  • randers4 Level 9 (62,715 points)

    There's nothing wrong with your settings.  I wonder if you're having wifi connectivity issues.  You might try unplugging your wireless router for 15 seconds, then plugging back in, then on your phone go to Settings>General>Reset>Reset Network Settings, then rejoin your wifi again.  Note: resetting network settings on your devices will erase passwords for previously joined networks.  You might also try changing your router settings to use Google's public DNS (see

  • pamelak Level 1 (0 points)

    Jumping in on this conversation from a few weeks ago. I'm having the same problems with calendar syncing: enter info on phone, it doesn't sync anywhere else; enter info anywhere else, it syncs IMMEDIATELY on other devices - except in my case, it doesn't go to the phone at all.  My phone, however, is 3GS, maybe getting to be too old?? It's aggravating because I've been syncing for YEARS, first with Mobile Me, then with iCloud as soon as it became available, so this is nothing new for me. And just within the last few weeks, these problems have cropped up. I've been wondering, as Autumn94 has wondered, if a software update has screwed something up? I've also been wondering, since randers4 has mentioned wifi connectivity, if my 2005 Apple Airport is also just becoming too old to be useful any more? I regularly (at least a couple of times a week) have to unplug and replug it to reboot the wifi; I've narrowed it down to that piece of equipment and not the Comcast modem that is the source of the problem. However - recognizing that I probably should update my wifi router and my phone - I still can't help but feel that the calendar issue is separate. Wondering if there are any new insights since this original post?

  • pamelak Level 1 (0 points)

    FYI - rebooted phone - all is well now.

Previous 1 2 Next