Previous 1 2 Next 22 Replies Latest reply: Mar 18, 2013 5:18 PM by Old Toad
cyrano7 Level 1 Level 1 (0 points)

I have been using iWeb to make my website and Yahoo to host.

 

Tonight they stopped communicating, and I think the problem may be on the iweb side.

 

iweb no longer opens and says: Can't open file "~/Library/Application Support/iWeb/Domain.sites2."

 

 

I have an a 2008 27iMac that has an functional iWeb. I think my options might be:

 

a) copy iWeb onto a memory stick and load it onto this computer (I am no tekkie, I do not know if applications can be transferred like that)

 

b) download iWeb (from a third party, I presume) off the internet.

 

Any help please?


iMac (27-inch Late 2009), OS X Mountain Lion (10.8.2)
  • Eric Ross Level 6 Level 6 (11,665 points)

    Take a look at this link, it may help.  https://discussions.apple.com/thread/4121370?start=0&tstart=0

  • Wyodor Level 6 Level 6 (19,650 points)

    Put the app on a stick and see what happens.

     

    If both your Macs are on a LAN, enable filesharing and connect from one to the other and copy the app.

     

    And perhaps there's something wrong with the domain file.

     

    Either retreive a copy from the latest backup (Time Machine) or try iWebSites :

     

    http://www.wyodor.net/_Demo/Aptana/iWebSites.html

     

     

    You may have to learn how to do all that.

  • Old Toad Level 10 Level 10 (128,850 points)

    Give this a try:

     

    1. move the domain file from your Home/Library/Application Support/iWeb folder to the Desktop.
    2. launch iWeb, create a new test site, save the new domain file and close iWeb.
    3. go to the your Home/Library/Application Support/iWeb folder and delete the new domain file.
    4. move your original domain file from the Desktop to the iWeb folder.
    5. launch iWeb and try again.

     

     

    OT

  • cyrano7 Level 1 Level 1 (0 points)

    Thanks.

     

    1 located an iWeb application in my time machine backup. I drug it to the desktop and tried to open.

     

    Even with the Time Machine saved iweb, I get the same message: Can't open file "~/Library/Application Support/iWeb/Domain.sites2."

     

    2. I copied the iWeb program from my older computer, and the same thing.

     

    So, even if I follow your steps and find the domain file, I doubt that iWeb would open.

     

    Is this a plan B. If I can locate the domain file, move that to my older iMac, and launch the domain from there?

     

    Thanks.

  • Wyodor Level 6 Level 6 (19,650 points)

    Did you try iWebSites?

     

    And what do you mean by "if I can locate the domain file?"

     

    You know where it is. You wrote the location in your post.

  • cyrano7 Level 1 Level 1 (0 points)

    Partial success.

     

    I tried to open up iWeb from the icon in the applications folder, and it opened, the older version opened that it seems is from the old computer, with my old website.

     

    I presume if I could find the new website on the new computer and move that to the old iWeb, I could be up and running.

     

    However, and forgive my ignorance, I cannot find the LIBRARY folder, that I think holds the iWeb domain.

    I think it is in the home icon place, but under Applications, all is has is Parallels stuff.

     

    How do I find the website domain folder, please? (There are instruction on the web, but they are out of date.)

     

    Plan B could be to find the website domain, and move it to the old comptuer and upload the site from there?

    Thanks.

  • Wyodor Level 6 Level 6 (19,650 points)

    One the page i linked to is explicitely explained how to display the Library folder in OS X 8.

     

    And with iWebSites you do not even have to go to that folder.

     

    Anyway, here's the trick :

     

    Hold the Alt key when you choose the Go menu.

     

    Let go and hold again.

     

    And here's a pretty picture from the HELP :

     

    http://www.wyodor.net/_Discussions2/WhereLibraryFolderHelp_01.jpg

  • cyrano7 Level 1 Level 1 (0 points)

    OK, I found the LIBRARY file, and under that the APPLICATION SUPPORT file, but under that I see no iWeb.

    There is iPhoto, iTunes, iWork '09 (and it is not in that file) and many others. I can find no iWeb there.

     

    Thanks. I must be close.

  • cyrano7 Level 1 Level 1 (0 points)

    Thanks, I found the LIBRARY, and the APPLICATIONS folder, but I cannot locate iWeb anything in there.

     

    Earlier you mentioned OS 8. I have OS 10.8.3.

     

    Maybe that makes a difference in where the iWeb folder is?

     

    Many thanks.

  • cyrano7 Level 1 Level 1 (0 points)

    First, I drop and dragged the iWeb from my old computer onto the new, and it opened. Which is good, but it has my old website.

     

    Second, I went to USER there is no LIBRARY file. There is DOCUMENTS, DOWNLOADS, MOVIES, MUSIC, PICTURES, the usual, et al, but no LIBRARY. Thus, I cannot proceed from there.

     

    Third, I am able to find iWeb on the time machine, and then I dragged it to the desktop and opened it the OLD website from the old computer appears.

     

    I think I could maybe find the domain, if I could ever find that darn LIBRARY file. Why is it now where it is suppsed to be, and where might it be? And why can't I find it just by searching 'domain'?

     

    Sorry for the ineptitude.

  • Roddy Level 6 Level 6 (17,265 points)

    See this page for info about how to find the user library and open an iWeb Domain.sites2 file when using Mountain Lion...

     

    http://www.iwebformusicians.com/iWeb/mountain-lion.html

  • cyrano7 Level 1 Level 1 (0 points)

    Many thanks.

     

    These iWeb problems occurred when I was making changes to my iWeb site and attempting to connect it to my Yahoo server. I thought the problem was with Yahoo, which may be true, but could the problem also be with iWeb? No longer functioning as it should?

     

    I have Webcrusher, and I could save the file to a folder, run it through Webcrusher and then send it to Yahoo, but there is a glitch there, it does not go through. Some glitch there too.

     

    So, I have the website saved to a folder, and if I can never find it again on iWeb, a solution might be to via Webcrusher.

     

    At this point, I am seriously considering just making a new site on Dreamweaver, which I have never done before, so that will be tedious and mistake-filled.

     

    Thoughts? I presume that if I download that application you recommend, I could then find my website on my time machine?

     

    Many thanks.

  • Roddy Level 6 Level 6 (17,265 points)

    Under previous version of the operating system, a Domain.sites2 file would open in iWeb by double clicking it. In Lion/Mountain Lion you need to use the helper script.

     

    The app will allow you to browse to any Domain.sites2 and open it in iWeb.

     

    If the site still won't open in iWeb you may have to face the fact that the Domain file is corrupt and you need to rebuild the site. There's not much point in rebuilding it using iWeb since the app is redundant.

     

    There are many more suitable (and cheaper) apps than DreamWeaver and a search of this forum will turn up a lot of suggestions for alternatives.

  • cyrano7 Level 1 Level 1 (0 points)

    Thank you very much.

     

    I have Dreamweaver, so it is no expense to me. That being the case, is that a good next step?

Previous 1 2 Next