1 Reply Latest reply: Mar 17, 2013 11:34 AM by BDAqua
javajazz Level 1 Level 1 (10 points)

Hi

 

I am still using preinstalled 10.5.3 on my MacBook 5,2 (2009 white model, already discontinued).

 

Tonight I got a permanent gray screen and does not get in to the system when rebooting.

 

Sometimes I got Apple logo but then disappeared again.

 

It seems I have problem with the hard drive?

 

Have tried Safe Boot (not working) and not working.

 

Finally rebooting using bootable USB contains 10.5.8 that give me the Disk Utility but the hard drive can not be read and inexist.

 

Trying to reboot in Verbose mode and I got this message:

 

 

efiboot loaded from device: Acpi (........)

boot file path: \System\Library\CoreServices\boot.efi

'_

 

... and STOPS.

 

Does anyone know what should I do? How to fix the hard drive? Is this the hard drive problem, or the connector to the harddrive? or something else?

 

I have tried to reboot using ALL OF the suggested Start Up Key Combination such as in

 

http://support.apple.com/kb/ht1533

 

but always get a gray screen again.

 

Also have done the AHT (Apple Hardware Test) extended mode but it seems this test does not test hard drive.

 

Does anyone know how to fix this?

 

Thanks very much.


MacBook, Mac OS X (10.5.3)