Previous 1 2 Next 19 Replies Latest reply: Apr 3, 2013 11:05 AM by baltwo
ChicagoAl Level 1 Level 1 (0 points)

We have had an issue recently with the iMac my teen son uses, and it seemed to be resolved, as reported in this thread:

 

https://discussions.apple.com/message/21478407#21478407

 

Short version: I had to use an external DVD drive to get the computer to start from the install disk, and that allowed me to run Disk Utility, which (apparently) made the needed repairs.

 

However now the computer has reverted to those problems, basically it won't start up: grey screen or at best, spinning ball and Apple but no further.

 

So I went for a copy of Disk Warrior, and it found and repaired problems with the Directory (replaced it).   But then I ran a check on Files and Permissions and it came up with 'system symbolic link files' that are broken and can't be repaired.  

 

(The HD came up fine with AHT and with the Hardware check on DW.)

 

Should I try to run another repair program or just do a fresh install of the OS?  

 

If the latter, I assume from our 10.6 disks; what is on there is 10.6.8.   We have a Time Machine backup from two days ago, in case needed, but I've never restored from it.   A re-install of the system software should not affect the rest of the data on the computer, right?

 

Thanks for any advice!


MacPro, MBP, many Macs in the house, Mac OS X (10.6.8)
  • baltwo Level 9 Level 9 (61,900 points)

    We have a Time Machine backup from two days ago, in case needed, but I've never restored from it.

    Then, you need to restore it to another parttion or ext HD. That's the only way to ensure that'll do the job and result in a viable restoration. Alternatively, use something like Carbon Copy Cloner or SuperDuper! to put a bootable backup/clone onto another disk.

    A re-install of the system software should not affect the rest of the data on the computer, right?

    Correct. Reinstalling Snow Leopard (or the newer OSs) only replaces OS components and basic Apple apps, leaving user data, settings, and 3rd-party apps alone.

  • ChicagoAl Level 1 Level 1 (0 points)

    Time Machine is, of course, on an external drive.  Surely you are not saying it has to be put yet somewhere else?

     

    Also, looked to see if I could re-install from the built-in recovery disk, but got nowhere.  CMD + R = grey screen.   I am guessing that was part of the factory install (10.4) so since the computer's been updated to 10.5 and 10.6 it's no longer available.

  • baltwo Level 9 Level 9 (61,900 points)

    If you use TM to restore to your current boot volume, then you're assuming that it's viable. I don't use TM, preferring bootable backups/clones. So, yes I recommend restoring somewhere else to ensure it's viable.

     

    The recovery mode is only available with Lion and ML.

  • ChicagoAl Level 1 Level 1 (0 points)

    Thanks.   Tried the 10.6 install disk, got the message that it could not install on the HD...big X through it.   So I tried Disk Utility again and this time it said 'cannot unmount' the disk.   Whatever it is, it's getting worse! 

     

    I don't want to just restore from Time Machine as it probably has the same problems in the system software.  Or am I thinking about this wrong?  I'm thinking I'd use Time Machine only if I have to do something really drastic, or a re-install of the system software trashes the data.

  • baltwo Level 9 Level 9 (61,900 points)

    Zap the PRAM and Reset the SMC, then try installing the OS again.

  • ChicagoAl Level 1 Level 1 (0 points)

    It occurred to me that the disk might not unmount if some process was still running, so rather than restart (as I've done many times today) I shut it down and gave it a break for a while.    After restart, tried Disk Utility...success! 

     

    In fact it reports the disk 'appears to be okay.'  However it also updated boot support partitions; I'm going to redo the repair and if it comes up clean (maybe twice more) go back to Disk Warrior and see what it says.

     

    [Zapped PRAM some days ago without any change.  May have reset SMU as well.  I've done the 'usual suspects.' ;- )]

     

    Update: ran Repair Disk again and...'could not unmount disk' !   I guess possibly that updating of boot support partitions was still going, but from what I've read that happens quickly and you don't get a 'finished' message.  

     

    So I unplugged the computer and am going to let it sit in the corner and meditate upon its own wickedness while son and I go get some barbecue.  Maybe that will improve its attitude.  It is very likely to improve mine.

  • Chris27.040 Level 1 Level 1 (0 points)

    I started off with problems about being in the wrong region and now  have Plug- in Failure

    I am trying to access Setanta Sports Australia which requires

    Microsoft Silverlight and was already pre-installed on a Macbook Pro Retina 2.5 ghz Intel core i5 with Mountain Lion 2.8.3

     

    I have these different PlugIns active :

     

    file://localhost/Library/Internet%20Plug-Ins/DivXBrowserPlugin.plugin/

    file://localhost/Library/Internet%20Plug-Ins/Flash%20Player.plugin/

    file://localhost/Library/Internet%20Plug-Ins/JavaAppletPlugin.plugin/

    file://localhost/Library/Internet%20Plug-Ins/QuickTime%20Plugin.plugin/

    file://localhost/Library/Internet%20Plug-Ins/Silverlight.plugin/

     

    Help?

  • ChicagoAl Level 1 Level 1 (0 points)

    Chris, you need to find another place to ask your question.  Probably you should start a new thread.  Possibly you can find a similar question someone's already asked by searching with keywords 'silverlight' and 'plugin' and 'failure' or something.

     

    Your problem has nothing to do with mine, which means it is not likely to get you any help in this thread.

  • Allan Eckert Level 8 Level 8 (46,145 points)

    ChicagoAl is absolutely correct. You really should start your own thread for your question rather stealling his thread.

     

    Allan

  • ChicagoAl Level 1 Level 1 (0 points)

    So this just gets crazier and crazier. 

     

    After the computer sat for a long while I restarted and ran Disk Utility off the 10.6 install disk.  It reported the disk okay, three times in a row. No 'cannot unmount' issues.  So I ran the installer, and installed 10.6 fresh, then restarted.  All my son's files, etc, were there.  I then restarted from the install disk again, ran disk utility again to verify/repair the disk (okay x2) then repaired permissions. 

     

    Then I restarted the computer, and got the normal desktop...with a spinning beach ball, which prevented doing anything, even restarting.  Son reports this is what it's been doing, before it gets to a point when you can't even restart.

     

    SO...back to Disk Warrior.  This time I had it look at the files first, but rather than it finding those symbolic link files broken, it found some .plist issues it couldn't repair.  Actually those looked pretty trivial...one had to do with Microsoft Messenger, another with iphotomosaic. 

     

    I had it rebuild the directory again, because that's what DW does, and it said there was little to no difference between the new directory and the rebuilt one (might have been one change).   I had it replace the directory...and got an error message saying there was a problem with the disk and I should do the rebuild again.  But the rebuild option was greyed out, in fact DW was frozen now. 

     

    So I shut everything down and will be trying again tomorrow.

     

    Despite the hardware tests coming up fine, I suspect there is a fault in the disk itself.

  • ChicagoAl Level 1 Level 1 (0 points)

    Thanks, Allan, but I wouldn't say 'stealing,' I imagine Chris is new here and posted here accidentallly.   He may not even find his way back here.

  • ChicagoAl Level 1 Level 1 (0 points)

    Won't be able to look again until late today, but on last restart got that loud single note when restarting.  AND an error message from Disk Warrior that suggests there's not enough RAM.

     

    AHA!

     

    I don't remember how much RAM is on this iMac, pretty sure it was upgraded at some point before we got it.  It may have failed, the slot may be bad, whatever.   I may even have some sticks of the right memory around the house that I can swap in to see if that helps.

     

    These things can be frustrating but there is a certain problem-solving pleasure in them too.   At least if it's not your own computer you're working on!

  • baltwo Level 9 Level 9 (61,900 points)

    Let us know how the RAM swap turns out. If AHT didn't find any issues, Rember might.

  • ChicagoAl Level 1 Level 1 (0 points)

    RAM swap did not help. :- (  At least my wife's iMac (same generation) now has 4GB rather than 2.

     

    Ran Disk Warrior, rebuild could not replace the existing directory due to a 'disk malfunction.'   The warning message said that the problem is likely to get worse and to immediately back up everything on the drive.  Which we've done.  I then booted from Drive Genius, which has failed to repair the drive after three attempts.

     

    So it appears the drive is failing, yet the Hardware tests all come up fine as does S.M.A.R.T status...suggesting that it's not to be relied upon.

     

    Anyway, we have everything backed up via Time Machine, and after looking around, a replacement of the drive doesn't really look that difficult.  I've replaced hardware before, including a fan in one of the 'lamp' iMacs, just need the suction cups.

Previous 1 2 Next