Previous 1 7 8 9 10 11 Next 182 Replies Latest reply: Apr 24, 2015 4:28 AM by dragvra Go to original post Branched to a new discussion.
  • Rahul Francis Level 1 Level 1 (0 points)

    Just a quick update (Dec 2013)

     

    This still works for Windows 8.1! You no longer need to right click for run as administrator (just click once, then go to manage, then click run as administrator!)

     

    In addition, for Boot Camp 4 you have to click once on setup.exe, then Manage, then Troubleshoot Compatibility. Keep "troubleshooting" it and check it worked on previous operating systems. You can then press Windows 7 and it will run. Otherwise, it will give you an error saying "This software is only supported on Windows 7"

  • piggynuts Level 1 Level 1 (0 points)

    @ Aplet,

     

    thanks for posting, however, it did not work.  Your answer was incomplete, as the file copied to the desktop is not being read by bootcamp, and thus does not change the program.

     

    CORRECT WAY TO MODIFY THE BOOTCAMP FOLDER... some steps are probably unncessary, but this is how i got it to work, takes 15 minutes:

     

    Finder>Applications>Utilities> right click on Bootcamp> Show package contents> Contents> Info.plist

    Right click and Get info on Info.plist and click the lock at the bottom of the info page and enter your password.

     

    Add the user "Everyone" AND your own user account (obviously admin account) Read and Write permissions to the Plist file AND to the Contents folder itself or you won't be able to add anything new to the folder. 

     

    Open Plist and erase the 5-5 Macbook pro line towards the bottom, or whatever Macbook you're trying to install Windows 8 or 8.1 on.

     

    Save the file to the desktop and rename it info.plist

     

    Send the New info.plist to the contents folder, and Authorize permissions. It will time out and not completely overwrite the file, even though you have granted permissions, I gave it about 5 minutes.  Force restart the PC. 

     

    Try again, and it will timeout, I force restarted after about 5 minutes again.

     

    On second reboot, OPEN Bootcamp assistant, info.plist will be dark grey and should have a file size of zero KB since we've tried to over-write it twice, it now contains no data.  

     

    Close Bootcamp and immediately delete the original info.plist, it will say the file is in use, click OK. 

     

    Rename your new info.plist to info2.plist and place it in the Contents folder

     

    Now you can rename it to info.plist.

     

    Reboot, open bootcamp, problem solved.  

     

    If you have a second Mac, an easy work around would be to Target disk mode the one you want to install windows 8 as an external hard drive, then navigating to the folder and over writing info.plist with the modified one without having to do all these tricks. 

     

    Screen Shot 2013-12-08 at 5.42.13 PM.png

     

    Here is a photo of my success: Screen Shot 2013-12-08 at 5.52.45 PM.png

    If installing from a USB flash drive you can also modify which ones are compatible by editing the Pre-USB section in  the Plist, and adding the <string>MacbookPro5,5</string> to it.

  • piggynuts Level 1 Level 1 (0 points)

    I wanted to add that the post above from me is a guide of how to hack bootcamp so you can install Windows 8 on the 2009 MB Pro without doing all the silly work arounds mentioned in the beginning of this guide. 

     

    Once 8 is installed, you run the 4.5 boot camp drivers, reboot, then run the 5 bootcamp drivers as mentioned by projectreckless. 

  • piggynuts Level 1 Level 1 (0 points)

    You actually need to remove the PRE from the USB section, so it only says USB supported etc.  Once you delete the PRE and restart bootcamp, youll be able to install from the flash drive. 

  • Karyta Level 1 Level 1 (0 points)

    I found this video very useful, since what was listed here didn't work for me.  I think it is becuse of Mavericks.

     

    It is modifying boot camp assistant with terminal.

     

    http://www.youtube.com/watch?v=WQE2vbpYwRs

  • adzski Level 1 Level 1 (0 points)

    Hi ,

     

    does anyone have a win driver package for the pci express interface on a mid 09 macbook pro?

     

    This didnt work in bootcamp win 7 and now not in bootcamp win 8 but weirdly does ework in bootcamp win xp.

     

    I get a code 12 message,

     

    thanks

  • Mikey Nach Level 1 Level 1 (0 points)

    When I get to the step where you right click 'bootcamp.msi' and open it as an administrator it gives me an error message saying "This file does not have a program associated with it for performing this action."  I double  checked and the .msi file is set to open with windows installer.

     

    When I open the file normally it works fine, however that procedes to give the "needs special priveledges message". When I open it as an administrator it gives me the "file not associated with program message". Can anyone help me fix this? Thanks.

  • lee juwon Level 1 Level 1 (0 points)

    I'm having the same issue and I've checked on my file associations, everything's fine there. I'm lost now.

  • Mikey Nach Level 1 Level 1 (0 points)

    I found a solution to my problem. Instead of opening bootcamp.msi as an administrator all you have to do is copy the setup.exe from bootcamp 4.0.4033 and and paste it in bootcamp 5.0.5033 (in the same location as the original setup.exe). This should replace it with the old one. Then go to the bootcamp.msi file that wont open as administrator and rename it to BootCamp64. Now run setup.exe and it should work normally.

  • lee juwon Level 1 Level 1 (0 points)

    Thanks a lot, just did it now and it works. Now I'm checking if the Nvidia Driver updates will be managed by Bootcamp services.

  • MMello Level 1 Level 1 (0 points)

    Hey ProjectRentless,

     

    Thank you very much for theese tips, they worked great for my Mid 2009 MBP 13".

     

    If anyone needs so, I was also having trouble with the Windows 8 suddenly freezing and this topic resolved this problem: https://discussions.apple.com/thread/4007397?start=75

  • thezachmaster Level 1 Level 1 (0 points)

    I have been able to follow this tutorial, but when I get to installing Win8, it asks for drivers to install before I can actually install anything, and the computer will not reconize the drivers I have installed from the apple website on my USB. I am stuck with a "Windows Setup" with a selection area to select drivers to install, and on the bottom there are a browse, rescan, and next buttons (next is gray'ed out). In the install process, where there is 1. Collecting Information and 2 Installiing Windows, I am still in 1.

     

    Running 10.9.1 on a 2009 MacBook Pro 15"

     

    Help PLEASE,

    Thanks,

    Zach W

  • NDIrish821 Level 1 Level 1 (0 points)

    This helped so much. Thank you for taking the time to write this out. Worked like a charm!

  • Alexandros K Level 1 Level 1 (0 points)

    Hi all!

    I have a similar problem. I installed to w7 64b, on a Macbook Pro 17" (mid 2009) with 8GB RAM. I'm now runnin Mavericks (10.9). When I use W7 I get prompted to upgrade to bootcamp 3.3 (I'm on 3.2).

    I download it, install it and after reboot, I still have 3.2!

    I read millions of discussions about it and finally Apple replied to install 4.0.4033.

    The thing is, that I start the install, the display driver installs and everything seems ok, till the point that the "BootCamp64.msi" file is missing. I think that this file supposed to be the older (3.2) version that needs to be removed. I dowloaded (again) the 3.2 bootcamp (that is an.exe file) to install again or repair, but it keeps asking of this bootcamp64.msi file that's missing.

    I wouldn't have a problem to stay on 3.2 but my computer freezes many times a day - what can I do - any ideas please?

  • Epidural Level 1 Level 1 (0 points)

    Thank you so much for the install instructions. I have finally have windows 8 and maverick all in one package.

Previous 1 7 8 9 10 11 Next