Previous 1 2 Next 22 Replies Latest reply: Aug 14, 2013 5:02 PM by prd725
Danny Lukic Level 1 Level 1

I am just setting up a new laptop, and installed the latest java 7 update 17. It works fine on Firefox, but will not work in Safari. Before you tell me "dont use java", I have to. My works website uses java for download, so I must have it (until we move to Aspera).


I have checked both the system Java version (latest, and enabled) and the browsers settings. Java is enabled in all places it should be, yet I cannot get it to work in Safari. The Java website even tells me it cant even verify if Im running java or not. This is very annoying.


So to recap:


Safari: Enable Plugins, Enable Java and Enable Javascript is turned on.

Block Pop Ups is turned off.

Java 7 Update 17 has been installed on this computer.



System Tells me Im running the recommended version.

Security: Is set to HIGH, I even turned it lower at one point.


Ive repaired permissions, rebooted, etc. but no luck.


Any ideas?

15" Intel Mac Book Pro, Intel Mac Mini, MacPro, Mac OS X (10.4.10)
  • Aleks_Ivic Level 1 Level 1

    I can definitely say it was working last week but when I tried to remote desktop into work which uses Java, but today it doesn't work!  I think possibly modifying the blacklist file will resolve things (will need to investigate it myself).

  • Aleks_Ivic Level 1 Level 1

    Actually, they didn't block it (just read the plist file).  Upon upgrading to 6.0.3 I believe they just made it inactive.


    Visit this Sun Java site   and active it by clicking on the inactive plugin grey box.

  • pedrottic Level 1 Level 1

    Excelent! I was having the same problem and that just solved it. It should be a simpler way to do that.

  • simoncatibm Level 1 Level 1

    I have the same problem on Safari on Windows 7. I followed all the usual issues like checking the registry etc, but no luck.

  • waldjue Level 1 Level 1

    Excelent! I was having the same problem and that just solved it.

  • RAFGOLD Level 1 Level 1

    Well done Aleks_Ivic.

    I was having the same annoying situation just as Danny Lukic.

    And have done all, exactly as he did.

    I did what you suggested and it worked just fine!

    Everything is all right now!


  • jonasdenadai Level 1 Level 1

    Thanks, Aleks Ivic's suggestion worked for me.

  • ObiSant Level 1 Level 1

    That solved my problem too! Thank you!

  • Danny Lukic Level 1 Level 1

    I had actually mentioned that I had already gone to the Java site to detect what version I was running, and it would fail to do so each time in Safari. The link Alek posted is another test from Javas site (could not find it directly on java) but I went there and it told me I was using the latest java, yet the other java test page still would fail to detect and determine what version I was using, and java overall still wasnt working in Safari.


    An IT guy from our office found that if you disabled java in Safari prefs, closed Safari, restarted Safari, reenabled Java, then went to the java test site, I would get the prompt and java would work. I did that. It took about 6 or 7 attempts of trying to load that java page before it finally detected java and it started working. Major headache.

  • uhu Level 1 Level 1

    being at the same point (installed Jave 7 release 17 yesterday) but Safari all the time displays "missing plugin". Following your advice above the Oracle testpage tells me (in Safari) that it detects an older version of Java and when clicking the test link nothing happens except the anoying "missing plugin" placeholder.


    I'll give up, this is the second time Safari runs into such problems with Java. There are other browsers around!

  • writergirl2 Level 2 Level 2

    Excellent, thanks, was driving me nuts

  • Singrkel Level 1 Level 1

    I work for a financial institution that uses Java for the online banking system. It works amazing as we have almost a 0% fraud rate. I don't hate Java like the rest of the world...anyway...on to my question lol


    I have heard quite a few of our customers say that they are having a "Blocked Plug-In" today rather than the normal "Missing Plug-In" message. Has Apple blocked Java again or is it some wierd setting? This is the message our customers were receiving when Apple blocked it last time. However, our customers couldn't use Firefox either and this time they can. I haven't seen any news reporting it yet. It's imperative for our customers...I wish Apple would just leave it alone. If I purchase a $2500 computer, leave it alone and let me control it. Don't babysit me. This is why I will never ever ever buy a Mac. Not a fan of communism.

  • rscheu Level 1 Level 1

    Thans Aleks, this worked for me too!

  • sivasainath2005 Level 1 Level 1

    Hi even I am facing the same problem but java is working when I delete npJavaPlugin.dll file from safari java plugin folder. Now when I close and reopen safari that file again comes there. please help me . I am using safari 5.1.7 in Win 7 64

Previous 1 2 Next