5 Replies Latest reply: Apr 11, 2013 10:55 PM by Paulo Breim
Paulo Breim Level 1 Level 1 (0 points)

When I use the option to save attachments, mail not save the attached files and don't show any error message.

The console shows:


19/03/13 12:16:29,385 com.apple.security.pboxd[2781]: CGSGetWindowTags: Invalid window 0x2f0

19/03/13 12:16:29,385 com.apple.security.pboxd[2781]: kCGErrorFailure: CGSSetHideOnDeact: error getting window tags

19/03/13 12:16:32,706 com.apple.security.pboxd[2781]: CGSReleaseWindow: Invalid window 752

19/03/13 12:16:32,706 com.apple.security.pboxd[2781]: _NXTermWindow: error releasing window (1000)

19/03/13 12:16:32,706 Mail[604]: An exception occurred during invocation of -[AttachmentManager _saveAttachment:toPath:window:]

19/03/13 12:16:32,707 Mail[604]: *** -[NSURL initFileURLWithPath:]: nil string parameter

19/03/13 12:16:32,707 Mail[604]: (

          0   CoreFoundation                      0x00007fff90b6fb06 __exceptionPreprocess + 198

          1   libobjc.A.dylib                     0x00007fff8e9143f0 objc_exception_throw + 43

          2   CoreFoundation                      0x00007fff90b6f8dc +[NSException raise:format:] + 204

          3   Foundation                          0x00007fff8bd2f467 -[NSURL(NSURL) initFileURLWithPath:] + 81

          4   Foundation                          0x00007fff8bed078c -[NSFileWrapper(NSDeprecated) writeToFile:atomically:updateFilenames:] + 204

          5   Message                             0x00007fff97628089 -[NSFileWrapper(HFSExtensions) _Message_writeToFile:atomically:updateFilenames:] + 378

          6   Mail                                0x0000000104acfe74 Mail + 1015412

          7   CoreFoundation                      0x00007fff90b6309c __invoking___ + 140

          8   CoreFoundation                      0x00007fff90b62f37 -[NSInvocation invoke] + 263

          9   CoreMessage                         0x00007fff8ae0a867 -[MonitoredInvocation invoke] + 225

          10  CoreMessage                         0x00007fff8ae22eb2 -[ThrowingInvocationOperation main] + 33

          11  CoreMessage                         0x00007fff8adcf042 -[_MFInvocationOperation main] + 431

          12  Foundation                          0x00007fff8bd66036 -[__NSOperationInternal start] + 684

          13  Foundation                          0x00007fff8bd6d861 __block_global_6 + 129

          14  libdispatch.dylib                   0x00007fff90e00f01 _dispatch_call_block_and_release + 15

          15  libdispatch.dylib                   0x00007fff90dfd0b6 _dispatch_client_callout + 8

          16  libdispatch.dylib                   0x00007fff90dfe1fa _dispatch_worker_thread2 + 304

          17  libsystem_c.dylib                   0x00007fff8bc17d0b _pthread_wqthread + 404

          18  libsystem_c.dylib                   0x00007fff8bc021d1 start_wqthread + 13





When I try to attach a document, attached document is empty.


The console shows:


19/03/13 12:18:14,430 com.apple.security.pboxd[2781]: CGSGetWindowTags: Invalid window 0x314

19/03/13 12:18:14,430 com.apple.security.pboxd[2781]: kCGErrorFailure: CGSSetHideOnDeact: error getting window tags

19/03/13 12:18:14,612 com.apple.security.pboxd[2781]: CGSCopyWindowColorSpace: Invalid window 0x314

19/03/13 12:18:19,180 parentalcontrolsd[2844]: FCCreateAppSignature [853] -- *** SecCodeSignerAddSignature returned: -50 on pass: 2

19/03/13 12:18:20,593 com.apple.security.pboxd[2781]: CGSReleaseWindow: Invalid window 788

19/03/13 12:18:20,593 com.apple.security.pboxd[2781]: _NXTermWindow: error releasing window (1000)

19/03/13 12:18:49,335 parentalcontrolsd[2844]: FCCreateAppSignature [853] -- *** SecCodeSignerAddSignature returned: -50 on pass: 1



Thank you for your help

  • Eric Root Level 8 Level 8 (35,070 points)

    Try setting up another admin user account to see if the same problem continues. If Back-to-My Mac is selected in System Preferences, the Guest account will not work. The intent is to see if it is specific to one account or a system wide problem. This account can be deleted later.


    Isolating an issue by using another user account


    If the problem is still there, try booting into the Safe Mode.  Shut down the computer and then power it back up. Immediately after hearing the startup chime, hold down the shift key and continue to hold it until the gray Apple icon and a progress bar appear. The boot up is significantly slower than normal. This will reset some caches, forces a directory check, and disables all startup and login items, among other things. If the system operates normally, there may be 3rd party applications which are causing a problem. Try deleting/disabling the third party applications after a restart. For each disable/delete, you will need to restart if you don't do them all at once.


    Safe Mode


    Safe Mode - About


    General information.


    Isolating issues in Mac OS X

  • Paulo Breim Level 1 Level 1 (0 points)

    Thank you Eric, let me tell what is the situation now.


    I tried another administrator user and the problem persists.

    I tried running in Safe Mode and the problem still exists.


    After some more tests I've isolated the problem a bit more and now I have a bizarre situation.

    Running in safe mode or normal mode .


    1 - Close mail

    2 - If I drag and drop a file over de mail's icone at the dock bar, the mail is open in the sent mail with the file attached correclty.

    3 - If I close the message and drag and drop again over and over, the file is attached correcly

    4 - BUT if drag and drop a diferente file, it is attached with zero bytes and thenceforward not attached correct any more.

    5 - If I clise the mail and drag and drop again, work well again.


    So It only works in the first attached file.

    If I start opening the mail and then attaching filkes, not works.

  • Paulo Breim Level 1 Level 1 (0 points)

    New tests.


    When I drag and drop a file in the mail, it only accept the first file that I attached since open mail, any other file does not attach.

    if I try attache the same first file, works correct.

  • Paulo Breim Level 1 Level 1 (0 points)

    I did more tests on the problem of saving files attached.


    Right clicking on the Save Attachement ... ands choosing Download Folder  DOES NOT SAVE, but with the option to Save Downloads Folder, works well.

  • Paulo Breim Level 1 Level 1 (0 points)

    Well Here is the solution


    Since rebooting my mac in Safe Mode and the problem still there, the conclusion is that some Mail files is corrupted.

    In this case the solution is reinstall Montain Lion without lost your data, configurations etc


    1 - Restart your System pressing Command + R

    2 - Choose re-install system

    3 - Go to drink a beer or wine for 3 hours


    Be sure that your are connect in the internet, preferable by RJ45 (best speed)