5 Replies Latest reply: Mar 21, 2013 10:52 AM by BDAqua
danielmacias Level 1 Level 1 (0 points)

Hola a todos.

Escribo porque necesito ayuda con la versión de la librería libxml2.2.dylib.

Al ejecutar la aplicación "RADR" el sistema me avisa de un error y la aplicación no se ejecuta.

Según leo en el reporte, el problema es causado por la versión de la librería, que esta es versión 9 y el programa solicita la 10.

¿Qué puedo hacer?¿Puedo actualizar la librería?¿Cómo la actualizaría?

 

 

El error que el sistema reporta es el siguiente:

 

-------------------------------------------------------------------------------- ------------------------------------

 

Process:     RADR [398]
Path:        /Applications/RADR.app/Contents/MacOS/RADR
Identifier:  com.m-nus.RADR
Version:     ??? (???)
Code Type:   X86 (Native)

Parent Process:  launchd [324]

 

Interval Since Last Report:      1818 sec
Crashes Since Last Report:       1

Per-App Interval Since Last Report:  0 sec

Per-App Crashes Since Last Report:   1

 

Date/Time:   2013-03-19 20:34:12.742 +0100
OS Version:  Mac OS X 10.5.8 (9L31a)

Report Version:  6

Anonymous UUID:  859D6594-C208-400A-B9CD-036EF53C57ED

 

Exception Type:  EXC_BREAKPOINT (SIGTRAP)

Exception Codes: 0x0000000000000002, 0x0000000000000000

Crashed Thread:  0

 

Dyld Error Message:

  Library not loaded: /usr/lib/libxml2.2.dylib

  Referenced from: /Applications/RADR.app/Contents/MacOS/RADR

  Reason: Incompatible library version: RADR requires version 10.0.0 or later, but libxml2.2.dylib provides version 9.0.0


MacBook, Mac OS X (10.5.8), Run program RADR
  • BDAqua Level 10 Level 10 (120,035 points)

    Hola,

    ¿Tiene un enlace a esta aplicación? General la App incluirá la versión de libxml2.2.dylib que necesita, pero puede ser un alias que apuntan a una versión incorrecta, en / usr / lib /

  • danielmacias Level 1 Level 1 (0 points)

    Gracias por tu atención BDAqua

     

    Este es el enlace a la aplicación

    --> https://radr.dj/beta/download <--

     

    Miré en la ruta que indica el fallo (/usr/lib/libxml2.2.dylib) pero no sabía como mirar la versión ni que hacer con el archivo.

  • BDAqua Level 10 Level 10 (120,035 points)

    OK, le eché un vistazo a la PKG, que no contiene esa lib, creo que debe ser en función de las aplicaciones requeridas otros a tenerlo instalado, que uno tiene?

    Requisitos de software:
       Native Instruments Traktor Pro 1.2 superior y / o Serato Scratch Live y / o Ableton Live.

  • danielmacias Level 1 Level 1 (0 points)

    ¿Entiendo que lo que quiere decir es que esa lib debe de tenerla las otras aplicaciones.? Si es así, usando solo Traktor no me ha dado problemas nunca.

    Yo tengo instalado Native Instruments traktor Pro superior al 1.2. hace mucho tiempo y el software RADR lo he instalado recientemente.

    El error me da al ejecutar RADR. LLevo tiempo usando solo Traktor y nunca tuve problemas.

    Traktor es un software para mexclar música y RADR  toma los nombres de las canciones para emitirlos por twitter.

     

    Si usted es de habla inglesa y se siente más comodo esciribiendo en ingles, podemos tratar el problema en ingles.

     

    Le estoy muy agradecido por el interes que está mostrando, gracias.

  • BDAqua Level 10 Level 10 (120,035 points)

    Yes English would be better for me... been like 60+ years since I took Spanish.

     

    Well, I don't know where to get it, or where it thinks it should be, it isn't included in RADR...

    RADRpkgContents.gif

    I think my libxml2.2.dylib came with OpenOffice Install, no idea which version might have version 10.0.0 in it.

     

    Here's the same problem with a different APP...

     


    http://vdrift.net/Forum/showthread.php?tid=1662