7 Replies Latest reply: Mar 28, 2013 5:09 PM by baltwo
workindog Level 1 (0 points)

I had no luck from Apple tech support on this one! I hope this works for you and is helpful.


I had the logic board replaced on my MacBook Pro and had to wipe the hard drive. When I got it back, of course Java 6 is gone. I tried to install the Java 2013, but when it was almost finished it gave me a message that the install failed, and I should contact the software manufacturer. Figuring it was apple--as the Oracle site says--I called.


They walked me through installing Java 7, which I didn't want or need. And then when I went back and tried to install again, same message. They gleefully informed me that since I now have Java (7) that their work was done, even though Chrome was now broken, none of my java 32  bit games worked, and I could no longer access my bank accounts. Not their problem, too bad.


Here is the fix I finally stumbled upon, and I hope this is the correct order.

1. I followed the instructions for uninstalling Java 7 on the oracle website

2. I went into /System/Library/Frameworks/JavaVM.framework/Versions

3. The folders "Current" or "CurrentJDK" (sorry I can't remember if one or both!) appeared to be empty or orphaned or otherwise not working.

4. I deleted both of them.

5. I ran the java 2013 install program again, and it worked, it did not fail, and successfully installed

6. I then had to futz with the browsers to get them to use Java 6. Chrome worked well, safari is not cooperating so far.


I am really disappointed that the tech people not only did not solve the problem of their installer not working, they made it worse by having me install java 7 and making it much much worse, leaving stuff I relied on unusable.


If there are other hints any body has, do share.

1.5 GHz PowerBook G4, Mac OS X (10.4.9)
  • William Lloyd Level 7 (21,040 points)

    Java 7 is not an Apple product.  It is an Oracle product.

  • workindog Level 1 (0 points)

    Thank you... Not quite. 


    Yes, Java 7 is from Oracle.  And Java for other computers.  But I am not talking about installing 7, I am talking about 6.


    The Java 6 INSTALLER is Mac specific, and downloaded DIRECTLY from APPLE, NOT from Oracle.  The Oracle site specifically  says that Apple does Java 6 for Macs, NOT them, contact Apple. 


    So here I am, sharing the fix. Since other people might have this problem with their macs, it seemed that the MAC forum would be the place to put it.


    I hope it will help someone.


    Thank you... Chris

  • William Lloyd Level 7 (21,040 points)

    Apple's latest update completely kills Java 6 in the browser.  It's dead, and it's not secure, so it's not coming back.  Read the release notes for the most recent Java update from Apple; it notes it removes Java 1.6 from the brower permanently.  Read the release notes carefully:




    If you want to use Java applets, you need to download Java 1.7 from Oracle.


    If you're running Java APPLICATIONS, then Java 1.6 from Apple is still working.

  • workindog Level 1 (0 points)

    Ah... so then we are in agreement here!  We are clear now!


    • Java 1.6 posed a security risk, hence java 1.7 was released
    • Java 1.7 is the recommended but not compatible with all things,
    • Java 1.7 is 64-bit only, and many java apps and Chrome browser are 32-bit
    • Java 1.7 can be rolled back if you need to do so
    • the instructions are at Oracle's site,
    • the installation program is an Apple product,
    • if the installer fails, I can suggest a reasonable solution to attempt, which worked for me.


    Yes. Java applets vs java applications. Exactly. Both  no longer working after the java 1.7 install. So get Java 1.6  from Apple, you say?  That is what my post is about:   Installing it and having the installer fail, and how to fix it. The page you linked says, "this update disables the Java SE 6 applet plug-in."   Disabled, not permanently removed. Disabled can be re-enabled.


    Apparently many others also have this need to have Java 1.6 back, or you wouldn't see all the instructions sites all over the place--including at Oracle--on how to roll it back.  I just wish I hadn't had to look everywhere for so long to find it.


    Fare thee well, valiant knight.


  • baltwo Level 9 (62,215 points)

    http://support.apple.com/kb/HT5559 provides the steps to reenable Java 1.6 plug-in.

  • workindog Level 1 (0 points)

    Thank you, i did consult that. Good link. 


    Sadly that did not work because the installer failed repeatedly before getting to that step. The neeed files were not even there. But I did try that!


    Maybe if some find that those steps don't work it is also because of a problem with those folders.


    But thank you for the link.

  • baltwo Level 9 (62,215 points)

    Which installer? The articles says you have to install both Java for OS X 2013-002 and the latest version of Java 7 from Oracle, before proceeding.