4 Replies Latest reply: Mar 21, 2013 12:54 PM by Ralph Johns (UK)
Timothy Barron Level 1 Level 1 (5 points)

I am able to see my family and can text chat but they make no sound. 

Meanwhile, they are able to see and hear me.

Again, without any changes the audio on my end has completely stopped, although all other sound applications work fine- just iChat sound is not working.

All the audio and video options that I can adjust are set to play and are turned on and have not been changed when the sound suddenly stopped and has never restarted.

 

I believe it is a connection issue because the connection doctor is 100% in audio and video nearly all the time but drops in audio for a second once in a while then returns to green 100%. 

 

I have OS 10.6.8 and iChat version 5.0.3

 

Any ideas?

 

Tim


iMac, Mac OS X (10.3.x)
  • Ralph Johns (UK) Level 9 Level 9 (69,735 points)

    Hi,

     

    Whilst LexSchellings is right that there can be Bandwidth (yor portion of your Internet Connection) issues there are some things to check and possible tweak.

     

    If your can get Video  but not Audio  then the fault could be at thier end rather than yours.

     

    First.

    They should check the Video menu and see that the option for the Audio (Microphone) is Enabled (The wording changes in some versions)

    2nd

    They should then go to the iChat Menu > Preferences > Video pane and check the green Response bar is moving when they talk.

    3rd

    The Microphone selected in the drop down on the same Video pane should also match the choice in System Preference > Sound > Input tab

    3a)

    The volume setting in here should be high enough to get the blue response bar to at least 1/2 way, preferably 3/4s but without banging into the right hand end.

     

    Summary so far.

    They should check the Mic is On in the Video menu

    That the Mic matches in iChat and the System Preferences.

    That they can see the blue bar in System Preferences > Sound s and the green bar in the video pane of the iChat Preferences move when the speak.

     

    Next.

    During a chat open the Connection Doctor.

    This will tell you the Local and the Buddy's Bit rate and Frame rate as well as the two green bars.

     

    The Bit rate needs to be over 128kbps

    The frame rate needs to be 15fps or higher. (lower than 10 and the video gets jerky)

     

    The bit rate will fluctuate but should not vary that much.

     

    In iChat > Preferences > Video Chat > Bandwidth Limit you can directly and sometime adversely effect the Video with this setting.

    It should ideally run with the setting at NONE.

    However some ISP internet service vary so much that this is not practical.

    Do not use it at less than the 200kbps setting.  500kbps may be "best".

     

    In the days when many people's internet connection was 256kbps download and 128kbps upload the ichat Buffering  would cope with fluctuation in the connection speed.

    It would do this by dropping an odd video frame or two.

    There comes a point though when the Audio cannot not be synced when this happens and iChat will drop the audio.

     

    A 5% variance in a 128kbps upload will drop the feed to below 100kbps by the time the connection to the ISP overheads are taken in to account.

     

    However a 5% fluctuation on a 10Mbps service will be more than some people actually get for a connection.

    This is why dropping ichat to 500kbps can smooth out the connection so that fluctuations are less critical.

     

    It can also help if one end is so much faster than the other end.

    In some cases where a Fast Buddy "Calls" a slower one iChat can seem to "think" the buddy is not responding.

     

    Summary of this

    Using the Connection Doctor balance the Connection speeds with the Bandwidth Limit.

    Do not use the lowest setting as it is actually below the min needed for Video chats (1-1)

    500kbps should smooth out most internet fluctuations and still be high enough for 4 way Video chats

     

    Setting the Bandwidth Limit can also help if the two of you are on vastly different speeds.

     

    You can change the Bandwidth Limit during a Live chat.

    The Connection Doctor will not "jump" to the new speed but will get there gradually as the Buffering smoooths out the change.

     

    Next (or really at the same time)

    The Buddy needs to be possibly doing this at their end as well.

    Change the setting on one computer and only proceed at the other when the Connection Doctor shows the new speed.

     

    Finally.

    If they have a Headset  (Mic and Headphones) then it may be crucial about how these are set up in iChat and System Preferences.

     

    Open System Preferences > Sound > Input as well as the iChat > Preference > Video Section.

    In both places change the sound input choice to anything but the headset.

    Now in System Preferences Set the Mic here "First"

    Then set it in iChat (2nd)

    Repeat for System Preferences > Sound > Output and the output choice in iChat.

     

    It has been seen that blue tooth headsets in particular need the System Preferences > Sound > Input set up before any app  is set up to use the Mic.

    It seems that some USB mics also need this.

     

     

     

    3Sigcopy2.png
    9:21 PM      Wednesday; March 20, 2013

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Timothy Barron Level 1 Level 1 (5 points)

    Gentlemen,

     

    Thank you for the great responses.  My wife and I went through the fixes and have determined that something is wrong with the iChat microphone on her end (in the States with the better computer and better connection)

     

    Her microphone level meter responds fine when we check it in the main system preferences.  However, when in iChat her microphone/audio meter does not register at all. (the green bar does not light up at all). 

    Do you know what might be wrong that prevents the iChat microphone from registering sound?

     

    Thanks for the help you guys are bloody brilliant.

     

    Tim

  • Ralph Johns (UK) Level 9 Level 9 (69,735 points)

    Hi Tim,

     

    There are three possibles.

     

    1) in the Video menu or iChat or Messages the items that deals with the Microphone is not ticked.

    In iChat it reads "Microphone enabled"

    In Messages it reads "Audio enabled".

    Screen Shot 2013-03-21 at 19.39.54.png

     

    2) The Mic in iChat (Preferences > Video section) may not match the one in System Preferences > Sound > Input.

    Screen Shot 2013-03-21 at 19.45.01.png

     

    3) It is the mic on a headset (or is at least having the same issue) where iChat got set "first" and then System Preferences 2nd.

     

    In My pic above I am using an external USB mic.

    It was set in System Preferences and then iChat as I happen to have had a Headset in use before and I tend to do it this way now.

     

    If it is not these and your posts seems to suggest you have actually checked these settings.

     

    Use another app that can record the Audio.

    Quicktime X in Snow Leopard, Lion and Mountain Lion can record the "Desktop"

    Launch the Player and chose the File Menu > New Audio recording or New Screen Recording.

    The Audio should definitely record the Audio  and I am sure the Screen Recording also does.

    If you have an earlier OS you will have to have the Pro key for your Quicktime Version to make Recordings.

     

    Also try Photo Booth if you have it.

     

    If you have FaceTime set that Mic up in that and try that.

    GarageBand and iMovie can also be used to test.

     

     

    Next open MIDI Audio Set up in Applications/Utilities and check the settings for the input are linked to the mic in use and are set to either the 44100 or the 48000 setting.

     

     

    3Sigcopy2.png
    7:53 PM      Thursday; March 21, 2013

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously