Previous 1 2 Next 24 Replies Latest reply: Aug 14, 2013 9:58 PM by Bejoyful Go to original post
  • CoyoteCreek Level 1 (0 points)

    Happy for them but not for me

  • lrr394 Level 1 (5 points)

    What you might need to do is to enable Java vis Safari.  To do this, do the following


    Safari > Preferences > Security > Enable Java.

  • Beatlegeus Level 1 (0 points)

    I had this problem too - tried everything!


    Finaly I tested it on


    Accepted to run their applet > It then showed it was installed correctly and after this it work on my bank and the other places I needed it.


    Very strange but it worked for me ...

  • thomas_r. Level 7 (30,700 points)

    I didn't see this topic before, but I find it very disturbing that so many people are trying to get Java working and are even disabling security features of their machines in order to do so. Java is the number one source of malware infections on the Mac right now! It's simply too dangerous to be playing games with at this time. See:



    Note that there is currently a known vulnerability in Java that as yet has no fix.

  • meow1954 Level 1 (0 points)

    My computer updated and I am having the same problems with playing games.  It says my Java is not installed and I'm pretty sure in has to do with the plug in that was blocked because of security issues. 


    I know Oracle gave a previous update to address this problem but it no longer seems to work once the computer updated. 

    Is this going to happen everytime an update occurs?

  • MoLiver4u Level 1 (0 points)

    If it's any consolation to those experiencing problems, I've found that Firefox works fine with Java....Safari is still crapped out...thanks Apple, for letting me decide for myself whether I want to take a security risk or not.:P

  • kcdaisley Level 1 (0 points)

    What I didn't think to do before, was to click on the grayed out words "Disabled app" or whatever words appear in the space that Java should be running. You'll then be prompt to allow appa to run. Click Allow, and you're done.


    To the comment above about lowering the security options in System Preferences: I tried that option without success. If you also tried this, please remember to restore the security setting to HIGH to protect your Mac.


    Good luck.

  • FriskyWf Level 1 (0 points)

    Clear browser history in Safari then quit Safari.
    Run Mac's Disk utility program,
    In Disk Utility: Select Mac HD, Select Repair Disk Permissions, when done you may

    Restart Safari


    Some extensions can cause Browsers to crash when in doubt, delete all extentions, then load them one by one always testing the game that will not run under certain types of extentions.


    User of: iMac OSX, Ipod, Ipad

  • ScottCarlson Level 1 (0 points)

    This...Worked....awesome!  Something so simple and irrelevant


    My system became a problem when I clicked "do not notify me until next update" and then refused to launch any more java applications

  • Bejoyful Level 1 (0 points)

    This worked for me too. Great tip !

Previous 1 2 Next