8 Replies Latest reply: May 1, 2013 9:49 AM by realdannys
realdannys Level 1 Level 1 (0 points)

I recieved my new rMBP this week to replace my Macbook Air and join my iMac and Mac mini and immediately came across a problem.


Ive always had file sharing enabled on all computers and sent and recieved files to the iMac from the Macbook Air with ease.


However I tried to copy a file from the iMac to my rMBP and was provided with an error code (-8000 something) and was forced to relaunch finder.


I brought the Macbook Air back up (incidently I used migration assistant to copy files and settings over from MBA) and it was able to send and recieve files from iMac with no problems.


The first thing I notice is that the rMBP asks for an admin password to write to the iMac - the MBA doesn't. If I check permission settings on folders from the iMac from both machines they both have the same permissions set so I can't understand this.


Now the error code when trying to copy from rMBP to iMac doesn't appear - instead I send a file and Finder goes crazy and copies a 0 byte file with the same file name onto the iMac thousands of times until I force Finder to relaunch again.


Incidently I can send files to and from the Mac Mini without any issues - and I can as of now recieve files from the iMac ok, but not send to.


Its a very odd bug, ive tried repairing permissions on both machines and restarting both but ot no avail. Can anyone think of anything to delete/reset/try to fix this odd behavour?

MacBook Pro with Retina display, OS X Mountain Lion (10.8.3), Tried with both 10.8.2 & 10.8.3
  • Eric Root Level 7 Level 7 (32,410 points)

    Try setting up another admin user account to see if the same problem continues. If Back-to-My Mac is selected in System Preferences, the Guest account will not work. The intent is to see if it is specific to one account or a system wide problem. This account can be deleted later.


    Isolating an issue by using another user account


    If the problem is still there, try booting into the Safe Mode.  Shut down the computer and then power it back up. Immediately after hearing the startup chime, hold down the shift key and continue to hold it until the gray Apple icon and a progress bar appear. The boot up is significantly slower than normal. This will reset some caches, forces a directory check, and disables all startup and login items, among other things. If the system operates normally, there may be 3rd party applications which are causing a problem. Try deleting/disabling the third party applications after a restart. For each disable/delete, you will need to restart if you don't do them all at once.


    Safe Mode


    Safe Mode - About


    General information.


    Isolating issues in Mac OS X


    Troubleshooting Permission Issues



    Step by Step to Fix Your Mac


    Upgrade Nightmares  

  • realdannys Level 1 Level 1 (0 points)

    ah good thinking on creating the new user - I usually do this in all problem testing but forgot totally, sometimes you need a reminder! I'll do that now and report back.

  • realdannys Level 1 Level 1 (0 points)

    Hmm, ok well, creating a new user and the problems are gone.


    I go back to my actual users and the weird things are back. I'm trying to login with different names but its always giving me the request to enter admin password when I go to create a file or copy one - and it wont let me delete them afterwards.

  • Linc Davis Level 10 Level 10 (158,565 points)

    Problems such as yours are sometimes caused by files that should belong to you but are locked or have wrong permissions. This procedure will check for such files. It makes no changes and therefore will not, in itself, solve your problem.

    First, empty the Trash.

    Triple-click the line below to select it, then copy the selected text to the Clipboard (command-C):

    find ~ $TMPDIR.. \( -flags +sappnd,schg,uappnd,uchg -o ! -user $UID -o ! -perm -600 -o -acl \) 2> /dev/null | wc -l

    Launch the Terminal application in any of the following ways:

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

    Paste into the Terminal window (command-V). The command may take a noticeable amount of time to run. Wait for a new line ending in a dollar sign (“$”) to appear.

    The output of this command, on a line directly below what you entered, will be a number such as "41." Please post it in a reply.

  • realdannys Level 1 Level 1 (0 points)

    Hi Linc,


    Ive just run this on my Retina Macbook Pro first - as that has just started doing weird stuff.


    Retina-Macbook-Pro:~ Daniel$ find ~ $TMPDIR.. \( -flags +sappnd,schg,uappnd,uchg -o ! -user $UID -o ! -perm -600 -o -acl \) 2> /dev/null | wc -l


    Retina-Macbook-Pro:~ Daniel$


    Is what I got.

  • Linc Davis Level 10 Level 10 (158,565 points)

    Back up all data. Don't continue unless you're sure you can restore from a backup, even if you're unable to log in.

    This procedure will unlock all your user files (not system files) and reset their ownership and access-control lists to the default. If you've set special values for those attributes on any of your files, they will be reverted. In that case, either stop here, or be prepared to recreate the settings if necessary. Do so only after verifying that those settings didn't cause the problem. If none of this is meaningful to you, you don't need to worry about it.


    Step 1

    If you have more than one user account, and the one in question is not an administrator account, then temporarily promote it to administrator status in the Users & Groups preference pane. To do that, unlock the preference pane using the credentials of an administrator, check the box marked Allow user to administer this computer, then reboot. You can demote the problem account back to standard status when this step has been completed.

    Triple-click the following line to select it. Copy the selected text to the Clipboard (command-C):

    { sudo chflags -R nouchg,nouappnd ~ $TMPDIR.. ; sudo chown -R $UID:staff ~ $_ ; sudo chmod -R u+rwX ~ $_ ; chmod -R -N ~ $_ ; } 2> /dev/null

    Paste into the Terminal window (command-V). You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning to be careful. If you don’t have a login password, you’ll need to set one before you can run the command. If you see a message that your username "is not in the sudoers file," then you're not logged in as an administrator.


    The command will take a noticeable amount of time to run. Wait for a new line ending in a dollar sign (“$”) to appear, then quit Terminal.

    Step 2 (optional)


    Step 1 should give you usable permissions in your home folder. This step will restore special attributes set by OS X on some user folders to protect them from unintended deletion or renaming. You can skip this step if you don't consider that protection to be necessary, and if everything is working as expected after step 1.

    Boot into Recovery by holding down the key combination command-R at startup. Release the keys when you see a gray screen with a spinning dial.

    When the OS X Utilities screen appears, select

    Utilities Terminal

    from the menu bar. A Terminal window will open.

    In the Terminal window, type this:



    Press the tab key. The partial command you typed will automatically be completed to this:



    Press return. A Reset Password window will open. You’re not  going to reset a password.

    Select your boot volume ("Macintosh HD," unless you gave it a different name) if not already selected.

    Select your username from the menu labeled Select the user account if not already selected.

    Under Reset Home Directory Permissions and ACLs, click the Reset button.



    from the menu bar.

  • Eric Root Level 7 Level 7 (32,410 points)



    When you post a long Terminal command, how do you get it to post with the slider bar and arrows?

  • realdannys Level 1 Level 1 (0 points)



    Its been a while, but ive gone back to fix this problem.


    To remind of the problem. I can copy files FROM my iMac to my retina Macbook Pro with no problems. However if I try and copy a file TO my iMac it asks for admin password and then finder goes crazy with errors and often sending black files.


    Keep in my mind my Macbook Air I sold could copy to the iMac just fine, without any password request. So I wonder if its the rMbp. Also my rMBP can copy to the Mac Mini fine as well.


    Just to add the above, the same problem exists on the iMac. So I can connect to and copy files from the rMBP, but I can't copy files TO it, without the finder asking for password and then various errors occuring (and eventually fail) when actually trying to transmit the file.


    So I ran

    { sudo chflags -R nouchg,nouappnd ~ $TMPDIR.. ; sudo chown -R $UID:staff ~ $_ ; sudo chmod -R u+rwX ~ $_ ; chmod -R -N ~ $_ ; } 2> /dev/null


    on both my rMBP and the iMac, but the problem still exists...


    - Dan