12 Replies Latest reply: Mar 28, 2013 9:46 AM by Eric Root
Stephen Schulte1 Level 1 Level 1 (10 points)

TextEdit won't display recent files!  THIS USED TO WORK-- but now all I see is the words (greyed-out) "Clear Menu".  Not even sure what that means.


My recent files works fine in WORD and other applications that offer this.  Any comments appreciated as to how to get this feature back!


Best regards,



Steve Schulte

Friday 22 March 2013

MacBook Pro, OS X Mountain Lion, Also a Mac SE running 6.0.4 - not upgrading that!
  • CT Level 6 Level 6 (17,430 points)

    How many "Recent Items" have you selected in System Preferences, General?

  • Stephen Schulte1 Level 1 Level 1 (10 points)

    Thanks for the fast reply, CT!


    For a long time I had it set for 30.  Then earlier today I set it for 50.  Just now-- 10.  Still nothing.  Is a restart needed?  (I have just been quitting and restarting TextEdit, not shutting down my MBP-13 running 10.8.3)


    Appreciate any feedback--



  • CT Level 6 Level 6 (17,430 points)

    A restart is always a good troubleshooting method.

  • Topher Kessler Level 6 Level 6 (9,790 points)

    Open the Terminal and run the following commands (one at a time):


    rm ~/Library/Preferences/com.apple.TextEdit.LSSharedFileList.plist
    rm ~/Library/Preferences/com.apple.TextEdit.SandboxedPersistentURLs.LSSharedFileList.plist 


    Then try relaunching TextEdit to see if it now saves the recent documents properly. You can also find these files and removign them by holding teh Option key down and choosing Library from the Go menu in the Finder. Then go to the Preferences folder and scroll down to locate and remove them.

  • Stephen Schulte1 Level 1 Level 1 (10 points)

    I have tried this - actually removed all these 6 files, restarted my Mac and re-opened TextEdit-- no change.









    I just repaired permissions… reopened TextEdit, the same, no change.


    Very strange.  I changed my HD to SSD two weeks ago, but think this issue is after that, maybe not - but why would this persist?


    Thanks for any more ideas.



  • Topher Kessler Level 6 Level 6 (9,790 points)

    Try going to the user library through the Go menu as I mentioned in my last post, and then open the Containers folder in there and remove the folder called "com.apple.TextEdit," (drag it to the Desktop for now but be sure it is gone from the Containers folder) and then see if the problem persists when you relaunch TextEdit.

  • Stephen Schulte1 Level 1 Level 1 (10 points)

    NOTHING-- what a mystery this is.  Do I have to wait a certain amount of time to build-up a "recents" history?


    I've shut-down (quit) TextEdit and restarted, opened files, closed them-- still only the grey "Clear Menu" shows.


    Best regards,



    Steve Schulte

    Friday 22 March 2013

  • Stephen Schulte1 Level 1 Level 1 (10 points)

    Any other suggestions because nothing is working.  Isn't there a way to completely UNInstall TextEdit and reinstall a fresh copy?


    Thanks--- frustrating and maddening as I really use that feature a lot!


    Best regards,



    Steve Schulte

    Wednesday 27 March 2013

  • Eric Root Level 8 Level 8 (41,180 points)

    Try setting up another admin user account to see if the same problem continues. If Back-to-My Mac is selected in System Preferences, the Guest account will not work. The intent is to see if it is specific to one account or a system wide problem. This account can be deleted later.


    Isolating an issue by using another user account


    If the problem is still there, try booting into the Safe Mode.  Shut down the computer and then power it back up. Immediately after hearing the startup chime, hold down the shift key and continue to hold it until the gray Apple icon and a progress bar appear. The boot up is significantly slower than normal. This will reset some caches, forces a directory check, and disables all startup and login items, among other things. If the system operates normally, there may be 3rd party applications which are causing a problem. Try deleting/disabling the third party applications after a restart. For each disable/delete, you will need to restart if you don't do them all at once.


    Safe Mode


    Safe Mode - About


    General information.


    Isolating issues in Mac OS X


    Troubleshooting Permission Issues



    Step by Step to Fix Your Mac


    Upgrade Nightmares  

  • Stephen Schulte1 Level 1 Level 1 (10 points)

    OK some progress and it does likely seem to be a third-party application interferring – but as I must have 50 third-party apps (most running for years but some new in the past month or so)-- this may take a LONG time to uncover.


    What I've done so far:


    1. My Mac has 2 Hard Drives and the second has a fresh, essentially untouched Mountain Lion 10.8.3 on it.  I booted from that and opened TextEdit (both the version on that HD and later the other on my main SSD) and both showed the recents files-- both worked fine.
    2. I then rebooted to my standard SSD and tested-- still the greyed-out clear menu-- not working
    3. So I now logged-in as a GUEST and the recent files showed!


    OK so it does seem to be something with another app interferring or??     I DID NOT DO A SAFE BOOT.  Should I do that?


    Thanks for any comments.


    Best regards,



    Steve Schulte

    Thursday 28 March 2013

  • Stephen Schulte1 Level 1 Level 1 (10 points)



    MY BAD--- I had a setting in "TinkerTool" set to not show any recent files…  Very naive of me - I've been using a Mac since 1989 and TinkerTool for at least 5 years.


    Normally I am very very careful using TinkerTool---- but this time I was not careful enough.  I will do screenshots of each TT setting and check on TT first before posting in the future.


    I want to thank everyone -- and especially Eric for really getting to the "root" cause <G> (sorry…)--- and I have learned a lot about troubleshooting that I know will come in handy in the future!


    Thanks again!


    Made my day,


    Steve--- with a fully functioning (well, some bugs in ML still) Mac!


  • Eric Root Level 8 Level 8 (41,180 points)

    Glad you got it sorted out so easily. No problem with "root" cause. I laughed when I read it.