5 Replies Latest reply: Mar 24, 2013 3:03 AM by léonie
Niall027 Level 1 Level 1 (10 points)

When I drag my jam pack folders into the loop browser it says 'indexing..' for a couple of minutes but doesn't do anything. I've tried moving the jam pack folders from the library of the root user to my own user library and back but none of it is working. Any ideas anyone? Thank you in advance

 

Niall


GarageBand (Mac) '11, OS X Mountain Lion (10.8.3)
  • léonie Level 9 Level 9 (72,440 points)

    Niall,

     

    why are you trying to index your loops. Did you just install them or can GarageBand no longer find them? Do they not show in the Loop Browser?

     

    When you click the drop-down menu at the top of the Loop Browser, do the Jam Packs not show?

    Screen Shot 2013-03-22 at 20.20.42.png

     

    Regards

    Léonie

  • Niall027 Level 1 Level 1 (10 points)

    Hi Léonie,

     

    Firstly, thanks for replying. the jam packs titles were listed (Jam Pack 1, Jam Pack Remix Tools etc.) but they were empty. So I went looking for the corresponding folders and saw that all the .caf files were there. I thought that dragging the folder icons onto the loop browser might get Garageband to reindex and recognise them but it was just experimental. I didn't know for sure what I was doing, which is why I came here.

     

    Thanks again,

    Niall

  • léonie Level 9 Level 9 (72,440 points)

    So I went looking for the corresponding folders and saw that all the .caf files were there. I thought that dragging the folder icons onto the loop browser might get Garageband to reindex and recognise them but it was just experimental.

    That i s exactly how it is done.

     

    But an empty loop browser does not necessarily mean, that GB does not recognize the loops. Have you checked all filters?

    The Loop browser may look empty, unless you click and select a button that is not dimmed. Or all your buttons dimmed, when you select the JamPack 1?

    Screen Shot 2013-03-23 at 07.05.56.png

    You may have selected a project signature that simply has no loops - like 12/4; and set the scale neither major nor minor, also the "preference" setting "preferences > Loops > keyword browsing > Filter for more relevant results" will exclude most of the loops from being displayed. With the signature set to 4/4 and selecting "All Drums" you should see lenty of loops in JamPack 1:

     

     

    I'd move the loops folder back to exactly where it has been installed and where you indexed it last.  If clearing the filters does not bring them back, check the permissions on that folder. Are you signed in from an admin account?

    Make sure the permissions on the loop folders and the loops are set, so that you have read access.

     

    And if you dragged your loops several times to the loop browser you now may have duplicate loops.

     

    I'd rebuild the loop index, and start over; see this document:

     

         Rebuilding the Loop Index in GarageBand

     

    Regards

    Léonie

  • Niall027 Level 1 Level 1 (10 points)

    HI Léonie,

     

    Thank you, I learned a few new things from your reply. I'd been using a 2/2 time signature. I never realised that the loops considered incompatable didn't display at all in the loop browser. It turns that GB considers 2/2 as incompatable with 4/4 and there are almost no 2/2 compatable loops in the jam packs.

     

    Thanks again,

    Niall

  • léonie Level 9 Level 9 (72,440 points)

    I'd been using a 2/2 time signature.

    You are welcome, Niall.

     

    When I want to use 4/4 loops in an 2/2 time signature project, I simply switch the project to 4/4 from the LED display, browse the 4/4 loops, add the loops that I want to use, and then switch back to the correct time signature. This works usually well with software instrument loops. Sometimes the loops will need a little tweaking - change the velocity on some notes, but they usually are a good starting point.

     

    Cheers

    Léonie