10 Replies Latest reply: Mar 25, 2013 2:23 PM by SSteele
adambfoot Level 1 Level 1 (0 points)

I have used FCP for a few years now and always just popped my SD cards in and went to log and transfer and the .mts files would automatically pop up.  For some reason FCP does not read them anymore and it doesnt work by trying to add the PRIVATE folder to log and transfer.

 

The problem didnt happen at once, i have about 6 memory cards and they all stopped being detected at different times.  I use a PC at work and thought maybe the cards worked with FCP and as soon as i used them to dump footage on the PC they were reformatted somehow to a PC and wont go back to the mac.  Could this be?  And I am pretty sure the last memory card that stopped working was never used with the PC but I may be wrong.

 

Do I need to format my memory cards when I first buy them so they work with a mac?  If so how?

 

Would rotating them between a PC and Mac stop them from being detected by my mac?

 

I have reinstalled FCP and they still wont work?  Is there anything else I can try?

 

The Cache.dat and filemng.dat files in my memory card have orange work cones next to them as their icons when I open my memory card in my mac, I dont think they use to have this as their icon if that matters.

 

Any help would be great!  Thanks so much and the cards have all been used with a Panasonic GH2 only.


Final Cut Pro 7, Mac OS X (10.6.8)
  • 1. Re: FCP stopped reading my sd cards?
    Nick Holmes Level 7 Level 7 (29,835 points)

    You should format the cards in the camera that they are going to be used with.

  • 2. Re: FCP stopped reading my sd cards?
    adambfoot Level 1 Level 1 (0 points)

    how do i do this?  When i put my card in it just works normal and I dont see a format option in my camera.

  • 3. Re: FCP stopped reading my sd cards?
    David Mclaine Level 4 Level 4 (1,855 points)

    I don't know the camera but there will be an option to format somewhere.

    Have you tried copying the card to your Mac and then pointing L&T at the copied folder ?

    DM

  • 4. Re: FCP stopped reading my sd cards?
    adambfoot Level 1 Level 1 (0 points)

    Just tried that, no luck.

  • 5. Re: FCP stopped reading my sd cards?
    Nick Holmes Level 7 Level 7 (29,835 points)

    User manual: http://service.us.panasonic.com/OPERMANPDF/DMCGH2.PDF

     

    From page 28:

    Do not format the card on your PC or other equipment. Format it on the camera only to ensure proper operation. (P62)

  • 6. Re: FCP stopped reading my sd cards?
    adambfoot Level 1 Level 1 (0 points)

    I didn't format any if my cards to anything because I didn't know you had to...  I used a couple of my cards with a diff canon camera about 6 months ago and that didn't affect anything...  The only thing I think could be wrong is using these cards on a pc would mess them up from working on my Mac.

  • 7. Re: FCP stopped reading my sd cards?
    Nick Holmes Level 7 Level 7 (29,835 points)

    Simply "using" them on a PC will not change the directory structure or format unless you copy random stuff from the PC to the card (don't ever do this).

     

    A Mac can read and write Windows FAT 16 and 32 formatted storage media and read Windows NTFS formatted storage media. To write to NTFS, your Mac needs a free piece of software called NTFS3G.

     

    When I put my Panasonic camera's SD card into my Mac, Get Info tells me that it is formatted as FAT32, a Windows file system. Formatting in the camera adds some files that it needs to operate correctly. Formatting on either a PC or Mac won't provide those files and the camera will not work as expected.

     

    Look at it this way, you can put a movie on a DVD but it will just be data. To make it into a DVD Video disc that will work in a set top player it needs a strictly specified set of files on it that tell the player how to present the movie.The storage cards in AVCHD cameras also need a similar set of files to do much the same thing. This is why you always point FCP at the card itself, not the sub directory where the actual shots reside.

  • 8. Re: FCP stopped reading my sd cards?
    adambfoot Level 1 Level 1 (0 points)

    Thanks for explaining it better, once I can get this footage working I will format all my cards,

     

    But does anyone know why my cards have stopped being detected in FCP after working fine for 2+ years?  Is there anything I could try to do do fix this, I don't want to have to pay for a .mts converter 

  • 9. Re: FCP stopped reading my sd cards?
    Michael Grenadier Level 7 Level 7 (20,115 points)

    You don't say how you're reading the cards.  If you're using an external card reader, this may be the cause of the problem.  I've had several card readers fail over the years.  If the cards show up in the finder, that's not the problem. 

  • 10. Re: FCP stopped reading my sd cards?
    SSteele Level 3 Level 3 (515 points)

    I almost had to laugh after I read your post.  Out of the clear blue several days ago, the same thing happened to me with a Compact Flash card I've used successfully for 1 1/2 yrs.  It wouldn't show up on my computer, wouldn't read or format in my Sony Z7U which is where I have always and only used it, nor would it read or format in a Canon 5DMII which also uses compact flash and I was desperate to see if anything would read the card.

     

    It was a SanDisk Extreme Pro 32GB.  After doing some research on the web, I eventually contacted SanDisk and asked if they would replace it under warranty.  To their credit, they said they would.  I have sent it back but not received the replacement yet.  Fortunately the files on the card I had already gotten off.

     

    So I guess cards can just quit.  Does seem interesting that so many of yours have failed.

     

    Good luck.

    Sharon

     

    More of the story--the card being unreadable had happened right after I had given it to a colleague to use the files on his PC.  I'm just sure that was co-incidence. He only copied the files and ejected the card 'properly'.   I gave him another card with new shots from this weekend and just got it back a few minutes ago.  It still works fine.

     

    I only used my card in the Sony Z7U.  At first I would reformat it each time I had a new shoot.  The last few months or so I would just erase the files before a new shoot. 

     

    I'm going with it was just a card failure. 

     

    Message was edited by: SSteele