1 Reply Latest reply: Mar 24, 2013 4:20 AM by QuickTimeKirk
fhitch Level 1 Level 1 (0 points)

hi, I have a Mac OS X 10.5.8 and i need to download the latest itunes for my new nano to work if I download snow leopard will this fix the problem? thanks

iMac, Mac OS X (10.5.8)