Previous 1 2 3 4 Next 59 Replies Latest reply: Apr 10, 2014 4:53 AM by Solid_Sever Go to original post
  • TCSparrow Level 1 (0 points)

    Thank you for all your comments.  I was completely lost as to what was going on with my MBA.  I'm in the same boat as you all... late 2010 MBA, running 10.8.3, and have a Nvidia GeForce 320.


    I couldn't get my screen to stop flickering out of control... couldn't use my laptop it was so bad.  Restarted it and that worked.  Hopefully it'll last forever.. probably not though.  Thanks again everyone.

  • Anthony Curcione Level 3 (610 points)

    My wifes MBA started having this issue after 10.8.3, but I didn't find any info on it at the time.  I reapplied 10.8.3 via the combo updater and verified all SMC/EFI updates had been applied and it continued.  It was so bad that my wife could barely use the computer.  It was bad, bad, bad,


    So I took it to the Apple store since I have Apple Care on it and luckily it was happening when they opened it up.  They took it back to a tech who hooked it up to an external display and it was fine on the external.  Because of this they posited that it must be the display and NOT the graphics card so they ordered another panel.  It was installed late last Friday and we picked it up Saturday.


    Some time on Sunday the display started acting up again, only this time it isn't nearly as bad.  At least not yet.


    I was preparing to go back to the store, but maybe I'll wait.  Although, the more people who report the problem to Apple the better, right?

  • Helvitis Level 1 (0 points)

    Interesting, I'm having the same problem after updating to 10.8.3. I have 2010 11" Macbook Air with 1.4Ghz Core 2 Duo and Nvidia GeForce 320M as well.


    Message was edited by: Helvitis

  • byg23 Level 1 (0 points)

    I'm running 10.8.3, 2010 11" Macbook Air with 1.4Ghz Core 2 Duo and Nvidia GeForce 320M and exactly the same issue... comforting to know the problem is not hardware based.  A fix would be appreciated ASAP!

  • Anthony Curcione Level 3 (610 points)

    Just talked to AppleCare rep and the only thing he could recommend was doing a fresh install of the OS over the existing.  I don't think this will help, but I may give it a try.


    I also don't think he found any other reports of the problem so I would urge anyone that is having the problem and still has AppleCare to call in and get a case going.

  • jakobward Level 1 (0 points)

    If you reinstall - will you please let us know if that fixes it?!? Thanks!

  • Anthony Curcione Level 3 (610 points)

    Of course!  I'm in the process of it now.  I'm actually wondering if I should just do a manual combo update up to 10.8.2 and leave it at that.  Of course that won't really figure out if a reinstall is helpful, just that not updating to 10.8.3 is helpful.


    I dunno.  I'll let you know what I end up with.

  • Anthony Curcione Level 3 (610 points)

    So I reinstalled from the recovery partition which of course installed the latest version, not the base 10.8, so I couldn't go to 10.8.2.  BUT, so far I haven't seen the screen flicker on me.  I've done several tasks to tax the graphics and so far so good.  However I haven't closed the lid and waited a few minutes to open it again.


    I'll do that as soon as my Time Machine finishes it's huge backup thanks to the OS update!

  • Anthony Curcione Level 3 (610 points)

    And now a few hours later I've been trying very hard to get this thing to act up and I haven't been able to!  Even on battery power and woken from sleep - no issues thus far.  I've tried everything I can to stress the graphics and things that so far have always resulted in severe flickering of some sort.


    So I guess if you have the time, boot into your recovery partition (CMD+R on boot) and click "Reinstall" and go through all the steps.  I'd also repair permissions immediately afterwards of course and if you have Cocktail, dump your caches as well and then reboot again.


    Let me know if anyone else has any success with this.  I'm holding my breath to see if it holds.  I certainly hope so.

  • Anthony Curcione Level 3 (610 points)

    Don't bother trying this folks.  It didn't last long.  Guess I'll be taking this back to the store to SHOW them this thread and make sure someone somewhere is aware this was caused by 10.8.3.

  • rc-usa Level 1 (0 points)

    Okay, thanks for the update.  still flickering here, gotta close and open a few times to get it to stop.  Annoying.  Wonder if the next so version will fix this...I had just purchased a new screen 3 months ago after the original cracked.

  • Carolus730 Level 1 (0 points)

    Greetings from Rome, Italy.

    Same issue here. After updating to 10.8.3, my MBAir 11" (Late 2010) started to flicker after a long period with the lid closed. To get rid of the flickering I have to close lid again and reopen it after some seconds. Fortunately, now I know that isn't an hardware problem. I hope the fix will come soon.

  • Starhawk Level 1 (5 points)

    Im glad you tried to re-install 10.8.3, but I was almost sure it wouldn't solve anything. It certainly seems that whatever changes were made to the Nvidia drivers in this update are the cause of the problem.


    The only reason I knew of the specific changes is there was an existing problem that caused Pixelmator to crash on 10.8.2 and changes were made to 10.8.3. Obviously this bug with our 11" Macbook Airs was not found before release.



    I've sent in a bug report through Apple Feedback here: but it might help if others report it as well.

  • apple-kris Level 1 (0 points)

    Thanks for making me aware of this thread. I have exactly the same problem. It must be a software issue. Does anybody have any news? Here is a link to the discussion I opened a few days ago.

  • iDash Level 1 (0 points)

    exactly the same issue has ocurred on my (wife's) 11" Air (1.4 core2duo, 2GB ram, GeForce 320M) with 10.8.3 - it seems to start AFTER the SMC update (as I did that fairly recently), where as I updated to 10.8.3 when it was released.


    Solution  (or more accurately, workaround) seems to be, as others have commented, close it and leave it for a minute and re-open, then it appears to be absolutely fine.


    Judging what other have said and what I've seen over the years - it appears to be software rather than hardware related - so I can only assume that apple will fix in the next update (10.8.4 already seended to developers I hear).


    I have another (more recent) MBA 11" (iCore5 etc) and it does not exhbit the same behaviour (fortunately).


    Obviously more annoying than anything else - hope apple will sort this soon!