2 Replies Latest reply: Mar 27, 2013 9:21 AM by doktorbenn
doktorbenn Level 1 Level 1 (0 points)

Hi folks!

 

I just purchased Windows 8 and Winclone 3.7 trying to do the following, but finally failed and now kindly ask for your advice:

 

I'm running a brand-new iMac 21,5 (late 2012) with a simple internal HDD (no fusion drive!) and successfully installed Windows 8 on a partition on the internal HDD using boot camp (works perfectly fine). This partition I wanted to clone to an external SSD (Samsung 840 Pro) connected via USB 3 and make it bootable(!) from the external SSD (no hardware changes at all!). I found a tutorial on the web how to do so when connecting the SSD via thunderbolt saying there shouldn't be any problems when connecting via USB 3 neither. I googled for an applicable case for the SSD to be recognized under Windows 8 and found myself the "Thermaltake Silver River 5G" which a user described it would definitely(!) work using it for a bootable external Windows-8-SSD. I installed all current updates - both in OSX and Windows 8 - and also followed the steps to manually download and install the latest boot camp drivers for Windows 8 (whilst running Windows 8) though I had already installed them using whilst the boot camp process.

 

I then followed the steps of the tutorial I found creating an image of the (internal) boot camp partition ("Remove Memory Cache Files") and restoring it to the external SSD ("Replace BCD") and everything worked fine: I now got the internal boot camp partition cloned 1:1 to the external SSD (as there is no change in hardware, I believe I do not need to follow the steps regarding Sysprep?). But in the end, I cannot boot from the external SSD no matter how:

 

1. When I go to the system preferences -> start up volume menu in OSX, select the new boot camp Windows 8 partition on the external SSD (of course, there's two boot camp partitions now - but I tried both!) and click restart, it ignores the choice and always ends up booting from the internal boot camp Windows 8 partition.

 

2. When I restart the iMac holding the option key while restarting I can only select the internal boot camp Windows 8 partition (and the OSX partition respectively the recovery option, of course) as the external boot camp partition does not show up!

 

Any idea what went wrong? I personally believe there might be a driver issue so Windows 8 does not recognize the SSD whilst booting - but the strange thing about that is, that Windows 8 is supposed to be able to NATIVELY boot from an external USB-3-device (isn't it?). Or did I do wrong on any of the steps to clone the partition to the external SSD? Finally, do you think I might need to remove the internal boot camp partition? Here (http://forums.macrumors.com/showthread.php?t=1351547) it says no, and I actually do not want to risk loosing my internal partition without necessity.

 

Any support is highly appreciated!!


iMac, Windows 8
  • 1. Re: Problem booting Windows 8 from external SSD via USB 3
    Ralph Landry1 Level 7 Level 7 (32,350 points)

    Two knowledge base articles that may help:

     

    Starting from USB

     

    and

     

    FAQ on USB

  • 2. Re: Problem booting Windows 8 from external SSD via USB 3
    doktorbenn Level 1 Level 1 (0 points)

    Hi Ralph,

     

    thanks a lot for the helpful information! But the problem still persists, and I don't know what's wrong about the installation. I again checked the case and device are fully compatible with Windows 8 on USB 3 and the current boot camp drivers are installed - so everything should work perfectly fine as Windows 8 does natively support booting from external USB-3-devices.

     

    I personally still assume it's rather a driver related problem as the external SSD doesn't even show up whilst booting into the boot menu with "Alt" pressed - I can only choose to boot from the external SSD within the "start volume" menu in OSX (which then doesn't work out when rebooting, unfortunately). I mean, if there was a chance to boot from the external SSD with the configuration I got right now, but OSX/the iMac just "doesn't know" it shall boot from the external partition and therefore rather chooses the internal boot camp partition, the SSD would at least show up in the boot menu when pressing "Alt" on start-up, or do I go completely wrong? I even tried to rename the internal bootcamp partition (which did not work out) or disable it in order to prevent OSX/the iMac to boot from the internal bootcamp partition, but it didn't help: After rebooting it again chose the internal boot camp partition to start from.

     

    Might the deletion of the internal partition be worth a try? Meaning is there a realistic chance that the issue might be caused by that? I would give it a try although I really don't wanna loose the internal boot camp partition for no good reason (btw: would it be possible to clone an image back from the external SSD to the internal HDD then?). Or do you maybe have any other idea what driver could miss resp. could be wrong about the installation so the boot process from the external SSD fails...?

     

    Again MANY MANY THANKS in advance for your further assistance, everybody!!