8 Replies Latest reply: Jul 22, 2014 12:28 PM by savy.april
BlueJunco Level 1 (0 points)

I have had this issue since day one with this macbook pro.


I change the desktop background following the directions and no matter what I do after I shut down and use it again it just goes to a blank blue screen.


When i look at the desktop settings there is my picture like it should be but the macbook is not acting right.


This is really frustrating me. Its seems like a simple thing but the macbook pro wont do it.


What in the world can i do?

MacBook Pro (15-inch, Mid 2012), OS X Mountain Lion (10.8.1)
  • mende1 Level 10 (91,930 points)

    That's a problem with the Desktop settings file, so you have to delete it. First, open Finder, select Go menu (on the menu bar) > Go to Folder, and type ~/Library/Preferences. Then, delete "com.apple.desktop.plist" and "com.apple.systempreferences.plist", and restart. Finally, you should be able to change your wallpaper and keep it

  • BlueJunco Level 1 (0 points)

    Thank you so much. It's been like that for months.

  • mende1 Level 10 (91,930 points)

    You are welcome

  • Sgt Preston Level 1 (0 points)

    I opened Finder and proceded with your instructions however, niether of the "plist" were listed. Therefore I had nothing to delete. Sgt. Preston

  • Nyobie Level 1 (0 points)

    I had the same issue for the past couple weeks and I tried a few suggestions I was able to find on the Internet but no luck.  I decided to go into iPhoto and find the images I wanted to use for the desktop wallpaper and while doing so, I messed around with the menu feature which allows you to set images as your desktop.


    After I got tired of tinkering around in iPhoto, I exited all programs, then re-started.  The image I switched to before the re-start was still present.  I re-booted next.  The image stayed.  Since then, I've switched wallpapers a few times and they all stay like they're supposed to after a re-boot.


    I don't know what I did to 'fix' the problem but I was able to muck around in iPhoto for about 5 minutes before I got bored and re-started.  Maybe this is something you could try?


    I wish I knew what the problem was.  I didn't delete any files but I did have to re-build the Events image folder in iPhoto yesterday when I tried to fix the problem.  I had inadvertently removed all iPhoto images not knowing that iPhoto has some sort of interaction with desktop image settings.  I'm sure an Apple developer would be able to figure out what's happening but it's not obvious to me.

  • Sgt Preston Level 1 (0 points)

    Hey Nypbie.  Since I posted my problem, it has not happened again. I to went into iPhoto and switched desktop pictures, but they have stayed put after numerous re-boots. I don't know. Some kind of a Mac glitch I guess. Thanks for your response.  Sgt. Preston

  • Nyobie Level 1 (0 points)

    If you haven't set desktop images from System Preferences yet, that should now work for you.  I tried it and it works on my computer now but I think you had to set the desktop image on its first attempt using iPhoto to repair or replace whatever it was that was preventing the System Preferences desktop setting feature from working.


    Thanks for your follow-up post!

  • savy.april Level 1 (0 points)

    My Mac didn't have the desktop file in the go menu (its an Air, I'm not sure if that makes any difference) and I was a little uncomfortable deleting file coding that I wasn't familiar with, but I found something that worked for me as an alternative to deleting files that I wasn't familiar enough with (what if the file has something important that I need for something sometime?!)


    I just dragged the photo from my desktop into iPhoto. I then went into iPhoto and selected the picture and then went to the "share" tab in the top menu bar and selected the "set desktop" option. The image stuck to my desktop even after I rebooted and it doesn't leave my desktop with a junky thumbnail (which makes me a little crazy since I'm a neat freak...) I hope this works for everyone too!