2 Replies Latest reply: Nov 11, 2014 1:27 PM by Tomgin72
connie2077 Level 1 Level 1 (0 points)

I have started getting "blocked plug-ins" on my iMac. How do I update my Safari to correct this?

 

Regards,

 

Connie 2077


iMac