1 Reply Latest reply: Mar 28, 2013 5:53 AM by El Morche
El Morche Level 1 Level 1 (0 points)

My Macbook Air (late 2010) suddenly started dropping its wifi connection with my Time Capsule (2nd Gen)  last night. At around the same time I had the same problem with my MacBook (late 2008). Both are running version 10.8.3. After a bit of research this morning I found that changing the service order under System Preferences>Network>Set Service Order - to put Bluetooth below Wifi in the priority order - seems to have cured the problem on the MacBook but not the MacBook Air.

 

There are no wifi issues that I am aware of with the iOS devices that I have - iPhone 4, iPhone 5 and iPad Mini.

 

Strange thing is that if I use Network Diagnostics to make the wifi connection on the MacBook Air and keep Network Diagnostics running in the background then the connection is held.

 

By coincidence, a couple of hours after this problem manifested itself, I had a warning on my Macbook that the hard drive on my Time Capsule was full and that it would start deleting the earliest backups. I use Time Machine on my MacBook but not on the MacBook Air. I'm not sure if this is just a coincidence or not but thought that I should mention it anyway. I've switched off Time Machine temporarily on my MacBook in the meantime.

 

There are some extremely long threads about wifi issues which offer a confusing amount of advice so I thought it better to start a fresh one.

 

I have reported the problem to Apple.

 

Any advice or guidance would be much appreciated.


MacBook Air, OS X Mountain Lion (10.8.3), 11" Late 2010
  • El Morche Level 1 Level 1 (0 points)

    With the help of Apple Support this problem seems to be cured.

     

    Here is a summary of the steps that they took me through:-

     

    In Settings>Network>

     

    Click on Gear Wheel beside +- at bottom of list of network services, select "Set Service Order" and check that WiFi is at the top of the list.

     

    Click on Advanced and select DNS tab. Click on + at bottom of DNS Servers List and enter 8.8.8.8

     

    In WiFi tab check that your preferred network is at the top of the list.

     

    Apply any changes that have been made and switch off.

     

    Reset SMC and NVRAM/PRAM

     

    Check that there are no channel conflicts with other wifi networks.