4 Replies Latest reply: Mar 27, 2013 12:12 PM by Niku
Niku Level 2 Level 2 (285 points)

This problem comes up from time to time, but I always forget how I fixed it. This time, I'm going to paste the solution on my computer along with FRAUD addresses, etc. Anyway, when I start up my comuter, I get a series of unwanted applications starting up. This delays my use of the computer. I don't want them THEN. I want them when I ask for them. How do I fix my computer so that only programs I ask for appear?


iDVD 7.1.1 (1150)
  • macjack Level 9 Level 9 (50,650 points)

    It's the Resume feature.

     

    When choosing Restart, Sleep or Shutdown there is a checkbox you can uncheck to prevent the apps from launching.

     

    Also in System Preferences > General there is a hard-to-find checkbox under "Number of recent items" you can turn off.

    Also, you can hold the shift key to disable resume on a one time basis.

     

    If you don't want autosave or resume you can copy & paste this command into Terminal at the prompt...

    defaults write -g ApplePersistence -bool no

    Press return

    Now reboot.

     

    The reverse would be "yes".

  • Niku Level 2 Level 2 (285 points)

    I applied your remedies with  confidence that they would fix the problem. Unfortunately, that was not the case. They didn't help, and I still have then problem.

     

    ======

    When choosing Restart, Sleep or Shutdown there is a checkbox you can uncheck to prevent the apps from launching.

    --

    All of those boxes were already unchecked. However, just to make sure that I had explored every possibility, I checked them and tried again. The problem remained. I then unchecked them  and tried again. Still no fix.

    =====

     

     

    Also in System Preferences > General there is a hard-to-find checkbox under "Number of recent items" you can turn off.

    --

    I found the place and changed the setting to "None". It didn't help when I restarted the computer.

    ====

    Also, you can hold the shift key to disable resume on a one time basis.

    ---

    I tried this without success at various times, but maybe not at the right time. When should this technique be used?

    ===

     

     

    If you don't want autosave or resume you can copy & paste this command into Terminal at the prompt...

    defaults write -g ApplePersistence -bool no

    Press return

    Now reboot.

     

    The reverse would be "yes".

    ===

    I didn't try this because I didn't quite understand it. As I understand it, I am supposed to copy "defaults write -g ApplePersistence -bool no" and paste it into "Terminal at the prompt...". I don't understand where or how I am supposed to do the pasting part.

  • macjack Level 9 Level 9 (50,650 points)

    Yes,the Terminal app is located in your Utilities foder, double-click to launch just do a paste cmd-v, like you normally would, the press return key on your keyboard. Then restart.

  • Niku Level 2 Level 2 (285 points)

    macjack,

     

    That didn't help, although I have to wonder if my "terminal" is the way it's supposed to be. When I click on "terminal" I see the following:

    ------

     

    "Last login: Wed Mar 27 11:36:11 on console

    You have mail.

    Macintosh-2:~ "

    ------

    It also has my name, but I have deleted it for this posting. Anyway, I finally had to give up, and so I called Apple. Their fix was successful. Here's how it goes.

    (1) Apple icon in Menu bar

    (2) Sysrem Preferrences

    (3) Users &Groups (this is on the left end of the fourth row down)

    (4) Unlock padlock

    (5) Password

    (6) In the "Hide" column, check those items that you DO NOT want to open automatically when you check in

     

    Actually, there were still a few "gangsters" that kept opening when I didn't want them, so I uninstalled them. Oh, since my AppleCare  Protection Plan has expired, that little lesson cost me $19.00. To bad Apple doesn't allow you to renew their program.

    PS: You may be sure that these instructions have now been pasted on my computer.