11 Replies Latest reply: Jan 15, 2014 8:17 AM by xgretsch
DWComeau Level 1 (0 points)

I am trying to install my Brother MFC-7860DW printer.  Apple indicates that an updated driver is available; yet, when I try to add it, I receive "Can't install the software . . .because it is not currently available from the Software Update Server".


OS X Mountain Lion (10.8.3)
  • acatachanas Level 1 (5 points)

    Exact same problem described above. Apple needs to ensure their updates are shared adequately and efficiently with other companies in order to limit these compatibility issues... I like the brand, but so far this is the second driver issue I face since the last OSX 10.8.x OS update... Not practical at all. We have a windows laptop at home also, works perfectly, no issues of this sort. Time to get your act together apple, I need to have access to my Brother MFC7860DW wirelessly please.

  • astrocity94 Level 1 (0 points)

    Have you tried "Reseting the Printing System"?  I ran into the same issues with Brother MFC-7360D and MFC-7460DN.  I returned the 7360D back to Amazon because it wouldn't work with my MacBookPro going through our network and ordered the 7460DN instead hoping it would work out of the box.  Ran into the exact same issue.  I was about to return the 7460DN when I ran into this post here - https://discussions.apple.com/thread/3257552?start=0&tstart=0

     

    Here's the summary of the fix:

    1) Delete the "Brother" directory under "/Library/Printers"

    2) Install latest Brother drivers from Apple - http://support.apple.com/kb/DL894

    3) Reset the printing system (see below)

     

    To Reset the Printer Setting

    1) Open "System Preferences"

    2) Select "Print & Scan"

    3) Right click on the "Printers" window

    4) Select "Reset Printing System..." (Be warned that this will delete all your existing/working printers)

     

    Props to John Blanchard1 and jManMUC for their insights/fixes

  • biola23 Level 1 (0 points)

    Thanks - worked perfectly and solved my issue!

  • Egaylin Level 1 (0 points)

    Astrocity, please, when I download “Brother Printer Drivers 2.10 for OS X” from Apple Support and try to open it, I get the message “The following disk images could not be opened” because “BrotherPrinterDrivers2.10.dmg” is “not recognized.”  I am running OS X, Version 10.8. ?????

  • boxofG Level 1 (10 points)

    just wondering if you ran the software update while the printer is connected to your Mac?

  • macnavi Level 2 (475 points)

    Great solution and worked for me! Only resetting the Printer system already worked for me for my Brother HL-2070N series. No need to download and reinstall the drivers. Once you've reset the Printer system, you can add the printer again and it will "obtain" the already installed drivers.

     

    Makes sense as well, as it the Printer system that is corrupted, not the drivers.

     

    Interesting enough, when I reset this Printer system on one Mac, the other Mac, which had the same issue, could print again as well without resetting the Printer system.

  • msuica Level 1 (0 points)

    astrocity94, your succint summary worked like a charm.

     

    Many thanks.

  • egorkuchumov Level 1 (0 points)

    It works greate for printer. But i cant use wireless scanner

  • EibborThompson Level 1 (0 points)

    Thanks astro! Fixed my DCP-7065DN

  • ArcticFyre Level 1 (0 points)

    Thank you so much for this!  Did exactly as you (Astrocity) described and worked perfectly. Printer, scanner and all.

  • xgretsch Level 1 (0 points)

    @astrocity94 Worked perfectly for me too, with an HL-2270DW, after hours of faffing around trying other stuff. Many thanks.