Previous 1 2 3 Next 35 Replies Latest reply: Jan 12, 2015 5:59 PM by kinisuru
Shantley Level 1 Level 1 (0 points)

I have set up my system/apps on one SSD and my home folder on another. Unfortunately, I have been having lots of permission related problems recently and can't find a way to reset permissions and ACLs on the home folder. I tried the hidden "resetpassword" terminal command that can be accessed in recovery mode, which allows you to reset permissions and ACLs, but it won't touch home folders on a drive separate from the system. I also tried DiskWarrior, but that's not fixing the underlying issues (Acrobat X Pro freezing, Mail not being able to save attachments, can't create projects in imovie b/c I don't have permission, etc). Anyone know how to reset permissions on a home folder when it's on a separate drive?


Mac Pro, OS X Mountain Lion (10.8.3)
  • Linc Davis Level 10 Level 10 (147,445 points)

    Back up all data. Don't continue unless you're sure you can restore from a backup, even if you're unable to log in.

    This procedure will unlock all your user files (not system files) and reset their ownership and access-control lists to the default. If you've set special values for those attributes on any of your files, they will be reverted. In that case, either stop here, or be prepared to recreate the settings if necessary. Do so only after verifying that those settings didn't cause the problem. If none of this is meaningful to you, you don't need to worry about it.

    If you have more than one user account, and the one in question is not an administrator account, then temporarily promote it to administrator status in the Users & Groups preference pane. To do that, unlock the preference pane using the credentials of an administrator, check the box marked Allow user to administer this computer, then reboot. You can demote the problem account back to standard status when this step has been completed.

    Triple-click the following line to select it. Copy the selected text to the Clipboard (command-C):

    { sudo chflags -R nouchg,nouappnd ~ $TMPDIR.. ; sudo chown -R $UID:staff ~ $_ ; sudo chmod -R u+rwX ~ $_ ; chmod -R -N ~ $_ ; } 2> /dev/null

    Launch the Terminal application in any of the following ways:

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

    Paste into the Terminal window (command-V). You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning to be careful. If you don’t have a login password, you’ll need to set one before you can run the command. If you see a message that your username "is not in the sudoers file," then you're not logged in as an administrator.

     

    The command will take a noticeable amount of time to run. Wait for a new line ending in a dollar sign (“$”) to appear, then quit Terminal.

  • Shantley Level 1 Level 1 (0 points)

    Thank you Linc. I ran the command successfully, but it did not fix my underlying problems.

     

    Perhaps they're not related to permissions? In addition to the symptoms I mentioned above, I can no longer access the "Accounts" tab in Mail preferences. When I click on it I get the spinning wheel and need to force quit.

     

    I also reinstalled OSX yesterday with no changes. Another clue: I created another test user/account and don't have these problems. Any suggestions?

  • Eric Root Level 7 Level 7 (27,535 points)

    If the problem is still there, try booting into the Safe Mode.  Shut down the computer and then power it back up. Immediately after hearing the startup chime, hold down the shift key and continue to hold it until the gray Apple icon and a progress bar appear. The boot up is significantly slower than normal. This will reset some caches, forces a directory check, and disables all startup and login items, among other things. If the system operates normally, there may be 3rd party applications which are causing a problem. Try deleting/disabling the third party applications after a restart. For each disable/delete, you will need to restart if you don't do them all at once.

                   

    Safe Mode

     

    Safe Mode - About

     

    General information.

     

    Isolating issues in Mac OS X

     

    Troubleshooting Permission Issues

     

     

    Step by Step to Fix Your Mac

  • Linc Davis Level 10 Level 10 (147,445 points)

    Please follow these directions to delete the Mail "sandbox" folder.

    Back up all data.

    Quit Mail.

    Triple-click the line below to select it:

    ~/Library/Containers/com.apple.mail

    Right-click or control-click the highlighted line and select

    Services Reveal

    from the contextual menu. A Finder window should open with a folder named "com.apple.mail" selected. If it does, move the selected foldernot just its contents — to the Desktop. Leave the Finder window open for now.

    Relaunch Mail and test. If the problem is resolved, you'll have to recreate some of your Mail settings. You can then delete the folder you moved and close the Finder window. If you still have the problem, quit Mail again and put the folder back where it was, overwriting the one that may have been created in its place. Post your results.

    Caution: If you change any of the contents of the sandbox, but leave the folder itself in place, Mail may crash or not launch at all. Deleting the whole sandbox will cause it to be rebuilt automatically.

  • Shantley Level 1 Level 1 (0 points)

    Thanks Eric, but booting in safe mode doesn't make any difference.

  • Shantley Level 1 Level 1 (0 points)

    Thanks again Linc. I tried it, but it did not work. In fact it gave me the spinning wheel just by selecting "preferences" this time.

     

    Seems like I might need to recreate a new user account and transfer my files to it. Are you aware of any terminal commands or programs that would do this automatically? Obviously, I'd like to retain as much of my home folder as possible, but don't want to bring in any of the bum files.

  • Linc Davis Level 10 Level 10 (147,445 points)

    How did you move your home folder to the SSD?

  • Shantley Level 1 Level 1 (0 points)

    The wrong way, I am now finding out. I just manually copied the content.

     

    I originally did this several years ago and it worked fine. Two weeks ago I upgraded to a SSD and copied the content from that separate HDD to the new SSD. It worked just fine for about 10 days. It wasn't until just yesterday when I started having these issues.

  • Linc Davis Level 10 Level 10 (147,445 points)

    Select the icon of your home folder (a house) in the sidebar of a Finder window and open the Info window. Is the value of Where what you expect it to be?

  • Shantley Level 1 Level 1 (0 points)

    Yes, it's /Volumes/Home

     

    "Home" happens to be the name of the drive.

  • Linc Davis Level 10 Level 10 (147,445 points)

    Please read this whole message before doing anything.

     

    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.

     

    Step 1

     

    The purpose of this step is to determine whether the problem is localized to your user account.

     

    Enable guest logins* and log in as Guest. For instructions, launch the System Preferences application, select Help from the menu bar, and enter “Set up guest users” (without the quotes) in the search box. Don't use the Safari-only “Guest User” login created by “Find My Mac.”

     

    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.

     

    Test while logged in as Guest. Same problem?

     

    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.

     

    *Note: If you’ve activated “Find My Mac” or FileVault, then you can’t enable the Guest account. The “Guest User” login created by “Find My Mac” is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.

     

    Step 2

     

    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login, or by a peripheral device.

     

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode* and log in to the account with the problem. The instructions provided by Apple are as follows:

     

    • Shut down your computer, wait 30 seconds, and then hold down the shift key while pressing the power button.
    • When you see the gray Apple logo, release the shift key.
    • If you are prompted to log in, type your password, and then hold down the shift key again as you click Log in.

     

    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs.  The next normal boot may also be somewhat slow.

     

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    *Note: If FileVault is enabled, or if a firmware password is set, or if the boot volume is a software RAID, you can’t boot in safe mode.

     

    Test while in safe mode. Same problem?

     

    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of steps 1 and 2.

  • Shantley Level 1 Level 1 (0 points)

    Wow. Thank you for all the time you've put into this.

     

    Step 1: No problems while logged in as a guest

     

    Step 2: No difference, same problems while booted in safe mode

  • Linc Davis Level 10 Level 10 (147,445 points)

    Please look at the Info window again. The Kind should be Volume, the Format should be Mac OS Extended (Journaled), the box marked Locked should not be checked, and you should have Read & Write privileges.

     

    If all that is correct, select Apply to enclosed items from the action menu (gear icon) at the bottom of the dialog.

  • Shantley Level 1 Level 1 (0 points)

    Linc, I did what you mentioned and no change. Still having issues.

Previous 1 2 3 Next