4 Replies Latest reply: Apr 5, 2013 1:20 PM by John Medaglia
John Medaglia Level 1 Level 1

Cannot send but can receive email : os x 10.4 POP port 110; internet browser access OK; Mail connection doctor says "Mail unable connect to internet"; green dots for mail account names "connection and login to server succeeded";

red dot for smtp.comcast.net "could not connect to SMTP server".      Account preferences appear same as on another computer in which mail is OK.  

"Error

This message could not be delivered and will remain in your Outbox until it can be delivered.

The server "smtp.comcast.net" cannot be contacted on port 25.

"

Network Utility Port scan on 25 and on 110 OK. Have not found blocking by firewall.

Also, Why port 25 in one error message and not in other error message when I see port 110 in POP account setup?

--------


iMac G4 800 MHz, Mac OS X (10.4.4)
Solved by John Medaglia on Apr 5, 2013 1:20 PM Solved

Thanks,  Neville Hillyer. Your advice was helpful, but in os 10.4, mail 2.1.3, and Comcast setup advice online there were some port differences that solved the problem. Thanks to NH I saw the SSL option was not consistent on outgoing versus incoming; saw two different sequences to use mail preferences for setting up incoming versus outgoing; and saw on COMCAST set-up that they like 2 different port numbers. My other newer Macs have not had this problem (yet) which seems strange since I saw port 110 in all my Macs.

Mail preferences:

a-- accounts Information tab type POP, my userid, mypassword, and on advanced tab incoming port  should be 995, SSL checked, Authentication should be Password

b-- accounts information incoming server mail.comcast.net, my userid and mypassword, outging server smtp.comcast.net:myuserid, server settings port 465, SSL checked.

c-- in this old version mail 2.1.3, there is not save button until I select another account and a pop-up indicates my account changed and offered the save button which I selected. Mail then asked for my account's password; after I entered it, the outgoing test emails went out immediately.

 

Mail sending works again.

Reply by Neville Hillyer on Apr 5, 2013 9:35 AM Helpful

All replies

  • Neville Hillyer Level 4 Level 4

    comcast-smtp-settings.png

  • John Medaglia Level 1 Level 1

    Problem not solved.

    Cannot sent mail from this computer but can receive mail.

    I used Mail preferences, advanced, and check-marked SSL, which also automatically changed the port to 995. Password is correct on Mail Preferences.

    Network Utility shows 68.87.26.155 is a comcast mail server.

     

    Mail has previously worked until last month.

  • Neville Hillyer Level 4 Level 4
  • John Medaglia Level 1 Level 1

    Thanks,  Neville Hillyer. Your advice was helpful, but in os 10.4, mail 2.1.3, and Comcast setup advice online there were some port differences that solved the problem. Thanks to NH I saw the SSL option was not consistent on outgoing versus incoming; saw two different sequences to use mail preferences for setting up incoming versus outgoing; and saw on COMCAST set-up that they like 2 different port numbers. My other newer Macs have not had this problem (yet) which seems strange since I saw port 110 in all my Macs.

    Mail preferences:

    a-- accounts Information tab type POP, my userid, mypassword, and on advanced tab incoming port  should be 995, SSL checked, Authentication should be Password

    b-- accounts information incoming server mail.comcast.net, my userid and mypassword, outging server smtp.comcast.net:myuserid, server settings port 465, SSL checked.

    c-- in this old version mail 2.1.3, there is not save button until I select another account and a pop-up indicates my account changed and offered the save button which I selected. Mail then asked for my account's password; after I entered it, the outgoing test emails went out immediately.

     

    Mail sending works again.