5 Replies Latest reply: Jul 20, 2013 9:59 AM by PatrickFromCA
zigou_ Level 1 Level 1

I have rented a movie that I cannot read. Error message says "this movie requires Quicktime, which is not supported by this version of iTunes". BTW, iTunes is up to date, OS X is the latest version etc.

Just so you know

 

iTunes : 11.0.2 64 bits

OS X : 10.8.3

Hardware supports HD movies (CPU 2.53 GHz, RAM 4 Go etc)

And of course all other HD movies play perfectly, but not rentals as a rule.

 

Anybody has a similar experience?

 

Cheers

Z


MacBook Pro, OS X Mountain Lion (10.8.3)
  • Niel Level 10 Level 10

    Click here and follow the instructions.

     

    (79763)

  • Goteman Level 1 Level 1

    Having the exact same problem and error message when trying to download and play video podcasts. Have tried restarting iTunes, have tried the solution Niel mentions below. No luck yet.

  • zigou_ Level 1 Level 1

    Niel : thanks for the advice... but no luck yet. Anyway, it was not an old file but a recent rental.

    However, this helpded me partly :

    - locate the file in the Finder

    - drag it on the desktop to create a backup copy

    - delete the file in the iTunes (choose "yes" to erase the physical file if prompted)

    - drag and drop the backup copy, like you would import a new movie in itunes

     

    With this, I am able to play the movie in iTunes and on the Apple TV.

    Still, cannot transfer it to the iPad.

     

    I am at a loss here...

     

    Z

  • corwin of amber Level 1 Level 1

    Hi All

    A point of clarity on this.  Ref the files that are not supported, it depends on when they are created not when they are downloaded.  I had the same problem last year and the 32 bit fix suggested above worked then and has worked again now.

     

    On 10.8.3 update  it seems that the update has overwritten a number of customized settings including the 32 bit itunes change.  Ive spent days trying to get it all working as It was prior to the latest update.  Apple - the quality of your updates seem to be slipping, come on guys get with the program.

     

    Z - not sure why the fix didn't work for you

     

    Corwin of Amber

  • PatrickFromCA Level 1 Level 1

    Niel, your fix doesn't seem to work with iTunes 11.0.4.