6 Replies Latest reply: Mar 31, 2013 7:50 AM by kiwirock30
kiwirock30 Level 1 (0 points)

4th gen, IOS 6.1.3.


I've setup imessage and facetime correctly, WiFi works perfect, I've signed in and both my email is active for imessage etc... It won't sent imessages or facetime gives up trying to connect.


It's not my router, it's not blocking port 5223 outbound, I've even tried mapping inbound. I've signed out multiple times in imessage then re-signed in and made sure email address used is correct on setup.


I've even powered it off, and tried switching imessages off/on still no luck.


I've signed in to Apple and changed my country then back again then signed the ipod out and back in, still no **** progress.


My friends imessage on her iphone 4 with ios 6.1.3 works flawless and I helped set it up, I've done nothing different with my ipod touch and it just won't send, it hangs just before the send progress bar ends then eventually says not delivered, GRRRRRR.


What am I missing? I'm an IT tech, I've done everything I can think of. Not even upgrading to 6.1.3 has fixed it, it wouldn't work on the previous 6 either.


I can use Skype and everthing else fine. My DNS works flawless, my Wi-Fi works flawless, it signs in fine and shows my email address setup correct, what's the problem?

iPhone 4, iOS 5.1
  • kiwirock30 Level 1 (0 points)

    FYI... I can message myself to my own email address, but to no one else, nore receive.

  • lllaass Level 10 (172,035 points)

    Can anybody message you?

    Have you tried when connected to another network?

    Have you tried signing out of Settigs>FaceTime and signing in again?

    have you looked here:

    iOS: Troubleshooting Messages

  • kiwirock30 Level 1 (0 points)

    Tried each suggestion, and read the article along with the extra bits and links on what's needed if not working. I even tried bringing the iPhone here and sending an iMessage to my iPod Touch with both connected to the same Wi-Fi network, no luck. Skype on the other, video works perfect without leaving the Wireless subnet.


    I'm quite at a loss. No, no messages get to me and none will send, but I'm trying it with an iPhone that can both iMessage and FaceTime others beside me fine. I've tried signing out, re-signing in, checking all my credintials on my Apple ID via a web browser on my desktop too. I even changed region and back again incase it was a region issue.


    I powered down between signing out and in. I even tried just killing the iMessage process (double click home and delete the process). Still no go.


    I even wiped the network settings and re-did the passwords etc... for Wi-Fi, verified DNS settings. I even opened up port 5223 inbound to the iPod Touch from my DSL router (not that it should be require, the iPhone doesn't care less but tried none the less).



  • kiwirock30 Level 1 (0 points)

    Email address and Apple ID all activated and verifyed too.

  • lllaass Level 10 (172,035 points)

    All that is left:

    - Restore from backup. See:                                 

    iOS: How to back up           

    - Restore to factory settings/new iOS device.

  • kiwirock30 Level 1 (0 points)

    Okay I tried that and here's the results:


    Did a restore and chose setup new device (not from backup).


    Now I have a new problem, I can not sign-in at all with my Apple ID in iMessage or FacTime. But, I can sign-in with my Apple ID under Settings--> iTunes & App Stores fine. However, when I go back and try with iMessages and FaceTime, after about a minute it finally says could not sign in, Please check your network connection and try again. I can't turn iMessages off and back on, and power cycling doesn't fix it. Now it just won't sign in under those apps, but will in App store. Once signed in, in App store it still asks to sign in under iMessages.


    So the situation has just gone from bad to worse by restoring the device.


    I've read up elsewhere about doing a DFU recovery (not recovery mode recovery) so I might try loading old 4.3.3 firmware then re-upgrading to 6.1.3 and see if that solves anything incase there is a corrupt file or something on this. I've had it for just on a year, iMessage has never worked even when signed in. It doesn't seem to be a simple fix for something that should just work, especially after a restore to factory job.