1 Reply Latest reply: Apr 1, 2013 12:52 AM by Stains
Stains Level 1 (0 points)

I have an IPhone 5 on P&G with o2. After having updated my IPhone to the latest OS last week I'm having issues with sending text messages. Texts that I'm sending and being charged for aren't being delivered to the recipient despite being marked on my phone as 'sent'; I'm not getting the small red exclamation mark to say that any of them haven't been sent. As far as I'm aware this is only happening to one number (UK number, Orange network, basic Samsung model) and has only started happening since the update. I've tried sending other numbers text messages and they are sent and recieved no problem, however for some bizarre reason not this one number. I can recieve texts from the person and can accept calls and call them, I just can't send them a text message.


I've tried:


- Turning off IMessage.

- Resetting my Phone.

- Deleting the contact and all previous correspondence and manually entering the number in the text.

- Trying the number both with and without the +44 prefix.

- Updating my number to have the +44 prefix.

- Restoring Network settings.

- A full 3 hour wipe and full restore of the phone to factory settings.


And nothing has worked. At my wits end. The person who I'm having the difficulty texting is someone I speak to on an almost daily basis via text so I really need it sorting asap. I'm not even sure if it's a network problem or a problem with the phone. Any help would be much appreciated.

iPhone 5, iOS 6.1.3
  • Stains Level 1 (0 points)

    I've just switched SIM cards with someone else who is on P&G o2 and has an IPhone 5 running 6.1.2. My sim in their phone still won't send texts to the problem number yet their sim in my phone will? Think it might be a network issue?