Previous 1 2 Next 25 Replies Latest reply: Sep 16, 2013 5:36 AM by cajani Go to original post
  • spanzetta Level 1 (0 points)

    A port scan with Fing reports (Printer IP) the following ports/services:

    80 http

    443 https

    631 IPP

    8080 http-proxy

    9100 jetdirect

    9101 jetdirect

    9102 jetdirect

    9111 DragonDSConsole


    I don't see 5353 (Bonjour)... so.. could it be the Printer itself (Bonjour not enabled, which is not true of course) or the Router (that has 5353 closed, despite what Dlink says.. and the Port Forwarding that is enabled on that port)... or the iPhone has that port closed????

    What do you think?

  • spanzetta Level 1 (0 points)

    any ideas?

  • ChrisJ4203 Level 8 (47,669 points)

    The only other thought that comes into mind is the fact that Bonjour is installed with iTunes. You could uninstall iTunes, then reinstall iTunes. This does not affect your music library, apps or other settings, nor does it delete anything dealing with your phone.


    I'm thinking you are using a Windows computer, and if so, you need to make sure that you uninstall and reinstall as directed in this support document. Not sure which Windows you might be using, but I opted for the newer version.


    See if this helps. After going through the uninstall and reinstall it has you reboot the computer. I would then reboot the router again (sorry) and the phone before trying to print again. See what happens here.

  • spanzetta Level 1 (0 points)

    Hi Chris

    I am not talking about a PC.. I am talking about an iPhone 4S that doesn't see the Airprint Printer..
    The connection scheme is:

    iPhone 4S <--> WiFi Router (D-Link DLS-2680) <--> Airprint Printer (HP 3520 e-All-in-One)


    The problem appears to be on Bonjour because - afaik - that is the discovery method used by iPhone for Airprint..
    The Printer has Bonjour enabled (there is a specific menu entry for that).. but - as described - using the Fing app on the iPhone apparently it's not visible/enabled (5353 port).. and that could be a problem on iPhone itself, on the router or on the Printer..

    I did talk with HP (they assure that the printer has Bonjour enabled/is Airprtin compatible)

    I did talk with Dling (they assure that the router has Bonjour not blocked)..

    What else could it be?


  • ChrisJ4203 Level 8 (47,669 points)

    I realize that you are talking about the iPhone. I was just wondering if something about the communication between the phone and the printer is getting some information from the computer itself.


    I must say that I have seen a number of entries lately regarding D-Link routers and problems with communication with iPhones. I don't remember how many involved printers, but there seem to be a lot. While it may be a coincidence, I can't help but wonder. With the printer having the latest firmware as you said, the phone the same, the router seems to be the only thing that could interfere with the connection.

  • pnl321 Level 1 (0 points)

    Hi Chris,

    I too have a D-Link router (DIR-657) and am unable to print to my HP D110a wireless printer from my iPhones. This seems to have started after the latest iOS update but that is hard to tell for sure because I don't print very much at all using the iPhones. What I do know for sure is I have 2 laptops and a PC that I can print from. I have 2 other family members that come to visit and they connect to my network and they can print wirelessly. The printer has Bonjour and IPP enabled. The router has multicasting enabled which D-Link says would be the only thing that would prevent wireless printing from my iPhones. It seems like other people in this thread also have issues after updating to iOS 6.1.3 and I can't see any other reason why we can't print. Can you?

  • spanzetta Level 1 (0 points)

    Well.. I came to the conclusion that is definitevelly the DLink router that "cuts" the Bonjour traffic.. because I did configure my printer in Direct Wireless mode (that means the iPhone connects directly to the printer, bypassing completelly the router) and the Airprint works perfectly (and also the 2 HP iPhone apps now works fine..). As soon as the traffic goes trough the router problems comes back!


    I did open a ticket with DLink tech-support...and.. still waiting their answer (they have to admit it's their fault!) .. They told me that they are escalating the issue, doing research, blah blah...


    The fact that the 2 laptop can print wirelessly is normal.. PC doesn't use Airprint/Bonjour...


    I don't think at this point it's a matter of iOS version.. it's a matter of Router capabilities..

  • ShlomiL Level 3 (770 points)


    Have you enabled Multicast streams within your router configuration? it is disabled by the default configuration.


    be sure to check the option under Advvanced > Advanced Lan within your router homepage:


    Next be sure to reboot your router and check if that may help.



  • pnl321 Level 1 (0 points)

    I thought I had something. I went into Setup > Network Settings and added both phones to the DHCP Reservations List. I checked mine (wife was still at work) and I was able to find my printer. This new found joy lasted about 3 hours, though. 


    My printer doesn't have the Wireless Direct feature so I am unable to see if that is an option.

  • spanzetta Level 1 (0 points)

    Of course I've enabled MultiCast (also IGMP and UPnP).. and tried also with Fixed IP address and DHCP (with and without reservation list)..

    The Wireless Direct feature was the test that did demonstrate that iPhone and Printer can work togheter with Airprint.... NOT when there is the Router in the middle ...

    I hope DLink will find and solve the issue..
    I'll keep you informed..

  • cajani Level 1 (0 points)

    Some wireless routers are designed to switch channels when interference is detected from microwaves, wireless phones etc which may interfere with bonjour and hence AirPrint/AirPlay.

    If this is so for you router you should change the settings to a fixed channel for instance 11.

    try that and see if it works.

    It worked for the BT Home Hub router as suggested by:

Previous 1 2 Next