13 Replies Latest reply: May 8, 2013 8:26 AM by Old Toad
jayawe Level 1 Level 1 (0 points)

My iPhoto has been playing up and I want to reinstall it. I can't seem to manage it. I have tried to locate the receipt but no luck. I am using a MacBookPro with 10.6.8.

MacBook Pro, Mac OS X (10.6.8)
  • Terence Devlin Level 10 Level 10 (134,915 points)

    What does "playing up" mean? Are you sure it's not a Library issue?


    To re-install iPhoto


    1. Put the iPhoto.app in the trash (Drag it from your Applications Folder to the trash)


    2a: On 10.5:  Go to HD/Library/Receipts and remove any pkg file there with iPhoto in the name.


    2b: On 10.6: Those receipts may be found as follows:  In the Finder use the Go menu and select Go To Folder. In the resulting window type




    2c: on 10.7 they're at




    A Finder Window will open at that location and you can remove the iPhoto pkg files.


    3. Re-install.


    If you purchased an iLife Disk, then iPhoto is on it.


    If iPhoto was installed on your Mac when you go it then it’s on the System Restore disks that came with your Mac. Insert the first one and opt to ‘Install Bundled Applications Only.


    If you purchased it on the App Store or have a Recent Mac you can find it in your Purchases List.

  • jayawe Level 1 Level 1 (0 points)

    Hey and thanks for replying. iPhoto started not synching properly with my iPhone (can't seem to get all the pix off for example) and now it won't open at all - just no response when I try to open it

    I've gone through the steps for 10.6 and I am not sure what I am supposed to do as I can't see any iPhoto files in there?

  • Terence Devlin Level 10 Level 10 (134,915 points)

    As a Test:



    Hold down the option (or alt) key and launch iPhoto. From the resulting menu select 'Create Library'



    Import a few pics into this new, blank library. Is the Problem repeated there?

  • jayawe Level 1 Level 1 (0 points)

    It will open doing that but just freezes (which is what it was doing a few weeks ago before it stopped doing that altogether)

  • Terence Devlin Level 10 Level 10 (134,915 points)

    Create a new account (systempreferences -> accounts or Users & Groups on 10.7 and 10.8), make a new Library in that account, import some shots  and see if the problem is repeated there. If it is, then a re-install of the app might be indicated. If it's not, then it's likely the app is okay and the problem is something in the main account.

  • jayawe Level 1 Level 1 (0 points)

    Ok so i have another account and it worked fine there...what next?!

  • Terence Devlin Level 10 Level 10 (134,915 points)

    That tells you the app is fine. If it was bunged up then it wouldn't work in any account. So, the problem is local to the main account.


    Try trash the com.apple.iPhoto.plist file from the HD/Users/ Your Name / library / preferences folder.


    (On 10.7: Hold the option (or alt) key while clicking on the Go menu in Finder to access the User Library)


    (Remember you'll need to reset your User options afterwards. These include minor settings like the window colour and so on. Note: If you've moved your library you'll need to point iPhoto at it again.)


    What's the plist file?


    For new users: Every application on your Mac has an accompanying plist file. It records certain User choices. For instance, in your favourite Word Processor it remembers your choice of Default Font, on your Web Browser is remembers things like your choice of Home Page. It even recalls what windows you had open last if your app allows you to pick up from where you left off last. The iPhoto plist file remembers things like the location of the Library, your choice of background colour, whether you are running a Referenced or Managed Library, what preferences you have for autosplitting events and so on. Trashing the plist file forces the app to generate a new one on the next launch, and this restores things to the Factory Defaults. Hence, if you've changed any of these things you'll need to reset them. If you haven't, then no bother. Trashing the plist file is Mac troubleshooting 101.

  • jayawe Level 1 Level 1 (0 points)

    I deleted the file, and reopened iPhoto but it just froze again..

  • Old Toad Level 10 Level 10 (130,045 points)

    It could be another preference file other than iPhoto's.  To check that out try the following:


    Trouble Shooting Preferences


    NOTE: In Lion and Mountain Lion the Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and hit the Enter button - 10.7: Un-hide the User Library folder.


    1 - close all applications.


    2 - open your Home/Library folder and Option-drag (copy) the Preferences folder to the Desktop. 


    3 - select the contents of your Home/Library/Preferences folder and drag them into the Trash bin in the Dock.  You will be asked to provide your Admin password.


    4 - reboot.


    5 - run the application again and determine if the problems is fixed


    6 - If the problem is fixed:


    A - open the working Home/Library/Preferences folder.


    B - Open the Preferences  folder on the Desktop, select all of the contents and drag them into the working Home/Library/Preferences folder.


    C - When the Copy window pops up check the "Apply to All" check box and then click on the Don't Replace or Skip button.




    D - reboot.


    7 - If the problem is NOT fixed, drag the contents of the Preference folder on the Desktop into the Home/Library/Preference folder and replace the entire contents that were created by clicking on Replace.


    8 - reboot.




  • jayawe Level 1 Level 1 (0 points)

    Its taken a while and getting a friend who is IT savvy to help work through this but she has done these suggestions and it is still not working!

    Any other advice?

  • Old Toad Level 10 Level 10 (130,045 points)

    Boot into Safe Mode, Mac OS X: Starting up in Safe Mode, and see if iPhoto will operate as it should.  Then reboot normally and try again.

  • jayawe Level 1 Level 1 (0 points)

    No luck - still just froze...

  • Old Toad Level 10 Level 10 (130,045 points)

    What do we know:


    1 - iPhoto freezes in your account whether it's in Safe mode or not nor with a new library.


    2 - iPhoto does not freeze up in another user account.


    Looks like you'll need to backup your hard drive, reinstall your system and then migrate your files from the backup to your new account. 




    create a new, admin account (if your current account is an admin acct) on your Mac, move your home folder files, Documents, Movies, Music, Pictures, Desktop, etc., make sure iPhoto works there as expected and does not freeze and then delete the problem account.