11 Replies Latest reply: Jun 27, 2013 7:21 AM by Livingwatercolours
KiiaN Level 1 Level 1 (0 points)


I did a 16:46:00 long movie from my winter holiday, but iMovie didn't let me to export it. I have tried all the things I can think of, but still not working. Sometimes it just crashes while trying to export or finalize the movie and there comes an error saying: " The project could not be prepared for publishing because an error occurred. (-108) " I have duplicated the movie, took my music off of it and shortened it. And still nothing. I even found some advice and changed the exporting settings or something and I have done a shorter movie a couple of months ago and there was no problem exporting it, but now ...


So what would you do in my situation ?

Please help !!


Thank you in advance !


-Hopeless girl

  • John Cogdell Level 5 Level 5 (4,605 points)

    According to what I've seen in other posts on this forum, Error 108 means that you've run out of memory. You may not have enough free space on your hard drive to enable iMovie to work properly when exporting the project. As well as using memory (RAM), iMovie needs to work with temporary files and so forth, requiring free space on the hard drive.


    So, check the free space on the hard drive. One recommendation I've seen is to have at least 10% free, but I've had success when down to about 25 GB of free space.


    Another suggestion is to turn off Time Machine if you have it running. In System Preferences select Time Machine and click on the large OFF button. But remember to switch it back on after completing the export from iMovie.


    Also, don't worry about Finalizing the project. That is simply designed to export the project in all available sizes, which you probably don't require. So just Share in the size you require, using one of the preset options in the iMovie menu item "Share".



  • KiiaN Level 1 Level 1 (0 points)

    Thanks for the advices.

    I've checked my memory and I have about 50% free space so that shouldn't be an issue.

    I turned the Time Machine off but it didn't help either. I don't know what's wrong


    Do you have any suggestions what settings i should use like the compression type or something else ?


    - Kiia

  • John Cogdell Level 5 Level 5 (4,605 points)

    Sorry to hear that none of that helped Kiia.


    Regarding export settings, I generally use the Apple presets. If I'm burning a DVD (using iDVD) I usually select Share > Export > Media Browser and choose the Large or HD 720p setting. I can also access the exported movie file from the project's package contents folder, then copy and paste it to the Desktop. From there, I can copy the file to a USB flash drive or an external portable drive for playback through my Media Player.


    Alternatively, I use Share > Export Movie and save it to a preferred location (usually an external desktop hard drive). If I've imported the footage as Full 1920 x 1080, I usually export as HD 1080p - this can also be used for playback through my Media Player. Of course, exporting as 1080p can also be done using Share > Export > Media Browser.


    Having said all this, I don't think your export settings are causing the problem you are seeing. Possibly you have a corrupt clip (video, photo or music) that iMovie can't get past (just guessing). Yet you mentioned that you had removed music and shortened the movie, so perhaps that's unlikely.


    Have you tried closing iMovie and shutting down your Mac? A restart will refresh the memory (I have 8 GB on my MacBook Pro).


    Another suggestion is to trash the preference files for iMovie and iLife. For full details, see this User Tip by AppleMan1958:




    Best of luck with this Kiia. If anything else occurs to me I'll come back.



  • KiiaN Level 1 Level 1 (0 points)

    This is unbelievable !

    I had modified the clip adjustments so the only thing that I had to do was to change for all the clips the video effect from "hard light" to something else.

    And then it exported it right away.


    But thank you anyway, I hope your advice will be useful for someone else (:



  • John Cogdell Level 5 Level 5 (4,605 points)

    Good to hear that you've got it working Kiia. Sometimes it's a seemingly trivial thing that causes a problem. Well done in tracking it down!




    PS Stay away from the "hard light"

  • Livingwatercolours Level 1 Level 1 (0 points)

    I think I'm having the same problem. The project I have in imovie only give me the option to share it in the media browser in small, but I want to be able to play it on my tv, t doesn't give me the medium or large options. What is "hard light"?

  • John Cogdell Level 5 Level 5 (4,605 points)

    Livingwatercolours wrote:

    What is "hard light"?

    Hard Light is one of the Video Effects in iMovie. Double-click on a clip to open the Inspector. In the Clip tab you will see an item labelled Video Effect - click on this to reveal a panel of effects to choose from. See the following screenshot (I've arrowed the Hard Light effect):


    Hard Light.png


    My comment to KiiaN to "keep out of the hard light" was just a tongue in cheek remark, given that "hard light" seemed to be causing the problem.


    Regarding the problem you have in sharing your project, possibly the project doesn't support the larger sizes. What is the source of your clips? Were they imported from a camcorder or camera, or perhaps from a movie file on your hard drive? Right-click (or control-click) on a clip and select Reveal in Finder from the pop-up menu. In Finder, open the clip in QuickTime then select Window > Show Movie Inspector. In the Inspector, what does it show for FORMAT and FPS (frames per second)? I'm guessing that the resolution is less than 640 x 480 - that's why you are unable to share at the larger sizes.



  • Sunekbr Level 1 Level 1 (0 points)

    Hi there


    I also have a problem with exporting my files from iMovie to an ekternal hard drive. There is no problem exporting it on my Macbook, but when it is exported (and working) i cant move it to my external hard drive. There is 400 GB free disk space on my external, so space is not an issue. I then tried exporting it from iMovie directly to my external. iMovie is exporting but the file never shows up on my external. What to do?


    Best regards,




  • Livingwatercolours Level 1 Level 1 (0 points)

    Thank you John,

    I looked at the resolution size & it is indeed less than 640x480. It's strange though since I took a number of clips that morning, not changing any settings & some of the other ones are larger & are able to be shared at the medium & large sizes. I'm not sure what caused that. I'm using a Panasonic Lumix DMC-ZS19 camera. In the settings for the rec quality, it's on FSH the other options are SH & PSH. Do you think it's related to this?

  • John Cogdell Level 5 Level 5 (4,605 points)

    Livingwatercolours wrote:


    I'm using a Panasonic Lumix DMC-ZS19 camera. In the settings for the rec quality, it's on FSH the other options are SH & PSH. Do you think it's related to this?

    No, the FSH setting is fine. It's 1920 x 1080 60i, which is Full HD 30 frames per second (i means interlaced which records 2 fields per frame, or 60 fields per second).


    However, there is a setting for High Speed Video 320 x 240 at 220 frames per second in Motion JPEG format. Perhaps you inadvertently used this setting (although I'm not sure how iMovie handles a frame rate of 220 fps).


    See this screenshot taken from the Panasonic website -



    Lumix DMC-ZS19 .png

    TIP: Don't use the first setting (PSH 1920 x 1080 60p) as iMovie has trouble with 1080 60p clips (they may not even import). The SH setting (1280 x 720 60p) is a good option as it gives you progressive video in excellent quality. iMovie works best with progressive video (versus interlaced).


    See this Panasonic page (Overview for the Lumix DMC-ZS19) for a good explanation of progressive video (look under the heading about one third down the page entitled "Video"):





  • Livingwatercolours Level 1 Level 1 (0 points)

    Thank you very much for you help John. I've learned a lot.

    I didn't know they had the advanced owners manual. I'm going to read through that.

    Take care, & have a wonderful day!