6 Replies Latest reply: Apr 3, 2013 8:37 AM by andyBall_uk
magwire Level 1 (0 points)

Can't update safari from 5.0.5 to 5.1.7 on mac 10.6.8. Message says it can't because I already have newer version installed...?


iMac (17-inch Early 2006), Mac OS X (10.6.8), Safari
  • QuickTimeKirk Level 9 (52,200 points)

    You must have moved Safari from its expected location (HD/Applications folder) on your drive.

    Move it back and try again.

  • ds store Level 7 (30,325 points)

    I suggest you do #8 Reinstall Just OS X followed by running Software Update until clear.

     

    ..Step by Step to fix your Mac

  • WZZZ Level 6 (12,835 points)

    Before reinstalling, it would be far less painful to  try applying or reapplying the 10.6.8 Combo Update which will bring bring a new 5.0.5, then run Security Update 2013-001, which should bring it to 5.1.8.

     

    The Combo Update is not a reinstall, it will just replace missing or damaged files, from 10.6.0 through 10.6.8, including, in this case, the Safari 5.0.5.

     

    You won't have the hassle of running Software Update a zillion times for other items.

     

    Message was edited by: WZZZ

  • WZZZ Level 6 (12,835 points)

    If this succeeds, you won't have the hassle of running Software Update a zillion times for other items.

  • ds store Level 7 (30,325 points)

    There is something wrong with his machine.

     

    I suspect corruption, anti-malware and/or malware itself, thus the #8 Reinstall Just OS X method should solve all those issues at once and then Software Update should work perfectly after that.

     

    The new anti-malware Apple installed should flag and remove if any of it remains.

     

    It wouldn't hurt if there isn't a problem neither.

  • andyBall_uk Level 7 (20,490 points)

    magwire - as QuickTimeKirk suggests, you could be using an outdated Safari that isn't in Applications...

    Open Safari from Applications & see what version is actually there.

     

    You might already have 5.1.8, in which case the 'newer version' message on installing 5.1.7 is entirely normal, and you just need to use 5.1.8 & ignore/delete earlier ones.

     

    what 'anti-malware and/or malware itself' causes an outdated Safari ?