Previous 1 2 3 Next 40 Replies Latest reply: Oct 31, 2014 6:56 AM by webdevbrian Go to original post
  • Brehtej Level 1 Level 1 (0 points)

    I had this problem setting up iMessage for my parents,  and it wasn't recognizing my phone number as an iPhone with iMessage. I resolved it by going into the contacts app on the Mac, selected my name/number, selected iPhone as the number type, and added a +1 to the beginning of the number. After that, it immediately recognized my number as a number for iMessage. Pretty much, double check the number to make sure it's complete with area code.

  • P Willis Level 1 Level 1 (0 points)

    Frustrating as ****. Seems like such as uselss App to have. Works fine on my iMac, doesn't work at ALL on my iPad Air. Same Apple ID, logged in, verified, . . . useless. Same with Calendar, Notes and Facetime: Fine on an iMac, ***** on iPad.

     

    Sorry, frustrated and feeling really disorganized.

  • disintegration Level 1 Level 1 (0 points)

    this happen on my imac. I would receive a message on my phone and imac but could only reply from my phone. I opened contacts on the imac and reentered their phone number. just area code and number. did not place a (1) in front. reopened messages and I am able to reply to them again.

     

    have no idea why it happened to begin with. try it. hope it works for anyone else having this happen

  • pwillisca Level 1 Level 1 (0 points)

    disintegration, thanks for your reply. This seems to work!!!!!!!! Awesome! You're the King! :)

  • disintegration Level 1 Level 1 (0 points)

    well now lets not get carried away

     

    i am just glad it worked for ya and hopefully anyone else experiencing this annoying little issue.

  • pwillisca Level 1 Level 1 (0 points)

    No, really. This was driving me nuts. Now if I can get my calendars and notes in sync I'll be over the top!! 

  • disintegration Level 1 Level 1 (0 points)

    I have not run into that issue just yet and I think I have used up what little tech know-how I have for the remainder of the month lol. only thing I can think of would be to log out of icloud on all devices and then log back in and cross your fingers

  • MFrankieP Level 1 Level 1 (0 points)

    If you go to contacts and register the contact mobile number as iphone -- not mobile - it will allow you to ichat.

  • cvpacs Level 1 Level 1 (0 points)

    This has been a source of frustration for quite a few Apple customers.

     

    If iPad texting only works with other Apple devices then one solution is to install Google Voice on the iPad.

    Text works fine with this app.

  • DeadPhish79 Level 1 Level 1 (0 points)

    Is there a solution? All of my contacts I message on my mac are now showing up as not registered with iMessage. So annoying!!!!!!!!!

  • webdevbrian Level 1 Level 1 (0 points)

    I just got done dealing and solving with this on iOS8. I have a macbook pro which I use with my iphone with imessages and my wife's iphone.

     

    My wife and I use the same icloud account so we can sync calendars and reminders. We also share the same itunes account for purchasing with my card.

     

    Beyond the weirdness that was going on - we both recently updated to iOS8. What everyone needs to do, if you're having issues EVER with imessages is sign out of ALL DEVICES using iCloud. Sign out of iCloud, iMessages, iTunes (go into the settings and manually do all of this). Then restart all of the devices.

     

    Then, one by one, sign into each all over again. After when you've signed into all of them, reboot all of your devices again (I needed to do this).

     

    iCloud got extremely messed up when I updated our phones and updated from Yosemite.

     

    Hope this helps someone! I was tearing my hair out.

Previous 1 2 3 Next