5 Replies Latest reply: Apr 3, 2013 10:18 AM by lllaass
ashleyc Level 1 Level 1 (0 points)

I have a 4th gen iPod touch.  The software is at v2.2.1 and says that it is up to date and there are no updates for it.  My iTunes on my computer is up to date so it is not my iTunes.  When I try to download an app, the app store tells me i need at least iOS 5 but when I try to update the software it tells me it is up to date.  Is there a reason it will not let me download the update or doesn't recognize there are updates for it?  Thank you for any help in advance.


iPod touch, Windows XP