6 Replies Latest reply: Feb 6, 2016 1:57 PM by christopherfromwinchester
krismith190 Level 1 (0 points)

I use to be able to use screenshots by selecting cmd shift 3 or 4,but now I hear the click sound and I get the message


"Your screenshot can't be saved"  'You do not have permission to save files in the location where screenshots are stored'


I know I can use the 'grab' app, but I found this quicker.

help please

MacBook Pro (15-inch, Mid 2012)
  • Eric Ross Level 6 (11,665 points)

    Try using disk utility to repair the permissions on your hard drive.  http://support.apple.com/kb/HT1452

  • Linc Davis Level 10 (192,719 points)

    Back up all data. Don't continue unless you're sure you can restore from a backup, even if you're unable to log in.

    This procedure will unlock all your user files (not system files) and reset their ownership and access-control lists to the default. If you've set special values for those attributes on any of your files, they will be reverted. In that case, either stop here, or be prepared to recreate the settings if necessary. Do so only after verifying that those settings didn't cause the problem. If none of this is meaningful to you, you don't need to worry about it.


    Step 1

    If you have more than one user account, and the one in question is not an administrator account, then temporarily promote it to administrator status in the Users & Groups preference pane. To do that, unlock the preference pane using the credentials of an administrator, check the box marked Allow user to administer this computer, then reboot. You can demote the problem account back to standard status when this step has been completed.

    Triple-click the following line to select it. Copy the selected text to the Clipboard (command-C):

    { sudo chflags -R nouchg,nouappnd ~ $TMPDIR.. ; sudo chown -R $UID:staff ~ $_ ; sudo chmod -R u+rwX ~ $_ ; chmod -R -N ~ $_ ; } 2> /dev/null

    Launch the Terminal application in any of the following ways:

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

    Paste into the Terminal window (command-V). You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning to be careful. If you don’t have a login password, you’ll need to set one before you can run the command. If you see a message that your username "is not in the sudoers file," then you're not logged in as an administrator.


    The command will take a noticeable amount of time to run. Wait for a new line ending in a dollar sign (“$”) to appear, then quit Terminal.

    Step 2 (optional)


    Step 1 should give you usable permissions in your home folder. This step will restore special attributes set by OS X on some user folders to protect them from unintended deletion or renaming. You can skip this step if you don't consider that protection to be necessary, and if everything is working as expected after step 1.

    Boot into Recovery by holding down the key combination command-R at startup. Release the keys when you see a gray screen with a spinning dial.

    When the OS X Utilities screen appears, select

    Utilities Terminal

    from the menu bar. A Terminal window will open.

    In the Terminal window, type this:



    Press the tab key. The partial command you typed will automatically be completed to this:



    Press return. A Reset Password window will open. You’re not  going to reset a password.

    Select your boot volume ("Macintosh HD," unless you gave it a different name) if not already selected.

    Select your username from the menu labeled Select the user account if not already selected.

    Under Reset Home Directory Permissions and ACLs, click the Reset button.



    from the menu bar.

  • Shavhill Level 1 (0 points)

    I have the same issue. Could'nt repair it.

    I tried the 2 above solutions + that one :

    http://osxdaily.com/2015/10/05/disable-rootless-system-integrity-protection-mac- os-x/

    This last one discarded the "can't be saved" message but does not allow me to past the screenshot elsewhere....


    Didn't solve the probleme
    (Lemme know if it does for you)


    Until then, I use the "Grab" utility (not that handy) :

    > GO > Utilities > Grab

  • Shavhill Level 1 (0 points)

    UPDATE :

    Seems like Mozilla Firefox when open blocks the screenshots. Won't happen when Firefox is closed.

  • bhillman Level 1 (0 points)

    If Firefox being open blocks screen shots, see if Trusteer Endpoint Protection (Rapport) is installed. This has a preference setting that blocks screen shots.

    Screen Shot 2015-12-12 at 9.04.35 AM.png

  • christopherfromwinchester Level 1 (0 points)

    Thank you bhillman.  Going to "Console" on Trusteer, and choosing "Never" for blocking sites worked immediately.