8 Replies Latest reply: Apr 6, 2013 9:16 AM by Old Toad
MalcW Level 1 (30 points)

For years I have used PSE (Photoshop Elements) as the external editor in iPhoto (iPhoto 8 - 7.1.5).  Recently I upgraded to a new machine which has iPhoto 11 (9.4.2) installed.  I decided (amongst other things) to crop a photo in PSE using the "No Restriction" option.  When this photo was re-opened in iPhoto, iPhoto rendered it as a "stretched" photo - like it was trying to force it to the original photo ratio.  Obviously all the dimensions looked weird in this "stretched" photo! As an experiment I reverted the cropped photo to "Original" and then performed the exact same crop within iPhoto itself.  No problem. The photo was rendered exactly as you'd expect.  So why does the new iPhoto not seem to handle externally cropped photos properly?  Is there a solution? (other than forking out another 50 quid for the latest version of PSE - which may or may not have the same issue!)


Yes I'm using an old version pf PSE (6 in fact) but everything else (at least everything else that I've tried!) seems to work OK.


Thoughts anyone?

MacBook Pro (Retina, Mid 2012), OS X Mountain Lion (10.8.2), Using external Cinema Display
  • Terence Devlin Level 10 (137,945 points)

    What's the "no restriction" option you refer to?

  • MalcW Level 1 (30 points)

    In PSE select the Crop Tool and in the top left corner under Aspect Ratio the drop down menu gives you a choice of crop tool size.  One of the choices is "No restriction" which means that you get to choose the crop area.  Usually you choose "Use Photo Ratio" to maintain the crop as the same ratio as the original.  However there are other choices which in the past have worked well.  On this occassion I need to crop the photo for an unusual purpose and therefore chose "No Restriction".  This I have done many times in the past with no problemPSE SCreen shot.jpg

  • MalcW Level 1 (30 points)

    I've had a few gremlins with this latest incarnation of iPhoto.  And it seems to have done it again.  I just cropped another photo using "No Restriction" in PSE and then opened it in iPhoto. Worked perfectly this time.  Hmmm.  You have to wonder what is going on.  I'll keep playing around and report any other odd behaviour.


    Maybe it was just a one off?  Here's hoping.



  • Terence Devlin Level 10 (137,945 points)

    If it does recur you could try trashing the iPhoto cache.






  • Old Toad Level 10 (135,423 points)

    I may be preaching to the choir here but there may be some PSE tips here that might help, particularly regarding PSE's preferences:


    Using Photoshop or Photoshop Elements as Your Editor of Choice in iPhoto.


    1 - select Photoshop or Photoshop Elememts as your editor of choice in iPhoto's General Preference Section's under the "Edit photo:" menu.




    2 - double click on the thumbnail in iPhoto to open it in Photoshop.  When you're finished editing click on the Save button. If you immediately get the JPEG Options window make your selection (Baseline standard seems to be the most compatible jpeg format) and click on the OK button. Your done. 


    3 - however, if you get the navigation window



    that indicates that  PS wants to save it as a PS formatted file.  You'll need to either select JPEG from the menu and save (top image) or click on the desktop in the Navigation window (bottom image) and save it to the desktop for importing as a new photo.


    This method will let iPhoto know that the photo has been editied and will update the thumbnail file to reflect the edit..


    NOTE: With Photoshop Elements  the Saving File preferences should be configured as shown:



    I also suggest the Maximize PSD File Compatabilty be set to Always.  In PSE’s General preference pane set the Color Picker to Apple as shown:



    Note:  to switch between iPhoto and PS or PSE as the editor of choice Control (right)-click on the thumbnail and select either Edit in iPhoto or Edit in External Editor from the contextual menu. If you use iPhoto to edit more than PSE re-select iPhoto in the iPhoto General preference pane. Then iPhoto will be the default editor and you can use the contextual menu to select PSE for your editor when desired.



  • MalcW Level 1 (30 points)

    Thanks everyone for their suggestions.


    Like I said the new iPhoto has been throwing up some strange behaviour and this appears to be one instant where it is - inconsistent.  Old Toad's suggestion whilst accurate may be irrelevant in this case for the simple reason that I have been doing this for years with no problem and PSE has in fact behaved itself remarkably well all that time.  This problem ( and others) have only appeared with the new iPhoto.


    The cache suggestion from Terence may be the answer.  Although some of my other weird behaviour has been cured by rebuilding the thumbnails.  It suggests a corrupted file somewhere which is probably the devil to find.  If this hadn't worked the second time I tried it I might have suspected a major bug.  But now that it has worked I'm leaning towards a corruption somewhere.  It could be the Cache.  Reading through the various forums other problems have been resolved by rebuilding the thumbnails.  Although some have found it has taken upwards of 3 re-builds to solve the problem.


    I'll keep you all posted.


    Thanks again

  • MalcW Level 1 (30 points)

    Incidentally, just for your info, double clicking the thumbnail in iPhoto simply opens the picture to full size.  Selecting the thumbnail and hitting the Enter key opens the photo in PSE.  This behaviour has always been like this.

  • Old Toad Level 10 (135,423 points)

    Selecting the thumbnail and hitting the Enter key opens the photo in PSE.

    True if you leave the iPhoto/Advanced preference set to PSE.




    If you set it back to iPhoto then the Enter key method will open the iPhoto edit.  If one does more editing in iPhoto and uses PSE/PS more infrequently setting it back to iPhoto speeds up the workflow a bit.