3 Replies Latest reply: Apr 5, 2013 2:08 PM by bfreeman3
bfreeman3 Level 1 (0 points)

I recently upgraded to the Verizon Fios 150/65 plan.  The order went through the same day.  I was able to connect to the Internet at speeds up to 100 mbps.  I was very happy.  Then the tech came and installed a new wireless modem/router (Red Actiontec with two antena), and my upgrade turned into a downgrade.


After the tech installed the new router, and set up a new wi-fi network, all my devices that connect via wi-fi (ipads, iphones, laptops) were humming.  After the tech left, however, I realized that my desktop iMac which connects via Ethernet could not connect at all.  The Network System Preferences window reads "Cable Unplugged".  I could connect via wi-fi, but only at about 5Mbps down.  When I unplug the ethernet cable from the back of my iMac, and plug it into a Macbook Pro, after a couple seconds, it connects with no problem, and at over 100Mbps.  My first guess was that the Macbook Pro, being a newer machine (2011), had some greater sensitivity than the older desktop machine (2010).  But then I tried with an even older Macbook (2009), and it was also able to quickly connect as well.


I have tried all four ports on the router.  No differences in results.  All machines are running the same OS 10.7.5.  After hours with Verizon support, and about an hour with Apple support yesterday, they all failed to help, and punted me to the Apple store.  Apple store this morning ran diagnostics on iMac and concluded everything working as it should.  Was able to connect to their network no problem.


Here's the stumper. When I move the iMac across the house and into the closet where the router is housed, and connect it via a short (10') cable, the computer sees the router and connects great, getting close to 150Mbps.  Obviously, I cannot keep my computer in the closet.  And I'm not willing to live with a 5Mbps wi-fi connection when I was getting 40Mbps before I started this whole process.  What can I do?


Why would my connection work on my two laptops and not the desktop?  Why would it work on all computers with a short cable, but only the laptops with a long cable?  Why was it working great before the router swap out, but not at all after?

  • Paul_31 Level 6 (13,655 points)

    Not optimistic this will help but it won't hurt to try. On the troublesome iMac:


  • Linc Davis Level 10 (192,724 points)

    At 100 MB/sec, you're pushing Gigabit Ethernet to its limits. You need a shielded CAT 6 cable in perfect condition, and not too long.


    Changing your DNS settings won't have the slightest effect and is not beneficial in any other way.

  • bfreeman3 Level 1 (0 points)

    I bought a 100' Cat 6 cable at Fry's today.  Ran it across my house and plugged it into the problem computer.  Instantly saw the router.  Speed test was 150/57.  Thank you Linc Davis!.  Guess I'll be rewiring my home. What I still don't understand is why I can connect the laptops to that same older cable and they do fine.  They are not performing at the same speed as the new cable, but they see they connect to the router easily and just did a speed test that came in at 94/59.  Regardless, problem solved.  Thanks.