10 Replies Latest reply: Sep 13, 2013 9:14 AM by inkflo
cyrano7 Level 1 (0 points)

I have a late 2009, 27 iMac, 10.8.3.


I use InDesign, and I have an Epson Workforce 600 all in one printer.


I cannot get the option of printing in draft or economy mode.


I do not get the option. I have perused all the variables, and the option to print in draft or ecomony just does not come up. This seems very strange, and from what I have been able to read online, it may be some problem with the OS and Epson.


I tried downloading the Epson drive, but it will not install. The Mac says the file is corrupt.


Any help out there?



iMac (27-inch Late 2009), OS X Mountain Lion (10.8.2)
  • MichelPM Level 6 (11,373 points)



    I always used Epson scanners and printers.

    Before you click print, do you use the print or page setup menu option, first?

    Instead of draft or economy names, do you have options that may be called speed print or quick print or fast print mode and a another option that states quality mode?

  • cyrano7 Level 1 (0 points)

    Hello, thanks.


    This is indeed infuriating.


    I go to page setup, and do A4, I am in Korea. That seems normal.


    I go to Printer > Media and Quality > and select PLAIN PAPER


    Then, my only options are on a slider scale, from Normal to Best.

    The scale will not move to Draft.


    My only options with plan papter, are on a sliding scale, from normal to best.



  • cyrano7 Level 1 (0 points)

    I found something called Epson EasyPrint from Epson site, and downloaded it, but my computer will not install it because it says "Installer can't be opened because it is from an unidentified developer. Your security preferences allow installation of only apps from the Mac App Store and identified developers."


    The program should be legit, it is from the Epson website.


    I do not know how to override the prohibition.



  • AnaMusic Level 9 (57,110 points)

    cyrano7 wrote:



    I do not know how to override the prohibition.




    See Here  >  http://support.apple.com/kb/HT5290


    And Here...



  • cyrano7 Level 1 (0 points)



    That is the second Epson download that has been blocked by the computer.


    I hesitate to pull rank on the Mac, but I trust the Epson website, I think.


    Could these Epson aps be too new?  They did not coordinate with Mac yet?


    Trust the Epson website?

  • AnaMusic Level 9 (57,110 points)

    Gatekeeper adds Security to your Mac.


    It is easy enough to Turn it Off when necessary.

  • cyrano7 Level 1 (0 points)

    A. Thanks.


    B. Do you have any ideas if downloading any of the Epson apps will magically solve my problem?


    My Epson does not print in draft or economy mode.

    I've tried to print from:

    InDesign, Acrobat, Word, Excel and in none of them do I get a choice of draft or economy.

    Any clues?

  • AnaMusic Level 9 (57,110 points)

    cyrano7 wrote:


    A. Thanks.


    You're Welcome


    cyrano7 wrote:


    B. Do you have any ideas if downloading any of the Epson apps will magically solve my problem?


    Sorry... not my Forte.


    Have you tried Epson Support...

  • AnaMusic Level 9 (57,110 points)
  • inkflo Level 1 (0 points)

    Are you using Firefox as a browser?

    I have been having this problem, and I have solved it very easily.

    In Firefox, click on help at the top of the page, then click troubleshooting information.

    There will be a box on the right hand side to reset Firefox. Click on this and once it has saved your bookmarks etc, you should find that the plain paper and economy settings will appear in the print menu.